Zensys.Programmer.Controls Namespace

Z-Wave Programmer reference library
Zensys.Programmer.Controls Namespace

Classes

Class | Description
ListDataView | ListDataView class. Implements the data bound ListView control.
TreeDataView | TreeDataView class. Implements data bound TreeView control.
© 2006-2008 Zensys A/S. All rights reserved.


ListDataView Class

ListDataView Class
Members See Also

ListDataView class. Implements the data bound ListView control.

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ListDataView : ListView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ListView
Zensys.Programmer.Controls..::.ListDataView

See Also

ListDataView Members
Zensys.Programmer.Controls Namespace


ListDataView Members

[image]

Z-Wave Programmer reference library
ListDataView Members
ListDataView Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The ListDataView type exposes the following members.

Constructors

Name | Description
ListDataView |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
ArrangeIcons | Overloaded.
AutoResizeColumn | Resizes the width of the given column as indicated by the resize style. (Inherited from ListView.)
AutoResizeColumns | Resizes the width of the columns as indicated by the resize style. (Inherited from ListView.)
BeginInvoke | Overloaded.
BeginUpdate | Prevents the control from drawing until the EndUpdate()()() method is called. (Inherited from ListView.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Clear | Removes all items and columns from the control. (Inherited from ListView.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Overrides CreateHandle()()(). (Inherited from ListView.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
EndUpdate | Resumes drawing of the list view control after drawing is suspended by the BeginUpdate()()() method. (Inherited from ListView.)
EnsureVisible | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary. (Inherited from ListView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindItemWithText | Overloaded.
FindNearestItem | Overloaded.
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetItemAt | Retrieves the item at the specified location. (Inherited from ListView.)
GetItemRect | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRow | Gets the row.
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HitTest | Overloaded.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from ListView.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAfterLabelEdit | Raises the AfterLabelEdit event. (Inherited from ListView.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from ListView.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBeforeLabelEdit | Raises the BeforeLabelEdit event. (Inherited from ListView.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCacheVirtualItems | Raises the CacheVirtualItems event. (Inherited from ListView.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnColumnClick | Raises the ColumnClick event. (Inherited from ListView.)
OnColumnReordered | Raises the ColumnReordered event. (Inherited from ListView.)
OnColumnWidthChanged | Raises the ColumnWidthChanged event. (Inherited from ListView.)
OnColumnWidthChanging | Raises the ColumnWidthChanging event. (Inherited from ListView.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() event. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnDrawColumnHeader | Raises the DrawColumnHeader event. (Inherited from ListView.)
OnDrawItem | Raises the DrawItem event. (Inherited from ListView.)
OnDrawSubItem | Raises the DrawSubItem event. (Inherited from ListView.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ListView.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from ListView.)
OnHandleDestroyed | (Inherited from ListView.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemActivate | Raises the ItemActivate event. (Inherited from ListView.)
OnItemCheck | Raises the ItemCheck event. (Inherited from ListView.)
OnItemChecked | Raises the ItemChecked event. (Inherited from ListView.)
OnItemDrag | Raises the ItemDrag event. (Inherited from ListView.)
OnItemMouseHover | Raises the ItemMouseHover event. (Inherited from ListView.)
OnItemSelectionChanged | Raises the ItemSelectionChanged event. (Inherited from ListView.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from ListView.)
OnMouseLeave | (Inherited from ListView.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ListView.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from ListView.)
OnRetrieveVirtualItem | Raises the RetrieveVirtualItem event. (Inherited from ListView.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from ListView.)
OnSearchForVirtualItem | Raises the SearchForVirtualItem event. (Inherited from ListView.)
OnSelectedIndexChanged | Raises the SelectedIndexChanged event. (Inherited from ListView.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from ListView.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVirtualItemsSelectionRangeChanged | Raises the VirtualItemsSelectionRangeChanged event. (Inherited from ListView.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RealizeProperties | Initializes the properties of the ListView control that manage the appearance of the control. (Inherited from ListView.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
RedrawItems | Forces a range of ListViewItem objects to be redrawn. (Inherited from ListView.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SelectNode | Selects the row.
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Sort | Sorts the items of the list view. (Inherited from ListView.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a string representation of the ListView control. (Inherited from ListView.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateExtendedStyles | Updates the extended styles applied to the list view control. (Inherited from ListView.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | Overrides WndProc(Message%). (Inherited from ListView.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Activation | Gets or sets the type of action the user must take to activate an item. (Inherited from ListView.)
Alignment | Gets or sets the alignment of items in the control. (Inherited from ListView.)
AllowColumnReorder | Gets or sets a value indicating whether the user can drag column headers to reorder columns in the control. (Inherited from ListView.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoArrange | Gets or sets whether icons are automatically kept arranged. (Inherited from ListView.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | Gets or sets the background color. (Inherited from ListView.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets an ImageLayout value. (Inherited from ListView.)
BackgroundImageTiled | Gets or sets a value indicating whether the background image of the ListView should be tiled. (Inherited from ListView.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border style of the control. (Inherited from ListView.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control. (Inherited from ListView.)
CheckedIndices | Gets the indexes of the currently checked items in the control. (Inherited from ListView.)
CheckedItems | Gets the currently checked items in the control. (Inherited from ListView.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Columns | Gets the collection of all column headers that appear in the control. (Inherited from ListView.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | This property is not relevant for this class. (Inherited from ListView.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSource | Gets or sets the Data Source.
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from ListView.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | (Inherited from ListView.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
FocusedItem | Gets the item in the control that currently has focus. (Inherited from ListView.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color. (Inherited from ListView.)
FullRowSelect | Gets or sets a value indicating whether clicking an item selects all its subitems. (Inherited from ListView.)
GridLines | Gets or sets a value indicating whether grid lines appear between the rows and columns containing the items and subitems in the control. (Inherited from ListView.)
Groups | Gets the collection of ListViewGroup objects assigned to the control. (Inherited from ListView.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
HeaderStyle | Gets or sets the column header style. (Inherited from ListView.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideSelection | Gets or sets a value indicating whether the selected item in the control remains highlighted when the control loses focus. (Inherited from ListView.)
HotTracking | Gets or sets a value indicating whether the text of an item or subitem has the appearance of a hyperlink when the mouse pointer passes over it. (Inherited from ListView.)
HoverSelection | Gets or sets a value indicating whether an item is automatically selected when the mouse pointer remains over the item for a few seconds. (Inherited from ListView.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InsertionMark | Gets an object used to indicate the expected drop location when an item is dragged within a ListView control. (Inherited from ListView.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Items | Gets a collection containing all items in the control. (Inherited from ListView.)
LabelEdit | Gets or sets a value indicating whether the user can edit the labels of items in the control. (Inherited from ListView.)
LabelWrap | Gets or sets a value indicating whether item labels wrap when items are displayed in the control as icons. (Inherited from ListView.)
LargeImageList | Gets or sets the ImageList to use when displaying items as large icons in the control. (Inherited from ListView.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
ListViewItemSorter | Gets or sets the sorting comparer for the control. (Inherited from ListView.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MultiSelect | Gets or sets a value indicating whether multiple items can be selected. (Inherited from ListView.)
Name | Gets or sets the name of the control. (Inherited from Control.)
OwnerDraw | Gets or sets a value indicating whether the ListView control is drawn by the operating system or by code that you provide. (Inherited from ListView.)
Padding | Gets or sets the space between the ListView control and its contents. (Inherited from ListView.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether the control is laid out from right to left. (Inherited from ListView.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Scrollable | Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items. (Inherited from ListView.)
SelectedIndices | Gets the indexes of the selected items in the control. (Inherited from ListView.)
SelectedItems | Gets the items that are selected in the control. (Inherited from ListView.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowGroups | Gets or sets a value indicating whether items are displayed in groups. (Inherited from ListView.)
ShowItemToolTips | Gets or sets a value indicating whether ToolTips are shown for the ListViewItem objects contained in the ListView. (Inherited from ListView.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
SmallImageList | Gets or sets the ImageList to use when displaying items as small icons in the control. (Inherited from ListView.)
Sorting | Gets or sets the sort order for items in the control. (Inherited from ListView.)
StateImageList | Gets or sets the ImageList associated with application-defined states in the control. (Inherited from ListView.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | This property is not relevant for this class. (Inherited from ListView.)
TileSize | Gets or sets the size of the tiles shown in tile view. (Inherited from ListView.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopItem | Gets or sets the first visible item in the control. (Inherited from ListView.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCompatibleStateImageBehavior | (Inherited from ListView.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
View | Gets or sets how items are displayed in the control. (Inherited from ListView.)
VirtualListSize | Gets or sets the number of ListViewItem objects contained in the item cache when in virtual mode. (Inherited from ListView.)
VirtualMode | Gets or sets a value indicating whether you have provided your own data-management operations for the ListView control. (Inherited from ListView.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AfterLabelEdit | Occurs when the label for an item is edited by the user. (Inherited from ListView.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListView.)
BeforeLabelEdit | Occurs when the user starts editing the label of an item. (Inherited from ListView.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CacheVirtualItems | Occurs when the contents of the display area for a ListView in virtual mode has changed, and the ListView determines that a new range of items is needed. (Inherited from ListView.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ColumnClick | Occurs when the user clicks a column header within the list view control. (Inherited from ListView.)
ColumnReordered | Occurs when the column header order is changed. (Inherited from ListView.)
ColumnWidthChanged | Occurs after the width of a column is successfully changed. (Inherited from ListView.)
ColumnWidthChanging | Occurs when the width of a column is changing. (Inherited from ListView.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
DrawColumnHeader | Occurs when the details view of a ListView is drawn and the OwnerDraw property is set to true. (Inherited from ListView.)
DrawItem | Occurs when a ListView is drawn and the OwnerDraw property is set to true. (Inherited from ListView.)
DrawSubItem | Occurs when the details view of a ListView is drawn and the OwnerDraw property is set to true. (Inherited from ListView.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemActivate | Occurs when an item is activated. (Inherited from ListView.)
ItemCheck | Occurs when the check state of an item changes. (Inherited from ListView.)
ItemChecked | Occurs when the checked state of an item changes. (Inherited from ListView.)
ItemDrag | Occurs when the user begins dragging an item. (Inherited from ListView.)
ItemMouseHover | Occurs when the mouse hovers over an item. (Inherited from ListView.)
ItemSelectionChanged | Occurs when the selection state of an item changes. (Inherited from ListView.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListView.)
Paint | Occurs when the ListView control is painted. (Inherited from ListView.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RetrieveVirtualItem | Occurs when the ListView is in virtual mode and requires a ListViewItem. (Inherited from ListView.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from ListView.)
SearchForVirtualItem | Occurs when the ListView is in virtual mode and a search is taking place. (Inherited from ListView.)
SelectedIndexChanged | Occurs when the index of the selected item in the list view control changes. (Inherited from ListView.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property changes. (Inherited from ListView.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VirtualItemsSelectionRangeChanged | Occurs when a ListView is in virtual mode and the selection state of a range of items has changed. (Inherited from ListView.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ListDataView Class
Zensys.Programmer.Controls Namespace


ListDataView Constructor

ListDataView Constructor
ListDataView Class See Also

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ListDataView()

See Also

ListDataView Class
Zensys.Programmer.Controls Namespace


ListDataView Methods

[image]

Z-Wave Programmer reference library
ListDataView Methods
ListDataView Class See Also

The ListDataView type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
ArrangeIcons | Overloaded.
AutoResizeColumn | Resizes the width of the given column as indicated by the resize style. (Inherited from ListView.)
AutoResizeColumns | Resizes the width of the columns as indicated by the resize style. (Inherited from ListView.)
BeginInvoke | Overloaded.
BeginUpdate | Prevents the control from drawing until the EndUpdate()()() method is called. (Inherited from ListView.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Clear | Removes all items and columns from the control. (Inherited from ListView.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Overrides CreateHandle()()(). (Inherited from ListView.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
EndUpdate | Resumes drawing of the list view control after drawing is suspended by the BeginUpdate()()() method. (Inherited from ListView.)
EnsureVisible | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary. (Inherited from ListView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindItemWithText | Overloaded.
FindNearestItem | Overloaded.
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetItemAt | Retrieves the item at the specified location. (Inherited from ListView.)
GetItemRect | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRow | Gets the row.
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HitTest | Overloaded.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | (Inherited from ListView.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAfterLabelEdit | Raises the AfterLabelEdit event. (Inherited from ListView.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from ListView.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBeforeLabelEdit | Raises the BeforeLabelEdit event. (Inherited from ListView.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCacheVirtualItems | Raises the CacheVirtualItems event. (Inherited from ListView.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnColumnClick | Raises the ColumnClick event. (Inherited from ListView.)
OnColumnReordered | Raises the ColumnReordered event. (Inherited from ListView.)
OnColumnWidthChanged | Raises the ColumnWidthChanged event. (Inherited from ListView.)
OnColumnWidthChanging | Raises the ColumnWidthChanging event. (Inherited from ListView.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() event. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnDrawColumnHeader | Raises the DrawColumnHeader event. (Inherited from ListView.)
OnDrawItem | Raises the DrawItem event. (Inherited from ListView.)
OnDrawSubItem | Raises the DrawSubItem event. (Inherited from ListView.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ListView.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from ListView.)
OnHandleDestroyed | (Inherited from ListView.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemActivate | Raises the ItemActivate event. (Inherited from ListView.)
OnItemCheck | Raises the ItemCheck event. (Inherited from ListView.)
OnItemChecked | Raises the ItemChecked event. (Inherited from ListView.)
OnItemDrag | Raises the ItemDrag event. (Inherited from ListView.)
OnItemMouseHover | Raises the ItemMouseHover event. (Inherited from ListView.)
OnItemSelectionChanged | Raises the ItemSelectionChanged event. (Inherited from ListView.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from ListView.)
OnMouseLeave | (Inherited from ListView.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ListView.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from ListView.)
OnRetrieveVirtualItem | Raises the RetrieveVirtualItem event. (Inherited from ListView.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from ListView.)
OnSearchForVirtualItem | Raises the SearchForVirtualItem event. (Inherited from ListView.)
OnSelectedIndexChanged | Raises the SelectedIndexChanged event. (Inherited from ListView.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | (Inherited from ListView.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVirtualItemsSelectionRangeChanged | Raises the VirtualItemsSelectionRangeChanged event. (Inherited from ListView.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RealizeProperties | Initializes the properties of the ListView control that manage the appearance of the control. (Inherited from ListView.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
RedrawItems | Forces a range of ListViewItem objects to be redrawn. (Inherited from ListView.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SelectNode | Selects the row.
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Sort | Sorts the items of the list view. (Inherited from ListView.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a string representation of the ListView control. (Inherited from ListView.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateExtendedStyles | Updates the extended styles applied to the list view control. (Inherited from ListView.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | Overrides WndProc(Message%). (Inherited from ListView.)

Explicit Interface Implementations

Name | Description
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ListDataView Class
Zensys.Programmer.Controls Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
ListDataView..::.AccessibilityNotifyClients Method
ListDataView Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


ArrangeIcons Method

[image]

Z-Wave Programmer reference library
ListDataView..::.ArrangeIcons Method
ListDataView Class See Also

Overload List

Name | Description
ArrangeIcons()()() | Arranges items in the control when they are displayed as icons based on the value of the Alignment property. (Inherited from ListView.)
ArrangeIcons(ListViewAlignment) | Arranges items in the control when they are displayed as icons with a specified alignment setting. (Inherited from ListView.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
ListDataView..::.BeginInvoke Method
ListDataView Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
ListDataView..::.Dispose Method
ListDataView Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the ListView and optionally releases the managed resources. (Inherited from ListView.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


FindItemWithText Method

[image]

Z-Wave Programmer reference library
ListDataView..::.FindItemWithText Method
ListDataView Class See Also

Overload List

Name | Description
FindItemWithText(String) | Finds the first ListViewItem that begins with the specified text value. (Inherited from ListView.)
FindItemWithText(String, Boolean, Int32) | Finds the first ListViewItem or ListViewItem..::.ListViewSubItem, if indicated, that begins with the specified text value. The search starts at the specified index. (Inherited from ListView.)
FindItemWithText(String, Boolean, Int32, Boolean) | Finds the first ListViewItem or ListViewItem..::.ListViewSubItem, if indicated, that begins with the specified text value. The search starts at the specified index. (Inherited from ListView.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


FindNearestItem Method

[image]

Z-Wave Programmer reference library
ListDataView..::.FindNearestItem Method
ListDataView Class See Also

Overload List

Name | Description
FindNearestItem(SearchDirectionHint, Point) | Finds the next item from the given point, searching in the specified direction (Inherited from ListView.)
FindNearestItem(SearchDirectionHint, Int32, Int32) | Finds the next item from the given x- and y-coordinates, searching in the specified direction. (Inherited from ListView.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
ListDataView..::.GetChildAtPoint Method
ListDataView Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


GetItemRect Method

[image]

Z-Wave Programmer reference library
ListDataView..::.GetItemRect Method
ListDataView Class See Also

Overload List

Name | Description
GetItemRect(Int32) | Retrieves the bounding rectangle for a specific item within the list view control. (Inherited from ListView.)
GetItemRect(Int32, ItemBoundsPortion) | Retrieves the specified portion of the bounding rectangle for a specific item within the list view control. (Inherited from ListView.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


GetRow Method

ListDataView..::.GetRow Method
ListDataView Class See Also

Gets the row.

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public LogSession GetRow(
    ListViewItem item
)

Parameters

item
Type: System.Windows.Forms..::.ListViewItem
The item.

Return Value

See Also

ListDataView Class
Zensys.Programmer.Controls Namespace


HitTest Method

[image]

Z-Wave Programmer reference library
ListDataView..::.HitTest Method
ListDataView Class See Also

Overload List

Name | Description
HitTest(Point) | Provides item information, given a point. (Inherited from ListView.)
HitTest(Int32, Int32) | Provides item information, given x- and y-coordinates. (Inherited from ListView.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
ListDataView..::.Invalidate Method
ListDataView Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
ListDataView..::.Invoke Method
ListDataView Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
ListDataView..::.MemberwiseClone Method
ListDataView Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
ListDataView..::.PerformLayout Method
ListDataView Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
ListDataView..::.ResumeLayout Method
ListDataView Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
ListDataView..::.RtlTranslateAlignment Method
ListDataView Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


Scale Method

[image]

Z-Wave Programmer reference library
ListDataView..::.Scale Method
ListDataView Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


Select Method

[image]

Z-Wave Programmer reference library
ListDataView..::.Select Method
ListDataView Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


SelectNode Method

ListDataView..::.SelectNode Method
ListDataView Class See Also

Selects the row.

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void SelectNode(
    Guid UID
)

Parameters

UID
Type: System..::.Guid
The UID.

See Also

ListDataView Class
Zensys.Programmer.Controls Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
ListDataView..::.SetBounds Method
ListDataView Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
ListDataView..::.UpdateBounds Method
ListDataView Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ListDataView Class
ListDataView Members
Zensys.Programmer.Controls Namespace


ListDataView Properties

[image]

Z-Wave Programmer reference library
ListDataView Properties
ListDataView Class See Also

The ListDataView type exposes the following properties.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Activation | Gets or sets the type of action the user must take to activate an item. (Inherited from ListView.)
Alignment | Gets or sets the alignment of items in the control. (Inherited from ListView.)
AllowColumnReorder | Gets or sets a value indicating whether the user can drag column headers to reorder columns in the control. (Inherited from ListView.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoArrange | Gets or sets whether icons are automatically kept arranged. (Inherited from ListView.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | Gets or sets the background color. (Inherited from ListView.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets an ImageLayout value. (Inherited from ListView.)
BackgroundImageTiled | Gets or sets a value indicating whether the background image of the ListView should be tiled. (Inherited from ListView.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border style of the control. (Inherited from ListView.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control. (Inherited from ListView.)
CheckedIndices | Gets the indexes of the currently checked items in the control. (Inherited from ListView.)
CheckedItems | Gets the currently checked items in the control. (Inherited from ListView.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Columns | Gets the collection of all column headers that appear in the control. (Inherited from ListView.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | This property is not relevant for this class. (Inherited from ListView.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSource | Gets or sets the Data Source.
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from ListView.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | (Inherited from ListView.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
FocusedItem | Gets the item in the control that currently has focus. (Inherited from ListView.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color. (Inherited from ListView.)
FullRowSelect | Gets or sets a value indicating whether clicking an item selects all its subitems. (Inherited from ListView.)
GridLines | Gets or sets a value indicating whether grid lines appear between the rows and columns containing the items and subitems in the control. (Inherited from ListView.)
Groups | Gets the collection of ListViewGroup objects assigned to the control. (Inherited from ListView.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
HeaderStyle | Gets or sets the column header style. (Inherited from ListView.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideSelection | Gets or sets a value indicating whether the selected item in the control remains highlighted when the control loses focus. (Inherited from ListView.)
HotTracking | Gets or sets a value indicating whether the text of an item or subitem has the appearance of a hyperlink when the mouse pointer passes over it. (Inherited from ListView.)
HoverSelection | Gets or sets a value indicating whether an item is automatically selected when the mouse pointer remains over the item for a few seconds. (Inherited from ListView.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InsertionMark | Gets an object used to indicate the expected drop location when an item is dragged within a ListView control. (Inherited from ListView.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Items | Gets a collection containing all items in the control. (Inherited from ListView.)
LabelEdit | Gets or sets a value indicating whether the user can edit the labels of items in the control. (Inherited from ListView.)
LabelWrap | Gets or sets a value indicating whether item labels wrap when items are displayed in the control as icons. (Inherited from ListView.)
LargeImageList | Gets or sets the ImageList to use when displaying items as large icons in the control. (Inherited from ListView.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
ListViewItemSorter | Gets or sets the sorting comparer for the control. (Inherited from ListView.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MultiSelect | Gets or sets a value indicating whether multiple items can be selected. (Inherited from ListView.)
Name | Gets or sets the name of the control. (Inherited from Control.)
OwnerDraw | Gets or sets a value indicating whether the ListView control is drawn by the operating system or by code that you provide. (Inherited from ListView.)
Padding | Gets or sets the space between the ListView control and its contents. (Inherited from ListView.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether the control is laid out from right to left. (Inherited from ListView.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Scrollable | Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items. (Inherited from ListView.)
SelectedIndices | Gets the indexes of the selected items in the control. (Inherited from ListView.)
SelectedItems | Gets the items that are selected in the control. (Inherited from ListView.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowGroups | Gets or sets a value indicating whether items are displayed in groups. (Inherited from ListView.)
ShowItemToolTips | Gets or sets a value indicating whether ToolTips are shown for the ListViewItem objects contained in the ListView. (Inherited from ListView.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
SmallImageList | Gets or sets the ImageList to use when displaying items as small icons in the control. (Inherited from ListView.)
Sorting | Gets or sets the sort order for items in the control. (Inherited from ListView.)
StateImageList | Gets or sets the ImageList associated with application-defined states in the control. (Inherited from ListView.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | This property is not relevant for this class. (Inherited from ListView.)
TileSize | Gets or sets the size of the tiles shown in tile view. (Inherited from ListView.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopItem | Gets or sets the first visible item in the control. (Inherited from ListView.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCompatibleStateImageBehavior | (Inherited from ListView.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
View | Gets or sets how items are displayed in the control. (Inherited from ListView.)
VirtualListSize | Gets or sets the number of ListViewItem objects contained in the item cache when in virtual mode. (Inherited from ListView.)
VirtualMode | Gets or sets a value indicating whether you have provided your own data-management operations for the ListView control. (Inherited from ListView.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ListDataView Class
Zensys.Programmer.Controls Namespace


DataSource Property

ListDataView..::.DataSource Property
ListDataView Class See Also

Gets or sets the Data Source.

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public LogDataSource DataSource { get; set; }

Field Value

The Data Source.

See Also

ListDataView Class
Zensys.Programmer.Controls Namespace


TreeDataView Class

TreeDataView Class
Members See Also

TreeDataView class. Implements data bound TreeView control.

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class TreeDataView : TreeView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.TreeView
Zensys.Programmer.Controls..::.TreeDataView

See Also

TreeDataView Members
Zensys.Programmer.Controls Namespace


TreeDataView Members

[image]

Z-Wave Programmer reference library
TreeDataView Members
TreeDataView Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The TreeDataView type exposes the following members.

Constructors

Name | Description
TreeDataView |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BeginUpdate | Disables any redrawing of the tree view. (Inherited from TreeView.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CollapseAll | Collapses all the tree nodes. (Inherited from TreeView.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | (Inherited from TreeView.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
EndUpdate | Enables the redrawing of the tree view. (Inherited from TreeView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandAll | Expands all the tree nodes. (Inherited from TreeView.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetItemRenderStyles | Returns an OwnerDrawPropertyBag for the specified TreeNode. (Inherited from TreeView.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetNodeAt | Overloaded.
GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from TreeView.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRow | Gets the row.
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HitTest | Overloaded.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from TreeView.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAfterCheck | Raises the AfterCheck event. (Inherited from TreeView.)
OnAfterCollapse | Raises the AfterCollapse event. (Inherited from TreeView.)
OnAfterExpand | Raises the AfterExpand event. (Inherited from TreeView.)
OnAfterLabelEdit | Raises the AfterLabelEdit event. (Inherited from TreeView.)
OnAfterSelect | Raises the AfterSelect event. (Overrides TreeView..::.OnAfterSelect(TreeViewEventArgs).)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBeforeCheck | Raises the BeforeCheck event. (Inherited from TreeView.)
OnBeforeCollapse | Raises the BeforeCollapse event. (Inherited from TreeView.)
OnBeforeExpand | Raises the BeforeExpand event. (Inherited from TreeView.)
OnBeforeLabelEdit | Raises the BeforeLabelEdit event. (Inherited from TreeView.)
OnBeforeSelect | Raises the BeforeSelect event. (Inherited from TreeView.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() event. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnDrawNode | Raises the DrawNode event. (Inherited from TreeView.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Overrides OnHandleCreated(EventArgs). (Inherited from TreeView.)
OnHandleDestroyed | Overrides OnHandleDestroyed(EventArgs). (Inherited from TreeView.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemDrag | Raises the ItemDrag event. (Inherited from TreeView.)
OnKeyDown | Raises the KeyDown event. (Inherited from TreeView.)
OnKeyPress | Raises the KeyPress event. (Inherited from TreeView.)
OnKeyUp | Overrides OnKeyUp(KeyEventArgs). (Inherited from TreeView.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from TreeView.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from TreeView.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNodeMouseClick | Raises the NodeMouseClick event. (Inherited from TreeView.)
OnNodeMouseDoubleClick | Raises the NodeMouseDoubleClick event. (Inherited from TreeView.)
OnNodeMouseHover | Raises the NodeMouseHover event. (Inherited from TreeView.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from TreeView.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SelectNode | Selects the node.
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Sort | Sorts the items if the value of the TreeViewNodeSorter property is not null. (Inherited from TreeView.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Overrides ToString()()(). (Inherited from TreeView.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | Overrides WndProc(Message%). (Inherited from TreeView.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | (Inherited from TreeView.)
BackgroundImage | Gets or set the background image for the TreeView control. (Inherited from TreeView.)
BackgroundImageLayout | Gets or sets the layout of the background image for the TreeView control. (Inherited from TreeView.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from TreeView.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. (Inherited from TreeView.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | Overrides CreateParams. (Inherited from TreeView.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSource | Gets or sets the data source.
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from TreeView.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer. The DoubleBuffered property has no effect on the TreeView control. (Inherited from TreeView.)
DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from TreeView.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | The current foreground color for this control, which is the color the control uses to draw its text. (Inherited from TreeView.)
FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from TreeView.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from TreeView.)
HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from TreeView.)
ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from TreeView.)
ImageKey | Gets or sets the key of the default image for each node in the TreeView control when it is in an unselected state. (Inherited from TreeView.)
ImageList | Gets or sets the ImageList that contains the Image objects used by the tree nodes. (Inherited from TreeView.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Indent | Gets or sets the distance to indent each of the child tree node levels. (Inherited from TreeView.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from TreeView.)
LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from TreeView.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LineColor | Gets or sets the color of the lines connecting the nodes of the TreeView control. (Inherited from TreeView.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from TreeView.)
Padding | Gets or sets the spacing between the TreeView control's contents and its edges. (Inherited from TreeView.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from TreeView.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether the TreeView should be laid out from right-to-left. (Inherited from TreeView.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from TreeView.)
SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from TreeView.)
SelectedImageKey | Gets or sets the key of the default image shown when a TreeNode is in a selected state. (Inherited from TreeView.)
SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from TreeView.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from TreeView.)
ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a TreeNode. (Inherited from TreeView.)
ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from TreeView.)
ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from TreeView.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted. (Inherited from TreeView.)
StateImageList | Gets or sets the image list used for indicating the state of the TreeView and its nodes. (Inherited from TreeView.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text of the TreeView. (Inherited from TreeView.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopNode | Gets the first fully-visible tree node in the tree view control. (Inherited from TreeView.)
TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes. (Inherited from TreeView.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from TreeView.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AfterCheck | Occurs after the tree node check box is checked. (Inherited from TreeView.)
AfterCollapse | Occurs after the tree node is collapsed. (Inherited from TreeView.)
AfterExpand | Occurs after the tree node is expanded. (Inherited from TreeView.)
AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from TreeView.)
AfterSelect | Occurs after the tree node is selected. (Inherited from TreeView.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from TreeView.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from TreeView.)
BeforeCheck | Occurs before the tree node check box is checked. (Inherited from TreeView.)
BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from TreeView.)
BeforeExpand | Occurs before the tree node is expanded. (Inherited from TreeView.)
BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from TreeView.)
BeforeSelect | Occurs before the tree node is selected. (Inherited from TreeView.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
DrawNode | Occurs when a TreeView is drawn and the DrawMode property is set to a TreeViewDrawMode value other than Normal. (Inherited from TreeView.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemDrag | Occurs when the user begins dragging a node. (Inherited from TreeView.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse. (Inherited from TreeView.)
NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse. (Inherited from TreeView.)
NodeMouseHover | Occurs when the mouse hovers over a TreeNode. (Inherited from TreeView.)
PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from TreeView.)
Paint | Occurs when the TreeView is drawn. (Inherited from TreeView.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TreeView.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property changes. (Inherited from TreeView.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TreeDataView Class
Zensys.Programmer.Controls Namespace


TreeDataView Constructor

TreeDataView Constructor
TreeDataView Class See Also

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public TreeDataView()

See Also

TreeDataView Class
Zensys.Programmer.Controls Namespace


TreeDataView Methods

[image]

Z-Wave Programmer reference library
TreeDataView Methods
TreeDataView Class See Also

The TreeDataView type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BeginUpdate | Disables any redrawing of the tree view. (Inherited from TreeView.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CollapseAll | Collapses all the tree nodes. (Inherited from TreeView.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | (Inherited from TreeView.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
EndUpdate | Enables the redrawing of the tree view. (Inherited from TreeView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandAll | Expands all the tree nodes. (Inherited from TreeView.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetItemRenderStyles | Returns an OwnerDrawPropertyBag for the specified TreeNode. (Inherited from TreeView.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetNodeAt | Overloaded.
GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from TreeView.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRow | Gets the row.
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HitTest | Overloaded.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from TreeView.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAfterCheck | Raises the AfterCheck event. (Inherited from TreeView.)
OnAfterCollapse | Raises the AfterCollapse event. (Inherited from TreeView.)
OnAfterExpand | Raises the AfterExpand event. (Inherited from TreeView.)
OnAfterLabelEdit | Raises the AfterLabelEdit event. (Inherited from TreeView.)
OnAfterSelect | Raises the AfterSelect event. (Overrides TreeView..::.OnAfterSelect(TreeViewEventArgs).)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBeforeCheck | Raises the BeforeCheck event. (Inherited from TreeView.)
OnBeforeCollapse | Raises the BeforeCollapse event. (Inherited from TreeView.)
OnBeforeExpand | Raises the BeforeExpand event. (Inherited from TreeView.)
OnBeforeLabelEdit | Raises the BeforeLabelEdit event. (Inherited from TreeView.)
OnBeforeSelect | Raises the BeforeSelect event. (Inherited from TreeView.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() event. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnDrawNode | Raises the DrawNode event. (Inherited from TreeView.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Overrides OnHandleCreated(EventArgs). (Inherited from TreeView.)
OnHandleDestroyed | Overrides OnHandleDestroyed(EventArgs). (Inherited from TreeView.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemDrag | Raises the ItemDrag event. (Inherited from TreeView.)
OnKeyDown | Raises the KeyDown event. (Inherited from TreeView.)
OnKeyPress | Raises the KeyPress event. (Inherited from TreeView.)
OnKeyUp | Overrides OnKeyUp(KeyEventArgs). (Inherited from TreeView.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from TreeView.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from TreeView.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNodeMouseClick | Raises the NodeMouseClick event. (Inherited from TreeView.)
OnNodeMouseDoubleClick | Raises the NodeMouseDoubleClick event. (Inherited from TreeView.)
OnNodeMouseHover | Raises the NodeMouseHover event. (Inherited from TreeView.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from TreeView.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SelectNode | Selects the node.
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Sort | Sorts the items if the value of the TreeViewNodeSorter property is not null. (Inherited from TreeView.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Overrides ToString()()(). (Inherited from TreeView.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | Overrides WndProc(Message%). (Inherited from TreeView.)

Explicit Interface Implementations

Name | Description
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TreeDataView Class
Zensys.Programmer.Controls Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.AccessibilityNotifyClients Method
TreeDataView Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.BeginInvoke Method
TreeDataView Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.Dispose Method
TreeDataView Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the TreeView and optionally releases the managed resources. (Inherited from TreeView.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.GetChildAtPoint Method
TreeDataView Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


GetNodeAt Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.GetNodeAt Method
TreeDataView Class See Also

Overload List

Name | Description
GetNodeAt(Point) | Retrieves the tree node that is at the specified point. (Inherited from TreeView.)
GetNodeAt(Int32, Int32) | Retrieves the tree node at the point with the specified coordinates. (Inherited from TreeView.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


GetRow Method

TreeDataView..::.GetRow Method
TreeDataView Class See Also

Gets the row.

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public LogSession GetRow(
    TreeNode treeNode
)

Parameters

treeNode
Type: System.Windows.Forms..::.TreeNode
The tree node.

Return Value

See Also

TreeDataView Class
Zensys.Programmer.Controls Namespace


HitTest Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.HitTest Method
TreeDataView Class See Also

Overload List

Name | Description
HitTest(Point) | Provides node information, given a point. (Inherited from TreeView.)
HitTest(Int32, Int32) | Provides node information, given x- and y-coordinates. (Inherited from TreeView.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.Invalidate Method
TreeDataView Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.Invoke Method
TreeDataView Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.MemberwiseClone Method
TreeDataView Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


OnAfterSelect Method

TreeDataView..::.OnAfterSelect Method
TreeDataView Class See Also

Raises the AfterSelect event.

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void OnAfterSelect(
    TreeViewEventArgs e
)

Parameters

e
Type: System.Windows.Forms..::.TreeViewEventArgs
A TreeViewEventArgs that contains the event data.

See Also

TreeDataView Class
Zensys.Programmer.Controls Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.PerformLayout Method
TreeDataView Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.ResumeLayout Method
TreeDataView Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.RtlTranslateAlignment Method
TreeDataView Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


Scale Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.Scale Method
TreeDataView Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


Select Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.Select Method
TreeDataView Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


SelectNode Method

TreeDataView..::.SelectNode Method
TreeDataView Class See Also

Selects the node.

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void SelectNode(
    Guid UID
)

Parameters

UID
Type: System..::.Guid
The UID.

See Also

TreeDataView Class
Zensys.Programmer.Controls Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.SetBounds Method
TreeDataView Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
TreeDataView..::.UpdateBounds Method
TreeDataView Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TreeDataView Class
TreeDataView Members
Zensys.Programmer.Controls Namespace


TreeDataView Properties

[image]

Z-Wave Programmer reference library
TreeDataView Properties
TreeDataView Class See Also

The TreeDataView type exposes the following properties.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | (Inherited from TreeView.)
BackgroundImage | Gets or set the background image for the TreeView control. (Inherited from TreeView.)
BackgroundImageLayout | Gets or sets the layout of the background image for the TreeView control. (Inherited from TreeView.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from TreeView.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. (Inherited from TreeView.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | Overrides CreateParams. (Inherited from TreeView.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSource | Gets or sets the data source.
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from TreeView.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer. The DoubleBuffered property has no effect on the TreeView control. (Inherited from TreeView.)
DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from TreeView.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | The current foreground color for this control, which is the color the control uses to draw its text. (Inherited from TreeView.)
FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from TreeView.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from TreeView.)
HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from TreeView.)
ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from TreeView.)
ImageKey | Gets or sets the key of the default image for each node in the TreeView control when it is in an unselected state. (Inherited from TreeView.)
ImageList | Gets or sets the ImageList that contains the Image objects used by the tree nodes. (Inherited from TreeView.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Indent | Gets or sets the distance to indent each of the child tree node levels. (Inherited from TreeView.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from TreeView.)
LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from TreeView.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LineColor | Gets or sets the color of the lines connecting the nodes of the TreeView control. (Inherited from TreeView.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from TreeView.)
Padding | Gets or sets the spacing between the TreeView control's contents and its edges. (Inherited from TreeView.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from TreeView.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether the TreeView should be laid out from right-to-left. (Inherited from TreeView.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from TreeView.)
SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from TreeView.)
SelectedImageKey | Gets or sets the key of the default image shown when a TreeNode is in a selected state. (Inherited from TreeView.)
SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from TreeView.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from TreeView.)
ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a TreeNode. (Inherited from TreeView.)
ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from TreeView.)
ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from TreeView.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted. (Inherited from TreeView.)
StateImageList | Gets or sets the image list used for indicating the state of the TreeView and its nodes. (Inherited from TreeView.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text of the TreeView. (Inherited from TreeView.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopNode | Gets the first fully-visible tree node in the tree view control. (Inherited from TreeView.)
TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes. (Inherited from TreeView.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from TreeView.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

TreeDataView Class
Zensys.Programmer.Controls Namespace


DataSource Property

TreeDataView..::.DataSource Property
TreeDataView Class See Also

Gets or sets the data source.

Namespace: Zensys.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public LogDataSource DataSource { get; set; }

Field Value

The data source.

See Also

TreeDataView Class
Zensys.Programmer.Controls Namespace


Zensys.Programmer.Interfaces Namespace

Zensys.Programmer.Interfaces Namespace

Interfaces

Interface | Description
IDockingView | IDockingView interface.
IView | IView interface.
IViewDispatcher | Defines methods for binding views (windows forms) and controller extentions BaseAction


IDockingView Interface

IDockingView Interface
Members See Also

IDockingView interface.

Namespace: Zensys.Programmer.Interfaces
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public interface IDockingView

See Also

IDockingView Members
Zensys.Programmer.Interfaces Namespace


IDockingView Members

[image]

Z-Wave Programmer reference library
IDockingView Members
IDockingView Interface Properties See Also

The IDockingView type exposes the following members.

Properties

Name | Description
ViewContainer | Gets or sets the form.

See Also

IDockingView Interface
Zensys.Programmer.Interfaces Namespace


IDockingView Properties

[image]

Z-Wave Programmer reference library
IDockingView Properties
IDockingView Interface See Also

The IDockingView type exposes the following properties.

Properties

Name | Description
ViewContainer | Gets or sets the form.

See Also

IDockingView Interface
Zensys.Programmer.Interfaces Namespace


ViewContainer Property

IDockingView..::.ViewContainer Property
IDockingView Interface See Also

Gets or sets the form.

Namespace: Zensys.Programmer.Interfaces
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
Form ViewContainer { get; }

Field Value

The form.

See Also

IDockingView Interface
Zensys.Programmer.Interfaces Namespace


IView Interface

IView Interface
Members See Also

IView interface.

Namespace: Zensys.Programmer.Interfaces
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public interface IView

See Also

IView Members
Zensys.Programmer.Interfaces Namespace


IView Members

[image]

Z-Wave Programmer reference library
IView Members
IView Interface Properties See Also

The IView type exposes the following members.

Properties

Name | Description
DockStyle | Gets or sets the dock style.
ViewContainer | Gets or sets the form.

See Also

IView Interface
Zensys.Programmer.Interfaces Namespace


IView Properties

[image]

Z-Wave Programmer reference library
IView Properties
IView Interface See Also

The IView type exposes the following properties.

Properties

Name | Description
DockStyle | Gets or sets the dock style.
ViewContainer | Gets or sets the form.

See Also

IView Interface
Zensys.Programmer.Interfaces Namespace


DockStyle Property

IView..::.DockStyle Property
IView Interface See Also

Gets or sets the dock style.

Namespace: Zensys.Programmer.Interfaces
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
DockStyle DockStyle { get; set; }

Field Value

The dock style.

See Also

IView Interface
Zensys.Programmer.Interfaces Namespace


ViewContainer Property

IView..::.ViewContainer Property
IView Interface See Also

Gets or sets the form.

Namespace: Zensys.Programmer.Interfaces
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
Form ViewContainer { get; }

Field Value

The form.

See Also

IView Interface
Zensys.Programmer.Interfaces Namespace


IViewDispatcher Interface

IViewDispatcher Interface
Members See Also

Defines methods for binding views (windows forms) and controller extentions BaseAction

Namespace: Zensys.Programmer.Interfaces
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public interface IViewDispatcher

See Also

IViewDispatcher Members
Zensys.Programmer.Interfaces Namespace


IViewDispatcher Members

[image]

Z-Wave Programmer reference library
IViewDispatcher Members
IViewDispatcher Interface Methods See Also

The IViewDispatcher type exposes the following members.

Methods

Name | Description
Bind | Binds the specified view.
Drop | Drops the specified view.

See Also

IViewDispatcher Interface
Zensys.Programmer.Interfaces Namespace


IViewDispatcher Methods

[image]

Z-Wave Programmer reference library
IViewDispatcher Methods
IViewDispatcher Interface See Also

The IViewDispatcher type exposes the following methods.

Methods

Name | Description
Bind | Binds the specified view.
Drop | Drops the specified view.

See Also

IViewDispatcher Interface
Zensys.Programmer.Interfaces Namespace


Bind Method

IViewDispatcher..::.Bind Method
IViewDispatcher Interface See Also

Binds the specified view.

Namespace: Zensys.Programmer.Interfaces
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
void Bind(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions.

See Also

IViewDispatcher Interface
Zensys.Programmer.Interfaces Namespace


Drop Method

IViewDispatcher..::.Drop Method
IViewDispatcher Interface See Also

Drops the specified view.

Namespace: Zensys.Programmer.Interfaces
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
void Drop(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions.

See Also

IViewDispatcher Interface
Zensys.Programmer.Interfaces Namespace


Zensys.ZWave.Programmer.Actions Namespace

Zensys.ZWave.Programmer.Actions Namespace

Classes

Class | Description
CommonActions | CommonActions class. Contains common functions.
ConsoleFormActions | ConsoleFormActions class. Contains Console Form functions.
LogFormActions | LogFormActions class. Contains Log Form functions.
MainFormActions | MainFormActions class. Contains Main Form functions.
ProgrammerActions | ProgrammerActions class. Contains main application functions.
ZW010xFormActions | ZW010xFormActions class. Contains ZW010x Form functions.
ZW020xFormActions | ZW020xFormActions class. Contains ZW020x Form functions.
ZW030xFormActions | ZW030xFormActions class. Contains ZW030x Form functions.
ZW040xFormActions | ZW040xFormActions class. Contains ZW040x Form functions.


CommonActions Class

CommonActions Class
Members See Also

CommonActions class. Contains common functions.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class CommonActions : BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Actions..::.CommonActions

See Also

CommonActions Members
Zensys.ZWave.Programmer.Actions Namespace


CommonActions Members

[image]

Z-Wave Programmer reference library
CommonActions Members
CommonActions Class Constructors Methods See Also

The CommonActions type exposes the following members.

Constructors

Name | Description
CommonActions | Initializes a new instance of the CommonActions class.

Methods

Name | Description
BindLogData | Binds the log data.
BrowseFile | Browse the HEX file (Flash, EEPROM, SRAM etc.).
CheckDeviceChipTypeCompatibility | Checks the device chip type compatibility.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommonActions Class
Zensys.ZWave.Programmer.Actions Namespace


CommonActions Constructor

CommonActions Constructor
CommonActions Class See Also

Initializes a new instance of the CommonActions class.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public CommonActions(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

CommonActions Class
Zensys.ZWave.Programmer.Actions Namespace


CommonActions Methods

[image]

Z-Wave Programmer reference library
CommonActions Methods
CommonActions Class See Also

The CommonActions type exposes the following methods.

Methods

Name | Description
BindLogData | Binds the log data.
BrowseFile | Browse the HEX file (Flash, EEPROM, SRAM etc.).
CheckDeviceChipTypeCompatibility | Checks the device chip type compatibility.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommonActions Class
Zensys.ZWave.Programmer.Actions Namespace


BindLogData Method

CommonActions..::.BindLogData Method
CommonActions Class See Also

Binds the log data.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void BindLogData()

See Also

CommonActions Class
Zensys.ZWave.Programmer.Actions Namespace


BrowseFile Method

CommonActions..::.BrowseFile Method
CommonActions Class See Also

Browse the HEX file (Flash, EEPROM, SRAM etc.).

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string BrowseFile()

Return Value

See Also

CommonActions Class
Zensys.ZWave.Programmer.Actions Namespace


CheckDeviceChipTypeCompatibility Method

CommonActions..::.CheckDeviceChipTypeCompatibility Method
CommonActions Class See Also

Checks the device chip type compatibility.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public bool CheckDeviceChipTypeCompatibility(
    IDevice device
)

Parameters

device
Type: IDevice
The device.

Return Value

See Also

CommonActions Class
Zensys.ZWave.Programmer.Actions Namespace


ConsoleFormActions Class

ConsoleFormActions Class
Members See Also

ConsoleFormActions class. Contains Console Form functions.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ConsoleFormActions : BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Actions..::.ConsoleFormActions

See Also

ConsoleFormActions Members
Zensys.ZWave.Programmer.Actions Namespace


ConsoleFormActions Members

[image]

Z-Wave Programmer reference library
ConsoleFormActions Members
ConsoleFormActions Class Constructors Methods See Also

The ConsoleFormActions type exposes the following members.

Constructors

Name | Description
ConsoleFormActions | Initializes a new instance of the ConsoleFormActions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClearClick | Called when Clear click.
OnCopyClick | Called when Copy click.
OnFormClosing | Called when form closing.
OnFormLoad | Called when form load.
OnSaveClick | Called when Save click.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConsoleFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ConsoleFormActions Constructor

ConsoleFormActions Constructor
ConsoleFormActions Class See Also

Initializes a new instance of the ConsoleFormActions class.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ConsoleFormActions(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

ConsoleFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ConsoleFormActions Methods

[image]

Z-Wave Programmer reference library
ConsoleFormActions Methods
ConsoleFormActions Class See Also

The ConsoleFormActions type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClearClick | Called when Clear click.
OnCopyClick | Called when Copy click.
OnFormClosing | Called when form closing.
OnFormLoad | Called when form load.
OnSaveClick | Called when Save click.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConsoleFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnClearClick Method

ConsoleFormActions..::.OnClearClick Method
ConsoleFormActions Class See Also

Called when Clear click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnClearClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ConsoleFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnCopyClick Method

ConsoleFormActions..::.OnCopyClick Method
ConsoleFormActions Class See Also

Called when Copy click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnCopyClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ConsoleFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormClosing Method

ConsoleFormActions..::.OnFormClosing Method
ConsoleFormActions Class See Also

Called when form closing.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormClosing(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ConsoleFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormLoad Method

ConsoleFormActions..::.OnFormLoad Method
ConsoleFormActions Class See Also

Called when form load.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormLoad(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ConsoleFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnSaveClick Method

ConsoleFormActions..::.OnSaveClick Method
ConsoleFormActions Class See Also

Called when Save click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnSaveClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ConsoleFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


LogFormActions Class

LogFormActions Class
Members See Also

LogFormActions class. Contains Log Form functions.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class LogFormActions : BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Actions..::.LogFormActions

See Also

LogFormActions Members
Zensys.ZWave.Programmer.Actions Namespace


LogFormActions Members

[image]

Z-Wave Programmer reference library
LogFormActions Members
LogFormActions Class Constructors Methods See Also

The LogFormActions type exposes the following members.

Constructors

Name | Description
LogFormActions | Initializes a new instance of the LogFormActions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClearClick | Called when Clear click.
OnCopyClick | Called when Copy click.
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


LogFormActions Constructor

LogFormActions Constructor
LogFormActions Class See Also

Initializes a new instance of the LogFormActions class.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public LogFormActions(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

LogFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


LogFormActions Methods

[image]

Z-Wave Programmer reference library
LogFormActions Methods
LogFormActions Class See Also

The LogFormActions type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClearClick | Called when Clear click.
OnCopyClick | Called when Copy click.
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnClearClick Method

LogFormActions..::.OnClearClick Method
LogFormActions Class See Also

Called when Clear click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnClearClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

LogFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnCopyClick Method

LogFormActions..::.OnCopyClick Method
LogFormActions Class See Also

Called when Copy click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnCopyClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

LogFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormClosing Method

LogFormActions..::.OnFormClosing Method
LogFormActions Class See Also

Called when Form closing.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormClosing(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

LogFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormLoad Method

LogFormActions..::.OnFormLoad Method
LogFormActions Class See Also

Called when Form load.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormLoad(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

LogFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


MainFormActions Class

MainFormActions Class
Members See Also

MainFormActions class. Contains Main Form functions.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class MainFormActions : BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Actions..::.MainFormActions

See Also

MainFormActions Members
Zensys.ZWave.Programmer.Actions Namespace


MainFormActions Members

[image]

Z-Wave Programmer reference library
MainFormActions Members
MainFormActions Class Constructors Methods See Also

The MainFormActions type exposes the following members.

Constructors

Name | Description
MainFormActions | Initializes a new instance of the MainFormActions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadSettings | Loads the Application settings.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnActiveContentChanged | Called when Active Content changed.
OnConsoleClick | Called when Console menu item click.
OnDetectTargetClick | Called when Detect Target menu item click.
OnExitClick | Called when Exit menu item click.
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
OnLogClick | Called when Log menu item click.
OnSettingsClick | Called when Settings menu item click.
OnZW010xClick | Called when ZW010x menu item click.
OnZW020xClick | Called when ZW020x menu item click.
OnZW030xClick | Called when ZW030x menu item click.
OnZW040xClick | Called when ZW040x menu item click.
SaveSettings | Saves the Application settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


MainFormActions Constructor

MainFormActions Constructor
MainFormActions Class See Also

Initializes a new instance of the MainFormActions class.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public MainFormActions(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


MainFormActions Methods

[image]

Z-Wave Programmer reference library
MainFormActions Methods
MainFormActions Class See Also

The MainFormActions type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadSettings | Loads the Application settings.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnActiveContentChanged | Called when Active Content changed.
OnConsoleClick | Called when Console menu item click.
OnDetectTargetClick | Called when Detect Target menu item click.
OnExitClick | Called when Exit menu item click.
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
OnLogClick | Called when Log menu item click.
OnSettingsClick | Called when Settings menu item click.
OnZW010xClick | Called when ZW010x menu item click.
OnZW020xClick | Called when ZW020x menu item click.
OnZW030xClick | Called when ZW030x menu item click.
OnZW040xClick | Called when ZW040x menu item click.
SaveSettings | Saves the Application settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


LoadSettings Method

MainFormActions..::.LoadSettings Method
MainFormActions Class See Also

Loads the Application settings.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void LoadSettings()

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnActiveContentChanged Method

MainFormActions..::.OnActiveContentChanged Method
MainFormActions Class See Also

Called when Active Content changed.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnActiveContentChanged(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnConsoleClick Method

MainFormActions..::.OnConsoleClick Method
MainFormActions Class See Also

Called when Console menu item click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnConsoleClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnDetectTargetClick Method

MainFormActions..::.OnDetectTargetClick Method
MainFormActions Class See Also

Called when Detect Target menu item click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnDetectTargetClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnExitClick Method

MainFormActions..::.OnExitClick Method
MainFormActions Class See Also

Called when Exit menu item click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnExitClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormClosing Method

MainFormActions..::.OnFormClosing Method
MainFormActions Class See Also

Called when Form closing.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormClosing(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormLoad Method

MainFormActions..::.OnFormLoad Method
MainFormActions Class See Also

Called when Form load.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormLoad(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnLogClick Method

MainFormActions..::.OnLogClick Method
MainFormActions Class See Also

Called when Log menu item click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnLogClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnSettingsClick Method

MainFormActions..::.OnSettingsClick Method
MainFormActions Class See Also

Called when Settings menu item click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnSettingsClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnZW010xClick Method

MainFormActions..::.OnZW010xClick Method
MainFormActions Class See Also

Called when ZW010x menu item click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnZW010xClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnZW020xClick Method

MainFormActions..::.OnZW020xClick Method
MainFormActions Class See Also

Called when ZW020x menu item click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnZW020xClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnZW030xClick Method

MainFormActions..::.OnZW030xClick Method
MainFormActions Class See Also

Called when ZW030x menu item click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnZW030xClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnZW040xClick Method

MainFormActions..::.OnZW040xClick Method
MainFormActions Class See Also

Called when ZW040x menu item click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnZW040xClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


SaveSettings Method

MainFormActions..::.SaveSettings Method
MainFormActions Class See Also

Saves the Application settings.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void SaveSettings()

See Also

MainFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ProgrammerActions Class

ProgrammerActions Class
Members See Also

ProgrammerActions class. Contains main application functions.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ProgrammerActions : BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Actions..::.ProgrammerActions

See Also

ProgrammerActions Members
Zensys.ZWave.Programmer.Actions Namespace


ProgrammerActions Members

[image]

Z-Wave Programmer reference library
ProgrammerActions Members
ProgrammerActions Class Constructors Methods See Also

The ProgrammerActions type exposes the following members.

Constructors

Name | Description
ProgrammerActions | Initializes a new instance of the ProgrammerActions class.

Methods

Name | Description
DetectDevice | Overloaded.
EEPROMErase | Erase the EEPROM.
EEPROMWrite | Write the EEPROM.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FlashCompare | Compare the Flash.
FlashErase | Erase the Flash.
FlashProgram | Programs the Flash.
FlashRead | Read the flash.
FlashWrite | Writes the Flash.
FlashWriteOptions | Writes the Flash options.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnEEPROMCompareClick | Called when EEPROM Compare click.
OnEEPROMEraseClick | Called when EEPROM Erase click.
OnEEPROMReadClick | Called when EEPROM Read click.
OnEEPROMWriteClick | Called when EEPROM Write click.
OnFlashCompareClick | Called when Flash Compare click.
OnFlashEraseClick | Called when Flash Erase click.
OnFlashProgramClick | Called when Flash Program click.
OnFlashReadClick | Called when Flash Read click.
OnFlashReadOptionsClick | Called when Flash Read options click.
OnFlashWriteClick | Called when Flash Write click.
OnFlashWriteOptionsClick | Called when Flash Write options click.
OnReadHomeIdClick | Called when Read Home Id click.
OnWriteHomeIdClick | Called when Write Home Id click.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateFlashSettings | Overloaded.
WriteHomeId | Writes the Home Id.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


ProgrammerActions Constructor

ProgrammerActions Constructor
ProgrammerActions Class See Also

Initializes a new instance of the ProgrammerActions class.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ProgrammerActions(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


ProgrammerActions Methods

[image]

Z-Wave Programmer reference library
ProgrammerActions Methods
ProgrammerActions Class See Also

The ProgrammerActions type exposes the following methods.

Methods

Name | Description
DetectDevice | Overloaded.
EEPROMErase | Erase the EEPROM.
EEPROMWrite | Write the EEPROM.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FlashCompare | Compare the Flash.
FlashErase | Erase the Flash.
FlashProgram | Programs the Flash.
FlashRead | Read the flash.
FlashWrite | Writes the Flash.
FlashWriteOptions | Writes the Flash options.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnEEPROMCompareClick | Called when EEPROM Compare click.
OnEEPROMEraseClick | Called when EEPROM Erase click.
OnEEPROMReadClick | Called when EEPROM Read click.
OnEEPROMWriteClick | Called when EEPROM Write click.
OnFlashCompareClick | Called when Flash Compare click.
OnFlashEraseClick | Called when Flash Erase click.
OnFlashProgramClick | Called when Flash Program click.
OnFlashReadClick | Called when Flash Read click.
OnFlashReadOptionsClick | Called when Flash Read options click.
OnFlashWriteClick | Called when Flash Write click.
OnFlashWriteOptionsClick | Called when Flash Write options click.
OnReadHomeIdClick | Called when Read Home Id click.
OnWriteHomeIdClick | Called when Write Home Id click.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateFlashSettings | Overloaded.
WriteHomeId | Writes the Home Id.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


DetectDevice Method

[image]

Z-Wave Programmer reference library
ProgrammerActions..::.DetectDevice Method
ProgrammerActions Class See Also

Overload List

Name | Description
DetectDevice()()() | Detects the device.
DetectDevice(Boolean) | Detects the device.

See Also

ProgrammerActions Class
ProgrammerActions Members
Zensys.ZWave.Programmer.Actions Namespace


DetectDevice Method

ProgrammerActions..::.DetectDevice Method
ProgrammerActions Class See Also

Detects the device.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public bool DetectDevice()

Return Value

See Also

ProgrammerActions Class
DetectDevice Overload
Zensys.ZWave.Programmer.Actions Namespace


DetectDevice Method (Boolean)

ProgrammerActions..::.DetectDevice Method (Boolean)
ProgrammerActions Class See Also

Detects the device.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public bool DetectDevice(
    bool isCommandPrompt
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.

Return Value

See Also

ProgrammerActions Class
DetectDevice Overload
Zensys.ZWave.Programmer.Actions Namespace


EEPROMErase Method

ProgrammerActions..::.EEPROMErase Method
ProgrammerActions Class See Also

Erase the EEPROM.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void EEPROMErase(
    bool isCommandPrompt
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


EEPROMWrite Method

ProgrammerActions..::.EEPROMWrite Method
ProgrammerActions Class See Also

Write the EEPROM.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void EEPROMWrite(
    bool isCommandPrompt,
    string fileName
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
fileName
Type: System..::.String
Name of the file.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


FlashCompare Method

ProgrammerActions..::.FlashCompare Method
ProgrammerActions Class See Also

Compare the Flash.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void FlashCompare(
    bool isCommandPrompt,
    string fileName
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
fileName
Type: System..::.String
Name of the file.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


FlashErase Method

ProgrammerActions..::.FlashErase Method
ProgrammerActions Class See Also

Erase the Flash.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void FlashErase(
    bool isCommandPrompt
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


FlashProgram Method

ProgrammerActions..::.FlashProgram Method
ProgrammerActions Class See Also

Programs the Flash.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void FlashProgram(
    bool isCommandPrompt,
    string fileName
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
fileName
Type: System..::.String
Name of the file.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


FlashRead Method

ProgrammerActions..::.FlashRead Method
ProgrammerActions Class See Also

Read the flash.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string FlashRead(
    bool isCommandPrompt,
    string fileName
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
fileName
Type: System..::.String
Name of the file.

Return Value

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


FlashWrite Method

ProgrammerActions..::.FlashWrite Method
ProgrammerActions Class See Also

Writes the Flash.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void FlashWrite(
    bool isCommandPrompt,
    string fileName
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
fileName
Type: System..::.String
Name of the file.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


FlashWriteOptions Method

ProgrammerActions..::.FlashWriteOptions Method
ProgrammerActions Class See Also

Writes the Flash options.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void FlashWriteOptions(
    bool isCommandPrompt,
    byte frequency
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
frequency
Type: System..::.Byte
The frequency.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnEEPROMCompareClick Method

ProgrammerActions..::.OnEEPROMCompareClick Method
ProgrammerActions Class See Also

Called when EEPROM Compare click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnEEPROMCompareClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnEEPROMEraseClick Method

ProgrammerActions..::.OnEEPROMEraseClick Method
ProgrammerActions Class See Also

Called when EEPROM Erase click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnEEPROMEraseClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnEEPROMReadClick Method

ProgrammerActions..::.OnEEPROMReadClick Method
ProgrammerActions Class See Also

Called when EEPROM Read click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnEEPROMReadClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnEEPROMWriteClick Method

ProgrammerActions..::.OnEEPROMWriteClick Method
ProgrammerActions Class See Also

Called when EEPROM Write click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnEEPROMWriteClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFlashCompareClick Method

ProgrammerActions..::.OnFlashCompareClick Method
ProgrammerActions Class See Also

Called when Flash Compare click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFlashCompareClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs, application is in command prompt mode.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFlashEraseClick Method

ProgrammerActions..::.OnFlashEraseClick Method
ProgrammerActions Class See Also

Called when Flash Erase click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFlashEraseClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFlashProgramClick Method

ProgrammerActions..::.OnFlashProgramClick Method
ProgrammerActions Class See Also

Called when Flash Program click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFlashProgramClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFlashReadClick Method

ProgrammerActions..::.OnFlashReadClick Method
ProgrammerActions Class See Also

Called when Flash Read click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFlashReadClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFlashReadOptionsClick Method

ProgrammerActions..::.OnFlashReadOptionsClick Method
ProgrammerActions Class See Also

Called when Flash Read options click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFlashReadOptionsClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFlashWriteClick Method

ProgrammerActions..::.OnFlashWriteClick Method
ProgrammerActions Class See Also

Called when Flash Write click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFlashWriteClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFlashWriteOptionsClick Method

ProgrammerActions..::.OnFlashWriteOptionsClick Method
ProgrammerActions Class See Also

Called when Flash Write options click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFlashWriteOptionsClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnReadHomeIdClick Method

ProgrammerActions..::.OnReadHomeIdClick Method
ProgrammerActions Class See Also

Called when Read Home Id click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnReadHomeIdClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnWriteHomeIdClick Method

ProgrammerActions..::.OnWriteHomeIdClick Method
ProgrammerActions Class See Also

Called when Write Home Id click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnWriteHomeIdClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


UpdateFlashSettings Method

[image]

Z-Wave Programmer reference library
ProgrammerActions..::.UpdateFlashSettings Method
ProgrammerActions Class See Also

Overload List

Name | Description
UpdateFlashSettings(ChipTypes, String) | Updates the flash settings.
UpdateFlashSettings(ChipTypes, IFlashSettings) | Updates the flash settings.

See Also

ProgrammerActions Class
ProgrammerActions Members
Zensys.ZWave.Programmer.Actions Namespace


UpdateFlashSettings Method (, String)

ProgrammerActions..::.UpdateFlashSettings Method (, String)
ProgrammerActions Class See Also

Updates the flash settings.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void UpdateFlashSettings(
    ChipTypes chipType,
    string fileName
)

Parameters

chipType
Type: ChipTypes
Type of the chip.
fileName
Type: System..::.String
Name of the file.

See Also

ProgrammerActions Class
UpdateFlashSettings Overload
Zensys.ZWave.Programmer.Actions Namespace


UpdateFlashSettings Method (, )

ProgrammerActions..::.UpdateFlashSettings Method (, )
ProgrammerActions Class See Also

Updates the flash settings.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void UpdateFlashSettings(
    ChipTypes chipType,
    IFlashSettings flashSettings
)

Parameters

chipType
Type: ChipTypes
Type of the chip.
flashSettings
Type: IFlashSettings
The flash settings.

See Also

ProgrammerActions Class
UpdateFlashSettings Overload
Zensys.ZWave.Programmer.Actions Namespace


WriteHomeId Method

ProgrammerActions..::.WriteHomeId Method
ProgrammerActions Class See Also

Writes the Home Id.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void WriteHomeId(
    bool isCommandPrompt,
    string homeIdString
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true [is command prompt].
homeIdString
Type: System..::.String
The home id string.

See Also

ProgrammerActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW010xFormActions Class

ZW010xFormActions Class
Members See Also

ZW010xFormActions class. Contains ZW010x Form functions.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW010xFormActions : BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Actions..::.ZW010xFormActions

See Also

ZW010xFormActions Members
Zensys.ZWave.Programmer.Actions Namespace


ZW010xFormActions Members

[image]

Z-Wave Programmer reference library
ZW010xFormActions Members
ZW010xFormActions Class Constructors Methods See Also

The ZW010xFormActions type exposes the following members.

Constructors

Name | Description
ZW010xFormActions | Initializes a new instance of the ZW010xFormActions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnEEPROMBrowseHexFileClick | Called when EEPROM browse HEX file click.
OnFlashBrowseHexFileClick | Called when Flash Browse HEX file click.
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW010xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW010xFormActions Constructor

ZW010xFormActions Constructor
ZW010xFormActions Class See Also

Initializes a new instance of the ZW010xFormActions class.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW010xFormActions(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

ZW010xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW010xFormActions Methods

[image]

Z-Wave Programmer reference library
ZW010xFormActions Methods
ZW010xFormActions Class See Also

The ZW010xFormActions type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnEEPROMBrowseHexFileClick | Called when EEPROM browse HEX file click.
OnFlashBrowseHexFileClick | Called when Flash Browse HEX file click.
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW010xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnEEPROMBrowseHexFileClick Method

ZW010xFormActions..::.OnEEPROMBrowseHexFileClick Method
ZW010xFormActions Class See Also

Called when EEPROM browse HEX file click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnEEPROMBrowseHexFileClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW010xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFlashBrowseHexFileClick Method

ZW010xFormActions..::.OnFlashBrowseHexFileClick Method
ZW010xFormActions Class See Also

Called when Flash Browse HEX file click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFlashBrowseHexFileClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW010xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormClosing Method

ZW010xFormActions..::.OnFormClosing Method
ZW010xFormActions Class See Also

Called when Form closing.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormClosing(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW010xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormLoad Method

ZW010xFormActions..::.OnFormLoad Method
ZW010xFormActions Class See Also

Called when Form load.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormLoad(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW010xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW020xFormActions Class

ZW020xFormActions Class
Members See Also

ZW020xFormActions class. Contains ZW020x Form functions.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW020xFormActions : BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Actions..::.ZW020xFormActions

See Also

ZW020xFormActions Members
Zensys.ZWave.Programmer.Actions Namespace


ZW020xFormActions Members

[image]

Z-Wave Programmer reference library
ZW020xFormActions Members
ZW020xFormActions Class Constructors Methods See Also

The ZW020xFormActions type exposes the following members.

Constructors

Name | Description
ZW020xFormActions | Initializes a new instance of the ZW020xFormActions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnEEPROMBrowseHexFileClick | Called when EEPROM browse HEX file click.
OnFlashBrowseHexFileClick | Called when Flash browse HEX file click.
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW020xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW020xFormActions Constructor

ZW020xFormActions Constructor
ZW020xFormActions Class See Also

Initializes a new instance of the ZW020xFormActions class.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW020xFormActions(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

ZW020xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW020xFormActions Methods

[image]

Z-Wave Programmer reference library
ZW020xFormActions Methods
ZW020xFormActions Class See Also

The ZW020xFormActions type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnEEPROMBrowseHexFileClick | Called when EEPROM browse HEX file click.
OnFlashBrowseHexFileClick | Called when Flash browse HEX file click.
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW020xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnEEPROMBrowseHexFileClick Method

ZW020xFormActions..::.OnEEPROMBrowseHexFileClick Method
ZW020xFormActions Class See Also

Called when EEPROM browse HEX file click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnEEPROMBrowseHexFileClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW020xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFlashBrowseHexFileClick Method

ZW020xFormActions..::.OnFlashBrowseHexFileClick Method
ZW020xFormActions Class See Also

Called when Flash browse HEX file click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFlashBrowseHexFileClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW020xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormClosing Method

ZW020xFormActions..::.OnFormClosing Method
ZW020xFormActions Class See Also

Called when Form closing.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormClosing(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW020xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormLoad Method

ZW020xFormActions..::.OnFormLoad Method
ZW020xFormActions Class See Also

Called when Form load.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormLoad(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW020xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW030xFormActions Class

ZW030xFormActions Class
Members See Also

ZW030xFormActions class. Contains ZW030x Form functions.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW030xFormActions : BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Actions..::.ZW030xFormActions

See Also

ZW030xFormActions Members
Zensys.ZWave.Programmer.Actions Namespace


ZW030xFormActions Members

[image]

Z-Wave Programmer reference library
ZW030xFormActions Members
ZW030xFormActions Class Constructors Methods See Also

The ZW030xFormActions type exposes the following members.

Constructors

Name | Description
ZW030xFormActions | Initializes a new instance of the ZW030xFormActions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnEEPROMBrowseHexFileClick | Called when EEPROM browse HEX file click.
OnFlashBrowseHexFileClick | Called when Flash browse HEX file click.
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW030xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW030xFormActions Constructor

ZW030xFormActions Constructor
ZW030xFormActions Class See Also

Initializes a new instance of the ZW030xFormActions class.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW030xFormActions(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

ZW030xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW030xFormActions Methods

[image]

Z-Wave Programmer reference library
ZW030xFormActions Methods
ZW030xFormActions Class See Also

The ZW030xFormActions type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnEEPROMBrowseHexFileClick | Called when EEPROM browse HEX file click.
OnFlashBrowseHexFileClick | Called when Flash browse HEX file click.
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW030xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnEEPROMBrowseHexFileClick Method

ZW030xFormActions..::.OnEEPROMBrowseHexFileClick Method
ZW030xFormActions Class See Also

Called when EEPROM browse HEX file click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnEEPROMBrowseHexFileClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW030xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFlashBrowseHexFileClick Method

ZW030xFormActions..::.OnFlashBrowseHexFileClick Method
ZW030xFormActions Class See Also

Called when Flash browse HEX file click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFlashBrowseHexFileClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW030xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormClosing Method

ZW030xFormActions..::.OnFormClosing Method
ZW030xFormActions Class See Also

Called when Form closing.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormClosing(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW030xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormLoad Method

ZW030xFormActions..::.OnFormLoad Method
ZW030xFormActions Class See Also

Called when Form load.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormLoad(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW030xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW040xFormActions Class

ZW040xFormActions Class
Members See Also

ZW040xFormActions class. Contains ZW040x Form functions.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW040xFormActions : BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Actions..::.ZW040xFormActions

See Also

ZW040xFormActions Members
Zensys.ZWave.Programmer.Actions Namespace


ZW040xFormActions Members

[image]

Z-Wave Programmer reference library
ZW040xFormActions Members
ZW040xFormActions Class Constructors Methods See Also

The ZW040xFormActions type exposes the following members.

Constructors

Name | Description
ZW040xFormActions | Initializes a new instance of the ZW040xFormActions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
OnSramBrowseHexFileClick | Called when SRAM browse HEX file click.
OnSramCompareClick | Called when SRAM compare click.
OnSramReadClick | Called when SRAM read click.
OnSramWriteAndExecOutOfSramClick | Called when SRAM write and execute out of SRAM mode click.
OnSramWriteAndRunDevModeClick | Called when SRAM write and run development mode click.
OnSramWriteClick | Called when SRAM write click.
SramCompare | Compare the SRAM.
SramRead | Reads the SRAM.
SramWrite | Write the SRAM.
SramWriteAndExecOutOfSram | Srams the write and exec out of sram.
SramWriteAndRunDevMode | Write the SRAM and run development mode.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW040xFormActions Constructor

ZW040xFormActions Constructor
ZW040xFormActions Class See Also

Initializes a new instance of the ZW040xFormActions class.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW040xFormActions(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


ZW040xFormActions Methods

[image]

Z-Wave Programmer reference library
ZW040xFormActions Methods
ZW040xFormActions Class See Also

The ZW040xFormActions type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFormClosing | Called when Form closing.
OnFormLoad | Called when Form load.
OnSramBrowseHexFileClick | Called when SRAM browse HEX file click.
OnSramCompareClick | Called when SRAM compare click.
OnSramReadClick | Called when SRAM read click.
OnSramWriteAndExecOutOfSramClick | Called when SRAM write and execute out of SRAM mode click.
OnSramWriteAndRunDevModeClick | Called when SRAM write and run development mode click.
OnSramWriteClick | Called when SRAM write click.
SramCompare | Compare the SRAM.
SramRead | Reads the SRAM.
SramWrite | Write the SRAM.
SramWriteAndExecOutOfSram | Srams the write and exec out of sram.
SramWriteAndRunDevMode | Write the SRAM and run development mode.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormClosing Method

ZW040xFormActions..::.OnFormClosing Method
ZW040xFormActions Class See Also

Called when Form closing.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormClosing(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnFormLoad Method

ZW040xFormActions..::.OnFormLoad Method
ZW040xFormActions Class See Also

Called when Form load.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnFormLoad(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnSramBrowseHexFileClick Method

ZW040xFormActions..::.OnSramBrowseHexFileClick Method
ZW040xFormActions Class See Also

Called when SRAM browse HEX file click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnSramBrowseHexFileClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnSramCompareClick Method

ZW040xFormActions..::.OnSramCompareClick Method
ZW040xFormActions Class See Also

Called when SRAM compare click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnSramCompareClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnSramReadClick Method

ZW040xFormActions..::.OnSramReadClick Method
ZW040xFormActions Class See Also

Called when SRAM read click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnSramReadClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnSramWriteAndExecOutOfSramClick Method

ZW040xFormActions..::.OnSramWriteAndExecOutOfSramClick Method
ZW040xFormActions Class See Also

Called when SRAM write and execute out of SRAM mode click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnSramWriteAndExecOutOfSramClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnSramWriteAndRunDevModeClick Method

ZW040xFormActions..::.OnSramWriteAndRunDevModeClick Method
ZW040xFormActions Class See Also

Called when SRAM write and run development mode click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnSramWriteAndRunDevModeClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


OnSramWriteClick Method

ZW040xFormActions..::.OnSramWriteClick Method
ZW040xFormActions Class See Also

Called when SRAM write click.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void OnSramWriteClick(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The sender.
e
Type: System..::.EventArgs
The EventArgs instance containing the event data.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


SramCompare Method

ZW040xFormActions..::.SramCompare Method
ZW040xFormActions Class See Also

Compare the SRAM.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void SramCompare(
    bool isCommandPrompt,
    string fileName
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
fileName
Type: System..::.String
Name of the file.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


SramRead Method

ZW040xFormActions..::.SramRead Method
ZW040xFormActions Class See Also

Reads the SRAM.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void SramRead(
    bool isCommandPrompt,
    string fileName
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
fileName
Type: System..::.String
Name of the file.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


SramWrite Method

ZW040xFormActions..::.SramWrite Method
ZW040xFormActions Class See Also

Write the SRAM.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void SramWrite(
    bool isCommandPrompt,
    string fileName
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
fileName
Type: System..::.String
Name of the file.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


SramWriteAndExecOutOfSram Method

ZW040xFormActions..::.SramWriteAndExecOutOfSram Method
ZW040xFormActions Class See Also

Srams the write and exec out of sram.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void SramWriteAndExecOutOfSram(
    bool isCommandPrompt,
    string fileName
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
fileName
Type: System..::.String
Name of the file.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


SramWriteAndRunDevMode Method

ZW040xFormActions..::.SramWriteAndRunDevMode Method
ZW040xFormActions Class See Also

Write the SRAM and run development mode.

Namespace: Zensys.ZWave.Programmer.Actions
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void SramWriteAndRunDevMode(
    bool isCommandPrompt,
    string fileName
)

Parameters

isCommandPrompt
Type: System..::.Boolean
if set to true, application is in command prompt mode.
fileName
Type: System..::.String
Name of the file.

See Also

ZW040xFormActions Class
Zensys.ZWave.Programmer.Actions Namespace


Zensys.ZWave.Programmer.Classes Namespace

Zensys.ZWave.Programmer.Classes Namespace

Classes

Class | Description
ActionCollection | ActionCollection class. Contains references to the application Action classes.
BaseAction | Base class for actions. Provides methods that extends ControllerManager()()()
DockableView | DockableView class. Base class for dockable forms.
HexFileHelper | Class used to work with Intel Hex files
ProgrammerConsole | ProgrammerConsole class. Contains methods for parsing command line arguments.
ProgrammerSettings | ProgrammerSettings class. Contains application settings.
SerialPortInfo | SerialPortInfo class.


ActionCollection Class

ActionCollection Class
Members See Also

ActionCollection class. Contains references to the application Action classes.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ActionCollection : BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Classes..::.ActionCollection

See Also

ActionCollection Members
Zensys.ZWave.Programmer.Classes Namespace


ActionCollection Members

[image]

Z-Wave Programmer reference library
ActionCollection Members
ActionCollection Class Constructors Methods Properties See Also

The ActionCollection type exposes the following members.

Constructors

Name | Description
ActionCollection | Initializes a new instance of the ActionCollection class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CommonActions | Gets the Common actions.
ConsoleFormActions | Gets the Console Form actions.
LogFormActions | Gets the Log Form actions.
MainFormActions | Gets the Main Form actions.
ProgrammerActions | Gets the Programmer actions (Common functions that used to programm the chip).
ZW010xFormActions | Gets the ZW010x Form actions.
ZW020xFormActions | Gets the ZW020x Form actions.
ZW030xFormActions | Gets the ZW030x Form actions.
ZW040xFormActions | Gets the ZW040x Form actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


ActionCollection Constructor

ActionCollection Constructor
ActionCollection Class See Also

Initializes a new instance of the ActionCollection class.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ActionCollection(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


ActionCollection Properties

[image]

Z-Wave Programmer reference library
ActionCollection Properties
ActionCollection Class See Also

The ActionCollection type exposes the following properties.

Properties

Name | Description
CommonActions | Gets the Common actions.
ConsoleFormActions | Gets the Console Form actions.
LogFormActions | Gets the Log Form actions.
MainFormActions | Gets the Main Form actions.
ProgrammerActions | Gets the Programmer actions (Common functions that used to programm the chip).
ZW010xFormActions | Gets the ZW010x Form actions.
ZW020xFormActions | Gets the ZW020x Form actions.
ZW030xFormActions | Gets the ZW030x Form actions.
ZW040xFormActions | Gets the ZW040x Form actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


CommonActions Property

ActionCollection..::.CommonActions Property
ActionCollection Class See Also

Gets the Common actions.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public CommonActions CommonActions { get; }

Field Value

The common actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


ConsoleFormActions Property

ActionCollection..::.ConsoleFormActions Property
ActionCollection Class See Also

Gets the Console Form actions.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ConsoleFormActions ConsoleFormActions { get; }

Field Value

The Console Form actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


LogFormActions Property

ActionCollection..::.LogFormActions Property
ActionCollection Class See Also

Gets the Log Form actions.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public LogFormActions LogFormActions { get; }

Field Value

The Log Form actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


MainFormActions Property

ActionCollection..::.MainFormActions Property
ActionCollection Class See Also

Gets the Main Form actions.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public MainFormActions MainFormActions { get; }

Field Value

The Main Form actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


ProgrammerActions Property

ActionCollection..::.ProgrammerActions Property
ActionCollection Class See Also

Gets the Programmer actions (Common functions that used to programm the chip).

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ProgrammerActions ProgrammerActions { get; }

Field Value

The Programmer actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


ZW010xFormActions Property

ActionCollection..::.ZW010xFormActions Property
ActionCollection Class See Also

Gets the ZW010x Form actions.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW010xFormActions ZW010xFormActions { get; }

Field Value

The ZW010x Form actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


ZW020xFormActions Property

ActionCollection..::.ZW020xFormActions Property
ActionCollection Class See Also

Gets the ZW020x Form actions.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW020xFormActions ZW020xFormActions { get; }

Field Value

The ZW020x Form actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


ZW030xFormActions Property

ActionCollection..::.ZW030xFormActions Property
ActionCollection Class See Also

Gets the ZW030x Form actions.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW030xFormActions ZW030xFormActions { get; }

Field Value

The ZW030x Form actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


ZW040xFormActions Property

ActionCollection..::.ZW040xFormActions Property
ActionCollection Class See Also

Gets the ZW040x Form actions.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW040xFormActions ZW040xFormActions { get; }

Field Value

The ZW040x Form actions.

See Also

ActionCollection Class
Zensys.ZWave.Programmer.Classes Namespace


BaseAction Class

BaseAction Class
Members See Also

Base class for actions. Provides methods that extends ControllerManager()()()

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class BaseAction

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.BaseAction
Zensys.ZWave.Programmer.Classes..::.ActionCollection
Zensys.ZWave.Programmer.Actions..::.ZW020xFormActions
Zensys.ZWave.Programmer.Actions..::.ConsoleFormActions
Zensys.ZWave.Programmer.Actions..::.ZW010xFormActions
Zensys.ZWave.Programmer.Actions..::.ZW040xFormActions
Zensys.ZWave.Programmer.Actions..::.ZW030xFormActions
Zensys.ZWave.Programmer.Actions..::.MainFormActions
Zensys.ZWave.Programmer.Actions..::.LogFormActions
Zensys.ZWave.Programmer.Actions..::.CommonActions
Zensys.ZWave.Programmer.Actions..::.ProgrammerActions

See Also

BaseAction Members
Zensys.ZWave.Programmer.Classes Namespace


BaseAction Members

[image]

Z-Wave Programmer reference library
BaseAction Members
BaseAction Class Constructors Methods See Also

The BaseAction type exposes the following members.

Constructors

Name | Description
BaseAction | Initializes a new instance of the BaseAction class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseAction Class
Zensys.ZWave.Programmer.Classes Namespace


BaseAction Constructor

BaseAction Constructor
BaseAction Class See Also

Initializes a new instance of the BaseAction class.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public BaseAction(
    ControllerManager controllerManager
)

Parameters

controllerManager
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller manager.

See Also

BaseAction Class
Zensys.ZWave.Programmer.Classes Namespace


DockableView Class

DockableView Class
Members See Also

DockableView class. Base class for dockable forms.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class DockableView : DockContent, IView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
DockContent
Zensys.ZWave.Programmer.Classes..::.DockableView
Zensys.ZWave.Programmer.UI..::.ZW030xForm
Zensys.ZWave.Programmer.UI..::.ZW040xForm
Zensys.ZWave.Programmer.UI..::.LogForm
Zensys.ZWave.Programmer.UI..::.ZW010xForm
Zensys.ZWave.Programmer.UI..::.ConsoleForm
Zensys.ZWave.Programmer.UI..::.ZW020xForm

See Also

DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


DockableView Members

[image]

Z-Wave Programmer reference library
DockableView Members
DockableView Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The DockableView type exposes the following members.

Constructors

Name | Description
DockableView |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Overrides Form..::.OnLayout(LayoutEventArgs).)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DockStyle | Gets or sets the dock style.
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewContainer | Gets or sets the form.
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

DockableView Class
Zensys.ZWave.Programmer.Classes Namespace


DockableView Constructor

DockableView Constructor
DockableView Class See Also

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public DockableView()

See Also

DockableView Class
Zensys.ZWave.Programmer.Classes Namespace


DockableView Methods

[image]

Z-Wave Programmer reference library
DockableView Methods
DockableView Class See Also

The DockableView type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Overrides Form..::.OnLayout(LayoutEventArgs).)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

DockableView Class
Zensys.ZWave.Programmer.Classes Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
DockableView..::.AccessibilityNotifyClients Method
DockableView Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
DockableView..::.BeginInvoke Method
DockableView Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
DockableView..::.Dispose Method
DockableView Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


DockTo Method

[image]

Z-Wave Programmer reference library
DockableView..::.DockTo Method
DockableView Class See Also

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
DockableView..::.GetChildAtPoint Method
DockableView Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
DockableView..::.Invalidate Method
DockableView Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
DockableView..::.Invoke Method
DockableView Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
DockableView..::.MemberwiseClone Method
DockableView Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


OnLayout Method

DockableView..::.OnLayout Method
DockableView Class See Also

Overrides OnLayout method.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void OnLayout(
    LayoutEventArgs levent
)

Parameters

levent
Type: System.Windows.Forms..::.LayoutEventArgs
Layout event arguments.

See Also

DockableView Class
Zensys.ZWave.Programmer.Classes Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
DockableView..::.PerformLayout Method
DockableView Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
DockableView..::.ResumeLayout Method
DockableView Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
DockableView..::.RtlTranslateAlignment Method
DockableView Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


Scale Method

[image]

Z-Wave Programmer reference library
DockableView..::.Scale Method
DockableView Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


Select Method

[image]

Z-Wave Programmer reference library
DockableView..::.Select Method
DockableView Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
DockableView..::.SetBounds Method
DockableView Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


Show Method

[image]

Z-Wave Programmer reference library
DockableView..::.Show Method
DockableView Class See Also

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


ShowDialog Method

[image]

Z-Wave Programmer reference library
DockableView..::.ShowDialog Method
DockableView Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
DockableView..::.UpdateBounds Method
DockableView Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


Validate Method

[image]

Z-Wave Programmer reference library
DockableView..::.Validate Method
DockableView Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


ValidateChildren Method

[image]

Z-Wave Programmer reference library
DockableView..::.ValidateChildren Method
DockableView Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

DockableView Class
DockableView Members
Zensys.ZWave.Programmer.Classes Namespace


DockableView Properties

[image]

Z-Wave Programmer reference library
DockableView Properties
DockableView Class See Also

The DockableView type exposes the following properties.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DockStyle | Gets or sets the dock style.
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewContainer | Gets or sets the form.
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

DockableView Class
Zensys.ZWave.Programmer.Classes Namespace


DockStyle Property

DockableView..::.DockStyle Property
DockableView Class See Also

Gets or sets the dock style.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public DockStyle DockStyle { get; set; }

Field Value

The dock style.

Implements

IView..::.DockStyle

See Also

DockableView Class
Zensys.ZWave.Programmer.Classes Namespace


ViewContainer Property

DockableView..::.ViewContainer Property
DockableView Class See Also

Gets or sets the form.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Form ViewContainer { get; }

Field Value

The form.

Implements

IView..::.ViewContainer

See Also

DockableView Class
Zensys.ZWave.Programmer.Classes Namespace


HexFileHelper Class

HexFileHelper Class
Members See Also

Class used to work with Intel Hex files

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class HexFileHelper

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.HexFileHelper

See Also

HexFileHelper Members
Zensys.ZWave.Programmer.Classes Namespace


HexFileHelper Members

[image]

Z-Wave Programmer reference library
HexFileHelper Members
HexFileHelper Class Constructors Methods Fields See Also

The HexFileHelper type exposes the following members.

Constructors

Name | Description
HexFileHelper | Initializes a new instance of the HexFileHelper class.

Methods

Name | Description
BlankArray | Creates the blank array.
Compare | Compares two byte arrays
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadIntelHexFile | Reads the contents of a Intel hext file and converts it to its binary data.
ToByteArray | Converts string value to byte array.
ToIntelHexData | Overloaded.
ToLong | Converts string value to long value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteCSharpArray | Writes a file with a C# byte array containing the data from the array specified
WriteIntelHexFile | Overloaded.

Fields

Name | Description
ADDRESS_OUT_OF_RANGE | return values used by module
COMPARE_FAIL | COMPARE_OK, COMPARE_FAIL constants.
COMPARE_OK | COMPARE_OK, COMPARE_FAIL constants.
FILE_OPEN_ERROR | return values used by module
FILE_READ | return values used by module
FILE_WRITTEN | return values used by module
NOT_INTEL_HEX | return values used by module
UNKNOWN_FIELD | return values used by module

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


HexFileHelper Constructor

HexFileHelper Constructor
HexFileHelper Class See Also

Initializes a new instance of the HexFileHelper class.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public HexFileHelper()

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


HexFileHelper Fields

[image]

Z-Wave Programmer reference library
HexFileHelper Fields
HexFileHelper Class See Also

The HexFileHelper type exposes the following fields.

Fields

Name | Description
ADDRESS_OUT_OF_RANGE | return values used by module
COMPARE_FAIL | COMPARE_OK, COMPARE_FAIL constants.
COMPARE_OK | COMPARE_OK, COMPARE_FAIL constants.
FILE_OPEN_ERROR | return values used by module
FILE_READ | return values used by module
FILE_WRITTEN | return values used by module
NOT_INTEL_HEX | return values used by module
UNKNOWN_FIELD | return values used by module

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


ADDRESS_OUT_OF_RANGE Field

HexFileHelper..::.ADDRESS_OUT_OF_RANGE Field
HexFileHelper Class See Also

return values used by module

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public const byte ADDRESS_OUT_OF_RANGE

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


COMPARE_FAIL Field

HexFileHelper..::.COMPARE_FAIL Field
HexFileHelper Class See Also

COMPARE_OK, COMPARE_FAIL constants.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public const int COMPARE_FAIL

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


COMPARE_OK Field

HexFileHelper..::.COMPARE_OK Field
HexFileHelper Class See Also

COMPARE_OK, COMPARE_FAIL constants.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public const int COMPARE_OK

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


FILE_OPEN_ERROR Field

HexFileHelper..::.FILE_OPEN_ERROR Field
HexFileHelper Class See Also

return values used by module

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public const byte FILE_OPEN_ERROR

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


FILE_READ Field

HexFileHelper..::.FILE_READ Field
HexFileHelper Class See Also

return values used by module

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public const byte FILE_READ

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


FILE_WRITTEN Field

HexFileHelper..::.FILE_WRITTEN Field
HexFileHelper Class See Also

return values used by module

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public const byte FILE_WRITTEN

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


NOT_INTEL_HEX Field

HexFileHelper..::.NOT_INTEL_HEX Field
HexFileHelper Class See Also

return values used by module

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public const byte NOT_INTEL_HEX

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


UNKNOWN_FIELD Field

HexFileHelper..::.UNKNOWN_FIELD Field
HexFileHelper Class See Also

return values used by module

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public const byte UNKNOWN_FIELD

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


HexFileHelper Methods

[image]

Z-Wave Programmer reference library
HexFileHelper Methods
HexFileHelper Class See Also

The HexFileHelper type exposes the following methods.

Methods

Name | Description
BlankArray | Creates the blank array.
Compare | Compares two byte arrays
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadIntelHexFile | Reads the contents of a Intel hext file and converts it to its binary data.
ToByteArray | Converts string value to byte array.
ToIntelHexData | Overloaded.
ToLong | Converts string value to long value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteCSharpArray | Writes a file with a C# byte array containing the data from the array specified
WriteIntelHexFile | Overloaded.

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


BlankArray Method

HexFileHelper..::.BlankArray Method
HexFileHelper Class See Also

Creates the blank array.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static byte[] BlankArray(
    int length,
    byte blankValue
)

Parameters

length
Type: System..::.Int32
The length.
blankValue
Type: System..::.Byte
The blank value.

Return Value

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


Compare Method

HexFileHelper..::.Compare Method
HexFileHelper Class See Also

Compares two byte arrays

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static int Compare(
    byte[] flash1,
    byte[] flash2,
    int maxAdr
)

Parameters

flash1
Type: array<System..::.Byte>[]()[]
Array one to compare
flash2
Type: array<System..::.Byte>[]()[]
Array two to compare
maxAdr
Type: System..::.Int32
Max address to use

Return Value

COMPARE_OK if succesfull

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


ReadIntelHexFile Method

HexFileHelper..::.ReadIntelHexFile Method
HexFileHelper Class See Also

Reads the contents of a Intel hext file and converts it to its binary data.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static byte ReadIntelHexFile(
    string inputfile,
    byte[] flashData,
    int maxAdr
)

Parameters

inputfile
Type: System..::.String
Filename to open
flashData
Type: array<System..::.Byte>[]()[]
Array to place data in, index = address
maxAdr
Type: System..::.Int32
The highest address to accept from file

Return Value

FILE_READ if no error

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


ToByteArray Method

HexFileHelper..::.ToByteArray Method
HexFileHelper Class See Also

Converts string value to byte array.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static byte[] ToByteArray(
    string inData
)

Parameters

inData
Type: System..::.String
The in data.

Return Value

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


ToIntelHexData Method

[image]

Z-Wave Programmer reference library
HexFileHelper..::.ToIntelHexData Method
HexFileHelper Class See Also

Overload List

Name | Description
ToIntelHexData(Int32, array<Byte>[]()[]) | Converts data to Intel HEX format.
ToIntelHexData(Int32, array<Byte>[]()[], Byte) | /// Converts data to Intel HEX format.

See Also

HexFileHelper Class
HexFileHelper Members
Zensys.ZWave.Programmer.Classes Namespace


ToIntelHexData Method (Int32, Byte[])

HexFileHelper..::.ToIntelHexData Method (Int32, array<Byte>[]()[])
HexFileHelper Class See Also

Converts data to Intel HEX format.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static string ToIntelHexData(
    int startAdr,
    byte[] data
)

Parameters

startAdr
Type: System..::.Int32
The start address.
data
Type: array<System..::.Byte>[]()[]
The data.

Return Value

See Also

HexFileHelper Class
ToIntelHexData Overload
Zensys.ZWave.Programmer.Classes Namespace


ToIntelHexData Method (Int32, Byte[], Byte)

HexFileHelper..::.ToIntelHexData Method (Int32, array<Byte>[]()[], Byte)
HexFileHelper Class See Also

/// Converts data to Intel HEX format.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static string ToIntelHexData(
    int startAdr,
    byte[] data,
    byte skipValue
)

Parameters

startAdr
Type: System..::.Int32
The start address.
data
Type: array<System..::.Byte>[]()[]
The data.
skipValue
Type: System..::.Byte
The skip value.

Return Value

See Also

HexFileHelper Class
ToIntelHexData Overload
Zensys.ZWave.Programmer.Classes Namespace


ToLong Method

HexFileHelper..::.ToLong Method
HexFileHelper Class See Also

Converts string value to long value.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static long ToLong(
    string inData
)

Parameters

inData
Type: System..::.String
The in data.

Return Value

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


WriteCSharpArray Method

HexFileHelper..::.WriteCSharpArray Method
HexFileHelper Class See Also

Writes a file with a C# byte array containing the data from the array specified

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static byte WriteCSharpArray(
    string filename,
    byte[] flashData,
    string className,
    string arrayName
)

Parameters

filename
Type: System..::.String
file name to write
flashData
Type: array<System..::.Byte>[]()[]
data to put in array
className
Type: System..::.String
Name of the class.
arrayName
Type: System..::.String
array name to give

Return Value

See Also

HexFileHelper Class
Zensys.ZWave.Programmer.Classes Namespace


WriteIntelHexFile Method

[image]

Z-Wave Programmer reference library
HexFileHelper..::.WriteIntelHexFile Method
HexFileHelper Class See Also

Overload List

Name | Description
WriteIntelHexFile(String, array<Byte>[]()[]) | Writes the Intel HEX file.
WriteIntelHexFile(String, array<Byte>[]()[], Byte) | Writes the Intel Hex file.
WriteIntelHexFile(array<Byte>[]()[], Int32, Int32, array<Byte>[]()[]) | Writes the Intel HEX file.
WriteIntelHexFile(String, array<Byte>[]()[], Int32, Int32, array<Byte>[]()[]) | Writes contents of flashData to an intel Hexfile

See Also

HexFileHelper Class
HexFileHelper Members
Zensys.ZWave.Programmer.Classes Namespace


WriteIntelHexFile Method (String, Byte[])

HexFileHelper..::.WriteIntelHexFile Method (String, array<Byte>[]()[])
HexFileHelper Class See Also

Writes the Intel HEX file.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static byte WriteIntelHexFile(
    string filename,
    byte[] flashData
)

Parameters

filename
Type: System..::.String
The filename.
flashData
Type: array<System..::.Byte>[]()[]
The flash data.

Return Value

See Also

HexFileHelper Class
WriteIntelHexFile Overload
Zensys.ZWave.Programmer.Classes Namespace


WriteIntelHexFile Method (String, Byte[], Byte)

HexFileHelper..::.WriteIntelHexFile Method (String, array<Byte>[]()[], Byte)
HexFileHelper Class See Also

Writes the Intel Hex file.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static byte WriteIntelHexFile(
    string filename,
    byte[] flashData,
    byte recLen
)

Parameters

filename
Type: System..::.String
The filename.
flashData
Type: array<System..::.Byte>[]()[]
The flash data.
recLen
Type: System..::.Byte
The rec len.

Return Value

See Also

HexFileHelper Class
WriteIntelHexFile Overload
Zensys.ZWave.Programmer.Classes Namespace


WriteIntelHexFile Method (Byte[], Int32, Int32, Byte[])

HexFileHelper..::.WriteIntelHexFile Method (array<Byte>[]()[], Int32, Int32, array<Byte>[]()[])
HexFileHelper Class See Also

Writes the Intel HEX file.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static string WriteIntelHexFile(
    byte[] flashData,
    int startAdr,
    int endAdr,
    params byte[] recTemp
)

Parameters

flashData
Type: array<System..::.Byte>[]()[]
The flash data.
startAdr
Type: System..::.Int32
The start adr.
endAdr
Type: System..::.Int32
The end adr.
recTemp
Type: array<System..::.Byte>[]()[]
The rec temp.

Return Value

See Also

HexFileHelper Class
WriteIntelHexFile Overload
Zensys.ZWave.Programmer.Classes Namespace


WriteIntelHexFile Method (String, Byte[], Int32, Int32, Byte[])

HexFileHelper..::.WriteIntelHexFile Method (String, array<Byte>[]()[], Int32, Int32, array<Byte>[]()[])
HexFileHelper Class See Also

Writes contents of flashData to an intel Hexfile

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static byte WriteIntelHexFile(
    string filename,
    byte[] flashData,
    int startAdr,
    int endAdr,
    params byte[] recTemp
)

Parameters

filename
Type: System..::.String
Name of file to create
flashData
Type: array<System..::.Byte>[]()[]
All the data is written to intel hex file
startAdr
Type: System..::.Int32
The offset to start the writing at
endAdr
Type: System..::.Int32
The highest adress to write to
recTemp
Type: array<System..::.Byte>[]()[]
Length of data records

Return Value

FILE_OPEN_ERROR if file exists, FILE_WRITTEN if ok

See Also

HexFileHelper Class
WriteIntelHexFile Overload
Zensys.ZWave.Programmer.Classes Namespace


ProgrammerConsole Class

ProgrammerConsole Class
Members See Also

ProgrammerConsole class. Contains methods for parsing command line arguments.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ProgrammerConsole

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.ProgrammerConsole

See Also

ProgrammerConsole Members
Zensys.ZWave.Programmer.Classes Namespace


ProgrammerConsole Members

[image]

Z-Wave Programmer reference library
ProgrammerConsole Members
ProgrammerConsole Class Constructors Methods See Also

The ProgrammerConsole type exposes the following members.

Constructors

Name | Description
ProgrammerConsole | Initializes a new instance of the ProgrammerConsole class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Usage | Usage method. Show help in console window.

See Also

ProgrammerConsole Class
Zensys.ZWave.Programmer.Classes Namespace


ProgrammerConsole Constructor

ProgrammerConsole Constructor
ProgrammerConsole Class See Also

Initializes a new instance of the ProgrammerConsole class.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ProgrammerConsole(
    ControllerManager controller
)

Parameters

controller
Type: Zensys.ZWave.Programmer.Controllers..::.ControllerManager
The controller.

See Also

ProgrammerConsole Class
Zensys.ZWave.Programmer.Classes Namespace


ProgrammerConsole Methods

[image]

Z-Wave Programmer reference library
ProgrammerConsole Methods
ProgrammerConsole Class See Also

The ProgrammerConsole type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Usage | Usage method. Show help in console window.

See Also

ProgrammerConsole Class
Zensys.ZWave.Programmer.Classes Namespace


Usage Method

ProgrammerConsole..::.Usage Method
ProgrammerConsole Class See Also

Usage method. Show help in console window.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Usage()

See Also

ProgrammerConsole Class
Zensys.ZWave.Programmer.Classes Namespace


ProgrammerSettings Class

ProgrammerSettings Class
Members See Also

ProgrammerSettings class. Contains application settings.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ProgrammerSettings

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.ProgrammerSettings

See Also

ProgrammerSettings Members
Zensys.ZWave.Programmer.Classes Namespace


ProgrammerSettings Members

[image]

Z-Wave Programmer reference library
ProgrammerSettings Members
ProgrammerSettings Class Constructors Methods Properties See Also

The ProgrammerSettings type exposes the following members.

Constructors

Name | Description
ProgrammerSettings |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Loads the application settings.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Save the application settings
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DetectTargetOnStartup | Gets or sets a value indicating whether Detect Target on Startup is set.
InterfaceFilter | Gets or sets the Interface filter (e.g. "Silicon Labs").
ShowHexFilesPath | Gets or sets a value indicating whether Show HEX files path.

See Also

ProgrammerSettings Class
Zensys.ZWave.Programmer.Classes Namespace


ProgrammerSettings Constructor

ProgrammerSettings Constructor
ProgrammerSettings Class See Also

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ProgrammerSettings()

See Also

ProgrammerSettings Class
Zensys.ZWave.Programmer.Classes Namespace


ProgrammerSettings Methods

[image]

Z-Wave Programmer reference library
ProgrammerSettings Methods
ProgrammerSettings Class See Also

The ProgrammerSettings type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Loads the application settings.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Save the application settings
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProgrammerSettings Class
Zensys.ZWave.Programmer.Classes Namespace


Load Method

ProgrammerSettings..::.Load Method
ProgrammerSettings Class See Also

Loads the application settings.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Load()

See Also

ProgrammerSettings Class
Zensys.ZWave.Programmer.Classes Namespace


Save Method

ProgrammerSettings..::.Save Method
ProgrammerSettings Class See Also

Save the application settings

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Save()

See Also

ProgrammerSettings Class
Zensys.ZWave.Programmer.Classes Namespace


ProgrammerSettings Properties

[image]

Z-Wave Programmer reference library
ProgrammerSettings Properties
ProgrammerSettings Class See Also

The ProgrammerSettings type exposes the following properties.

Properties

Name | Description
DetectTargetOnStartup | Gets or sets a value indicating whether Detect Target on Startup is set.
InterfaceFilter | Gets or sets the Interface filter (e.g. "Silicon Labs").
ShowHexFilesPath | Gets or sets a value indicating whether Show HEX files path.

See Also

ProgrammerSettings Class
Zensys.ZWave.Programmer.Classes Namespace


DetectTargetOnStartup Property

ProgrammerSettings..::.DetectTargetOnStartup Property
ProgrammerSettings Class See Also

Gets or sets a value indicating whether Detect Target on Startup is set.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public bool DetectTargetOnStartup { get; set; }

Field Value

true if Detect Target on Startup; otherwise, false.

See Also

ProgrammerSettings Class
Zensys.ZWave.Programmer.Classes Namespace


InterfaceFilter Property

ProgrammerSettings..::.InterfaceFilter Property
ProgrammerSettings Class See Also

Gets or sets the Interface filter (e.g. "Silicon Labs").

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string InterfaceFilter { get; set; }

Field Value

The Interface filter.

See Also

ProgrammerSettings Class
Zensys.ZWave.Programmer.Classes Namespace


ShowHexFilesPath Property

ProgrammerSettings..::.ShowHexFilesPath Property
ProgrammerSettings Class See Also

Gets or sets a value indicating whether Show HEX files path.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public bool ShowHexFilesPath { get; set; }

Field Value

true if Show hex files path; otherwise, false.

See Also

ProgrammerSettings Class
Zensys.ZWave.Programmer.Classes Namespace


SerialPortInfo Class

SerialPortInfo Class
Members See Also

SerialPortInfo class.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class SerialPortInfo

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Classes..::.SerialPortInfo

See Also

SerialPortInfo Members
Zensys.ZWave.Programmer.Classes Namespace


SerialPortInfo Members

[image]

Z-Wave Programmer reference library
SerialPortInfo Members
SerialPortInfo Class Constructors Methods Properties See Also

The SerialPortInfo type exposes the following members.

Constructors

Name | Description
SerialPortInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDevice | Gets the device.
GetDevices | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Availability | Gets the availability.
Binary | Gets the binary.
Caption | Gets the caption.
ConfigManagerErrorCode | Gets the config manager error code.
ConfigManagerUserConfig | Gets the config manager user config.
CreationClassName | Gets the name of the creation class.
Description | Gets the description.
DeviceID | Gets the device ID.
MaxBaudRate | Gets the max baud rate.
MaximumInputBufferSize | Gets the maximum size of the input buffer.
MaximumOutputBufferSize | Gets the maximum size of the output buffer.
Name | Gets the name.
OSAutoDiscovered | Gets the OS auto discovered.
PNPDeviceID | Gets the PNP device ID.
PowerManagementCapabilities | Gets the power management capabilities.
PowerManagementSupported | Gets the power management supported.
ProviderType | Gets the type of the provider.
SettableBaudRate | Gets the settable baud rate.
SettableDataBits | Gets the settable data bits.
SettableFlowControl | Gets the settable flow control.
SettableParity | Gets the settable parity.
SettableParityCheck | Gets the settable parity check.
SettableRLSD | Gets the settable RLSD.
SettableStopBits | Gets the settable stop bits.
Status | Gets the status.
StatusInfo | Gets the status info.
Supports16BitMode | Gets the supports 16 bit mode.
SupportsDTRDSR | Gets the supports DTRDSR.
SupportsElapsedTimeouts | Gets the supports elapsed timeouts.
SupportsIntTimeouts | Gets the supports int timeouts.
SupportsParityCheck | Gets the supports parity check.
SupportsRLSD | Gets the supports RLSD.
SupportsRTSCTS | Gets the supports RTSCTS.
SupportsSpecialCharacters | Gets the supports special characters.
SupportsXOnXOff | Gets the supports XOnXOff.
SupportsXOnXOffSet | Gets the supports XOnXOffSet.
SystemCreationClassName | Gets the name of the system creation class.
SystemName | Gets the name of the system.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SerialPortInfo Constructor

SerialPortInfo Constructor
SerialPortInfo Class See Also

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public SerialPortInfo()

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SerialPortInfo Methods

[image]

Z-Wave Programmer reference library
SerialPortInfo Methods
SerialPortInfo Class See Also

The SerialPortInfo type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDevice | Gets the device.
GetDevices | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


GetDevice Method

SerialPortInfo..::.GetDevice Method
SerialPortInfo Class See Also

Gets the device.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static SerialPortInfo GetDevice(
    string deviceId
)

Parameters

deviceId
Type: System..::.String
The device id.

Return Value

SerialPortInfo class.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


GetDevices Method

[image]

Z-Wave Programmer reference library
SerialPortInfo..::.GetDevices Method
SerialPortInfo Class See Also

Overload List

Name | Description
GetDevices()()() | Gets the devices.
GetDevices(String) | Gets the devices.

See Also

SerialPortInfo Class
SerialPortInfo Members
Zensys.ZWave.Programmer.Classes Namespace


GetDevices Method

SerialPortInfo..::.GetDevices Method
SerialPortInfo Class See Also

Gets the devices.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static List<SerialPortInfo> GetDevices()

Return Value

SerialPortInfo collection.

See Also

SerialPortInfo Class
GetDevices Overload
Zensys.ZWave.Programmer.Classes Namespace


GetDevices Method (String)

SerialPortInfo..::.GetDevices Method (String)
SerialPortInfo Class See Also

Gets the devices.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static List<SerialPortInfo> GetDevices(
    string condition
)

Parameters

condition
Type: System..::.String
The condition.

Return Value

SerialPortInfo collection.

See Also

SerialPortInfo Class
GetDevices Overload
Zensys.ZWave.Programmer.Classes Namespace


SerialPortInfo Properties

[image]

Z-Wave Programmer reference library
SerialPortInfo Properties
SerialPortInfo Class See Also

The SerialPortInfo type exposes the following properties.

Properties

Name | Description
Availability | Gets the availability.
Binary | Gets the binary.
Caption | Gets the caption.
ConfigManagerErrorCode | Gets the config manager error code.
ConfigManagerUserConfig | Gets the config manager user config.
CreationClassName | Gets the name of the creation class.
Description | Gets the description.
DeviceID | Gets the device ID.
MaxBaudRate | Gets the max baud rate.
MaximumInputBufferSize | Gets the maximum size of the input buffer.
MaximumOutputBufferSize | Gets the maximum size of the output buffer.
Name | Gets the name.
OSAutoDiscovered | Gets the OS auto discovered.
PNPDeviceID | Gets the PNP device ID.
PowerManagementCapabilities | Gets the power management capabilities.
PowerManagementSupported | Gets the power management supported.
ProviderType | Gets the type of the provider.
SettableBaudRate | Gets the settable baud rate.
SettableDataBits | Gets the settable data bits.
SettableFlowControl | Gets the settable flow control.
SettableParity | Gets the settable parity.
SettableParityCheck | Gets the settable parity check.
SettableRLSD | Gets the settable RLSD.
SettableStopBits | Gets the settable stop bits.
Status | Gets the status.
StatusInfo | Gets the status info.
Supports16BitMode | Gets the supports 16 bit mode.
SupportsDTRDSR | Gets the supports DTRDSR.
SupportsElapsedTimeouts | Gets the supports elapsed timeouts.
SupportsIntTimeouts | Gets the supports int timeouts.
SupportsParityCheck | Gets the supports parity check.
SupportsRLSD | Gets the supports RLSD.
SupportsRTSCTS | Gets the supports RTSCTS.
SupportsSpecialCharacters | Gets the supports special characters.
SupportsXOnXOff | Gets the supports XOnXOff.
SupportsXOnXOffSet | Gets the supports XOnXOffSet.
SystemCreationClassName | Gets the name of the system creation class.
SystemName | Gets the name of the system.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


Availability Property

SerialPortInfo..::.Availability Property
SerialPortInfo Class See Also

Gets the availability.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<ushort> Availability { get; }

Field Value

The availability.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


Binary Property

SerialPortInfo..::.Binary Property
SerialPortInfo Class See Also

Gets the binary.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> Binary { get; }

Field Value

The binary.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


Caption Property

SerialPortInfo..::.Caption Property
SerialPortInfo Class See Also

Gets the caption.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string Caption { get; }

Field Value

The caption.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


ConfigManagerErrorCode Property

SerialPortInfo..::.ConfigManagerErrorCode Property
SerialPortInfo Class See Also

Gets the config manager error code.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<uint> ConfigManagerErrorCode { get; }

Field Value

The config manager error code.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


ConfigManagerUserConfig Property

SerialPortInfo..::.ConfigManagerUserConfig Property
SerialPortInfo Class See Also

Gets the config manager user config.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> ConfigManagerUserConfig { get; }

Field Value

The config manager user config.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


CreationClassName Property

SerialPortInfo..::.CreationClassName Property
SerialPortInfo Class See Also

Gets the name of the creation class.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string CreationClassName { get; }

Field Value

The name of the creation class.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


Description Property

SerialPortInfo..::.Description Property
SerialPortInfo Class See Also

Gets the description.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string Description { get; }

Field Value

The description.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


DeviceID Property

SerialPortInfo..::.DeviceID Property
SerialPortInfo Class See Also

Gets the device ID.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string DeviceID { get; }

Field Value

The device ID.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


MaxBaudRate Property

SerialPortInfo..::.MaxBaudRate Property
SerialPortInfo Class See Also

Gets the max baud rate.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<uint> MaxBaudRate { get; }

Field Value

The max baud rate.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


MaximumInputBufferSize Property

SerialPortInfo..::.MaximumInputBufferSize Property
SerialPortInfo Class See Also

Gets the maximum size of the input buffer.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<uint> MaximumInputBufferSize { get; }

Field Value

The maximum size of the input buffer.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


MaximumOutputBufferSize Property

SerialPortInfo..::.MaximumOutputBufferSize Property
SerialPortInfo Class See Also

Gets the maximum size of the output buffer.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<uint> MaximumOutputBufferSize { get; }

Field Value

The maximum size of the output buffer.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


Name Property

SerialPortInfo..::.Name Property
SerialPortInfo Class See Also

Gets the name.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string Name { get; }

Field Value

The name.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


OSAutoDiscovered Property

SerialPortInfo..::.OSAutoDiscovered Property
SerialPortInfo Class See Also

Gets the OS auto discovered.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> OSAutoDiscovered { get; }

Field Value

The OS auto discovered.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


PNPDeviceID Property

SerialPortInfo..::.PNPDeviceID Property
SerialPortInfo Class See Also

Gets the PNP device ID.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string PNPDeviceID { get; }

Field Value

The PNP device ID.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


PowerManagementCapabilities Property

SerialPortInfo..::.PowerManagementCapabilities Property
SerialPortInfo Class See Also

Gets the power management capabilities.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ushort[] PowerManagementCapabilities { get; }

Field Value

The power management capabilities.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


PowerManagementSupported Property

SerialPortInfo..::.PowerManagementSupported Property
SerialPortInfo Class See Also

Gets the power management supported.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> PowerManagementSupported { get; }

Field Value

The power management supported.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


ProviderType Property

SerialPortInfo..::.ProviderType Property
SerialPortInfo Class See Also

Gets the type of the provider.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string ProviderType { get; }

Field Value

The type of the provider.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SettableBaudRate Property

SerialPortInfo..::.SettableBaudRate Property
SerialPortInfo Class See Also

Gets the settable baud rate.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SettableBaudRate { get; }

Field Value

The settable baud rate.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SettableDataBits Property

SerialPortInfo..::.SettableDataBits Property
SerialPortInfo Class See Also

Gets the settable data bits.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SettableDataBits { get; }

Field Value

The settable data bits.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SettableFlowControl Property

SerialPortInfo..::.SettableFlowControl Property
SerialPortInfo Class See Also

Gets the settable flow control.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SettableFlowControl { get; }

Field Value

The settable flow control.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SettableParity Property

SerialPortInfo..::.SettableParity Property
SerialPortInfo Class See Also

Gets the settable parity.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SettableParity { get; }

Field Value

The settable parity.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SettableParityCheck Property

SerialPortInfo..::.SettableParityCheck Property
SerialPortInfo Class See Also

Gets the settable parity check.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SettableParityCheck { get; }

Field Value

The settable parity check.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SettableRLSD Property

SerialPortInfo..::.SettableRLSD Property
SerialPortInfo Class See Also

Gets the settable RLSD.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SettableRLSD { get; }

Field Value

The settable RLSD.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SettableStopBits Property

SerialPortInfo..::.SettableStopBits Property
SerialPortInfo Class See Also

Gets the settable stop bits.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SettableStopBits { get; }

Field Value

The settable stop bits.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


Status Property

SerialPortInfo..::.Status Property
SerialPortInfo Class See Also

Gets the status.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string Status { get; }

Field Value

The status.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


StatusInfo Property

SerialPortInfo..::.StatusInfo Property
SerialPortInfo Class See Also

Gets the status info.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<ushort> StatusInfo { get; }

Field Value

The status info.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


Supports16BitMode Property

SerialPortInfo..::.Supports16BitMode Property
SerialPortInfo Class See Also

Gets the supports 16 bit mode.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> Supports16BitMode { get; }

Field Value

The supports 16 bit mode.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SupportsDTRDSR Property

SerialPortInfo..::.SupportsDTRDSR Property
SerialPortInfo Class See Also

Gets the supports DTRDSR.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SupportsDTRDSR { get; }

Field Value

The supports DTRDSR.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SupportsElapsedTimeouts Property

SerialPortInfo..::.SupportsElapsedTimeouts Property
SerialPortInfo Class See Also

Gets the supports elapsed timeouts.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SupportsElapsedTimeouts { get; }

Field Value

The supports elapsed timeouts.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SupportsIntTimeouts Property

SerialPortInfo..::.SupportsIntTimeouts Property
SerialPortInfo Class See Also

Gets the supports int timeouts.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SupportsIntTimeouts { get; }

Field Value

The supports int timeouts.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SupportsParityCheck Property

SerialPortInfo..::.SupportsParityCheck Property
SerialPortInfo Class See Also

Gets the supports parity check.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SupportsParityCheck { get; }

Field Value

The supports parity check.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SupportsRLSD Property

SerialPortInfo..::.SupportsRLSD Property
SerialPortInfo Class See Also

Gets the supports RLSD.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SupportsRLSD { get; }

Field Value

The supports RLSD.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SupportsRTSCTS Property

SerialPortInfo..::.SupportsRTSCTS Property
SerialPortInfo Class See Also

Gets the supports RTSCTS.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SupportsRTSCTS { get; }

Field Value

The supports RTSCTS.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SupportsSpecialCharacters Property

SerialPortInfo..::.SupportsSpecialCharacters Property
SerialPortInfo Class See Also

Gets the supports special characters.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SupportsSpecialCharacters { get; }

Field Value

The supports special characters.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SupportsXOnXOff Property

SerialPortInfo..::.SupportsXOnXOff Property
SerialPortInfo Class See Also

Gets the supports XOnXOff.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SupportsXOnXOff { get; }

Field Value

The supports XOnXOff.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SupportsXOnXOffSet Property

SerialPortInfo..::.SupportsXOnXOffSet Property
SerialPortInfo Class See Also

Gets the supports XOnXOffSet.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Nullable<bool> SupportsXOnXOffSet { get; }

Field Value

The supports XOnXOffSet.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SystemCreationClassName Property

SerialPortInfo..::.SystemCreationClassName Property
SerialPortInfo Class See Also

Gets the name of the system creation class.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string SystemCreationClassName { get; }

Field Value

The name of the system creation class.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


SystemName Property

SerialPortInfo..::.SystemName Property
SerialPortInfo Class See Also

Gets the name of the system.

Namespace: Zensys.ZWave.Programmer.Classes
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string SystemName { get; }

Field Value

The name of the system.

See Also

SerialPortInfo Class
Zensys.ZWave.Programmer.Classes Namespace


Zensys.ZWave.Programmer.Controllers Namespace

Zensys.ZWave.Programmer.Controllers Namespace

Classes

Class | Description
ControllerManager | ControllerManager class.


ControllerManager Class

ControllerManager Class
Members See Also

ControllerManager class.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ControllerManager : IDisposable

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Controllers..::.ControllerManager

See Also

ControllerManager Members
Zensys.ZWave.Programmer.Controllers Namespace


ControllerManager Members

[image]

Z-Wave Programmer reference library
ControllerManager Members
ControllerManager Class Methods Properties See Also

The ControllerManager type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RegisterView | Registers the view.
Start | Starts the application.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnregisterView | Unregisters the view.

Properties

Name | Description
Actions | Gets the actions. ActionCollection
ActiveView | Gets or sets the Active view.
ConsoleForm | Gets or sets the Console form.
DocumentModel | Gets the document model.
Instance | Gets the instance.
LogForm | Gets or sets the Log form.
MainForm | Gets or sets the Main Form.
ZW010xForm | Gets or sets the ZW010X form.
ZW020xForm | Gets or sets the ZW020X form.
ZW030xForm | Gets or sets the ZW030X form.
ZW040xForm | Gets or sets the ZW040X form.
ZWaveManager | Gets or sets the ZWave manager.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


ControllerManager Methods

[image]

Z-Wave Programmer reference library
ControllerManager Methods
ControllerManager Class See Also

The ControllerManager type exposes the following methods.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RegisterView | Registers the view.
Start | Starts the application.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnregisterView | Unregisters the view.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


Dispose Method

ControllerManager..::.Dispose Method
ControllerManager Class See Also

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


RegisterView Method

ControllerManager..::.RegisterView Method
ControllerManager Class See Also

Registers the view.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void RegisterView(
    IView view,
    IViewDispatcher dispatcher
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
dispatcher
Type: Zensys.Programmer.Interfaces..::.IViewDispatcher
The dispatcher.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


Start Method

ControllerManager..::.Start Method
ControllerManager Class See Also

Starts the application.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static void Start(
    string[] args
)

Parameters

args
Type: array<System..::.String>[]()[]
The args.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


UnregisterView Method

ControllerManager..::.UnregisterView Method
ControllerManager Class See Also

Unregisters the view.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void UnregisterView(
    IView view,
    IViewDispatcher dispatcher
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
dispatcher
Type: Zensys.Programmer.Interfaces..::.IViewDispatcher
The dispatcher.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


ControllerManager Properties

[image]

Z-Wave Programmer reference library
ControllerManager Properties
ControllerManager Class See Also

The ControllerManager type exposes the following properties.

Properties

Name | Description
Actions | Gets the actions. ActionCollection
ActiveView | Gets or sets the Active view.
ConsoleForm | Gets or sets the Console form.
DocumentModel | Gets the document model.
Instance | Gets the instance.
LogForm | Gets or sets the Log form.
MainForm | Gets or sets the Main Form.
ZW010xForm | Gets or sets the ZW010X form.
ZW020xForm | Gets or sets the ZW020X form.
ZW030xForm | Gets or sets the ZW030X form.
ZW040xForm | Gets or sets the ZW040X form.
ZWaveManager | Gets or sets the ZWave manager.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


Actions Property

ControllerManager..::.Actions Property
ControllerManager Class See Also

Gets the actions. ActionCollection

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ActionCollection Actions { get; }

Field Value

The actions.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


ActiveView Property

ControllerManager..::.ActiveView Property
ControllerManager Class See Also

Gets or sets the Active view.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public DockableView ActiveView { get; set; }

Field Value

The Active view.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


ConsoleForm Property

ControllerManager..::.ConsoleForm Property
ControllerManager Class See Also

Gets or sets the Console form.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ConsoleForm ConsoleForm { get; set; }

Field Value

The Console form.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


DocumentModel Property

ControllerManager..::.DocumentModel Property
ControllerManager Class See Also

Gets the document model.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public DocumentModel DocumentModel { get; }

Field Value

The document model.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


Instance Property

ControllerManager..::.Instance Property
ControllerManager Class See Also

Gets the instance.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public static ControllerManager Instance { get; }

Field Value

The instance.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


LogForm Property

ControllerManager..::.LogForm Property
ControllerManager Class See Also

Gets or sets the Log form.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public LogForm LogForm { get; set; }

Field Value

The Log form.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


MainForm Property

ControllerManager..::.MainForm Property
ControllerManager Class See Also

Gets or sets the Main Form.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public MainForm MainForm { get; set; }

Field Value

The main form.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


ZW010xForm Property

ControllerManager..::.ZW010xForm Property
ControllerManager Class See Also

Gets or sets the ZW010X form.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW010xForm ZW010xForm { get; set; }

Field Value

The ZW010X form.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


ZW020xForm Property

ControllerManager..::.ZW020xForm Property
ControllerManager Class See Also

Gets or sets the ZW020X form.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW020xForm ZW020xForm { get; set; }

Field Value

The ZW020X form.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


ZW030xForm Property

ControllerManager..::.ZW030xForm Property
ControllerManager Class See Also

Gets or sets the ZW030X form.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW030xForm ZW030xForm { get; set; }

Field Value

The ZW030X form.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


ZW040xForm Property

ControllerManager..::.ZW040xForm Property
ControllerManager Class See Also

Gets or sets the ZW040X form.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW040xForm ZW040xForm { get; set; }

Field Value

The ZW040X form.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


ZWaveManager Property

ControllerManager..::.ZWaveManager Property
ControllerManager Class See Also

Gets or sets the ZWave manager.

Namespace: Zensys.ZWave.Programmer.Controllers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZWaveManager ZWaveManager { get; set; }

Field Value

The Z wave manager.

See Also

ControllerManager Class
Zensys.ZWave.Programmer.Controllers Namespace


Zensys.ZWave.Programmer.Controls Namespace

Zensys.ZWave.Programmer.Controls Namespace

Classes

Class | Description
GradientWaitingBar |
HomeIdTextBox | HomeIdTextBox class. Implements HomeIdTextBox control.

Enumerations

Enumeration | Description
GradientWaitingBar..::.SCROLLGRADIENTALIGN | enum variable of align this control


GradientWaitingBar Class

GradientWaitingBar Class
Members See Also

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class GradientWaitingBar : Control

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
Zensys.ZWave.Programmer.Controls..::.GradientWaitingBar

See Also

GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


GradientWaitingBar Members

[image]

Z-Wave Programmer reference library
GradientWaitingBar Members
GradientWaitingBar Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The GradientWaitingBar type exposes the following members.

Constructors

Name | Description
GradientWaitingBar | Initializes a new instance of the GradientWaitingBar class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() event. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. if control is disabled, we do not display the gradient. (Overrides Control..::.OnEnabledChanged(EventArgs).)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. scroll the gradient bitmap (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. On Size changed, we make a new bitmap of current size (Overrides Control..::.OnSizeChanged(EventArgs).)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | Processes Windows messages. (Inherited from Control.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
GradientColor1 | property of begin color in linear gradient
GradientColor2 | property of end color in linear gradient
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Interval | Gets or sets the interval. property of timer
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScrollWAY | property of scrolling direction in control
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Speed | property of speed in scrolling.
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text associated with this control. (Inherited from Control.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


GradientWaitingBar Constructor

GradientWaitingBar Constructor
GradientWaitingBar Class See Also

Initializes a new instance of the GradientWaitingBar class.

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public GradientWaitingBar()

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


GradientWaitingBar Methods

[image]

Z-Wave Programmer reference library
GradientWaitingBar Methods
GradientWaitingBar Class See Also

The GradientWaitingBar type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() event. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. if control is disabled, we do not display the gradient. (Overrides Control..::.OnEnabledChanged(EventArgs).)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. scroll the gradient bitmap (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. On Size changed, we make a new bitmap of current size (Overrides Control..::.OnSizeChanged(EventArgs).)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | Processes Windows messages. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.AccessibilityNotifyClients Method
GradientWaitingBar Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.BeginInvoke Method
GradientWaitingBar Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.Dispose Method
GradientWaitingBar Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.GetChildAtPoint Method
GradientWaitingBar Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.Invalidate Method
GradientWaitingBar Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.Invoke Method
GradientWaitingBar Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.MemberwiseClone Method
GradientWaitingBar Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


OnEnabledChanged Method

GradientWaitingBar..::.OnEnabledChanged Method
GradientWaitingBar Class See Also

Raises the EnabledChanged event. if control is disabled, we do not display the gradient.

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void OnEnabledChanged(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
An EventArgs that contains the event data.

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


OnPaint Method

GradientWaitingBar..::.OnPaint Method
GradientWaitingBar Class See Also

Raises the Paint event. scroll the gradient bitmap

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


OnSizeChanged Method

GradientWaitingBar..::.OnSizeChanged Method
GradientWaitingBar Class See Also

Raises the SizeChanged event. On Size changed, we make a new bitmap of current size

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
An EventArgs that contains the event data.

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.PerformLayout Method
GradientWaitingBar Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.ResumeLayout Method
GradientWaitingBar Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.RtlTranslateAlignment Method
GradientWaitingBar Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


Scale Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.Scale Method
GradientWaitingBar Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


Select Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.Select Method
GradientWaitingBar Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.SetBounds Method
GradientWaitingBar Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
GradientWaitingBar..::.UpdateBounds Method
GradientWaitingBar Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

GradientWaitingBar Class
GradientWaitingBar Members
Zensys.ZWave.Programmer.Controls Namespace


GradientWaitingBar Properties

[image]

Z-Wave Programmer reference library
GradientWaitingBar Properties
GradientWaitingBar Class See Also

The GradientWaitingBar type exposes the following properties.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | Gets the default size of the control. (Inherited from Control.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
GradientColor1 | property of begin color in linear gradient
GradientColor2 | property of end color in linear gradient
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Interval | Gets or sets the interval. property of timer
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScrollWAY | property of scrolling direction in control
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Speed | property of speed in scrolling.
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the text associated with this control. (Inherited from Control.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


GradientColor1 Property

GradientWaitingBar..::.GradientColor1 Property
GradientWaitingBar Class See Also

property of begin color in linear gradient

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Color GradientColor1 { get; set; }

Field Value

The gradient color1.

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


GradientColor2 Property

GradientWaitingBar..::.GradientColor2 Property
GradientWaitingBar Class See Also

property of end color in linear gradient

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Color GradientColor2 { get; set; }

Field Value

The gradient color2.

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


Interval Property

GradientWaitingBar..::.Interval Property
GradientWaitingBar Class See Also

Gets or sets the interval. property of timer

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public int Interval { get; set; }

Field Value

The interval.

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


ScrollWAY Property

GradientWaitingBar..::.ScrollWAY Property
GradientWaitingBar Class See Also

property of scrolling direction in control

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public GradientWaitingBar..::.SCROLLGRADIENTALIGN ScrollWAY { get; set; }

Field Value

The scroll WAY.

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


Speed Property

GradientWaitingBar..::.Speed Property
GradientWaitingBar Class See Also

property of speed in scrolling.

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public int Speed { get; set; }

Field Value

The speed.

See Also

GradientWaitingBar Class
Zensys.ZWave.Programmer.Controls Namespace


GradientWaitingBar.SCROLLGRADIENTALIGN Enumeration

GradientWaitingBar..::.SCROLLGRADIENTALIGN Enumeration
GradientWaitingBar Class See Also

enum variable of align this control

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public enum SCROLLGRADIENTALIGN

Members

Member name | Description
HORIZONTAL |
VERTICAL |

See Also

Zensys.ZWave.Programmer.Controls Namespace


HomeIdTextBox Class

HomeIdTextBox Class
Members See Also

HomeIdTextBox class. Implements HomeIdTextBox control.

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class HomeIdTextBox : TextBox

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.TextBoxBase
System.Windows.Forms..::.TextBox
Zensys.ZWave.Programmer.Controls..::.HomeIdTextBox

See Also

HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


HomeIdTextBox Members

[image]

Z-Wave Programmer reference library
HomeIdTextBox Members
HomeIdTextBox Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also

The HomeIdTextBox type exposes the following members.

Constructors

Name | Description
HomeIdTextBox |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Clear | Clears all text from the text box control. (Inherited from TextBoxBase.)
ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | (Inherited from TextBoxBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from TextBoxBase.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from TextBoxBase.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from TextBoxBase.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from TextBox.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAcceptsTabChanged | Raises the AcceptsTabChanged event. (Inherited from TextBoxBase.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from TextBox.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnBorderStyleChanged | Raises the BorderStyleChanged event. (Inherited from TextBoxBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() event. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from TextBox.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from TextBox.)
OnHandleCreated | (Inherited from TextBox.)
OnHandleDestroyed | (Inherited from TextBox.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnHideSelectionChanged | Raise the HideSelectionChanged event. (Inherited from TextBoxBase.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Overrides Control..::.OnLeave(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Overrides Control..::.OnLostFocus(EventArgs).)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnModifiedChanged | Raises the ModifiedChanged event. (Inherited from TextBoxBase.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | (Inherited from TextBoxBase.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnMultilineChanged | Raises the MultilineChanged event. (Inherited from TextBoxBase.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | This method is not relevant for this class. (Inherited from TextBoxBase.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnReadOnlyChanged | Raises the ReadOnlyChanged event. (Inherited from TextBoxBase.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextAlignChanged | Raises the TextAlignChanged event. (Inherited from TextBox.)
OnTextChanged | (Inherited from TextBoxBase.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Paste | Overloaded.
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Gets a value indicating the state of the ShortcutsEnabled property. (Inherited from TextBoxBase.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | (Inherited from TextBoxBase.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | (Inherited from Control.)
ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
Select | Overloaded.
SelectAll | Selects all text in the text box. (Inherited from TextBoxBase.)
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Sets the specified bounds of the TextBoxBase control. (Inherited from TextBoxBase.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
Undo | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from TextBox.)

Fields

Name | Description
MAX_ARRAY_LENGTH | MAX_ARRAY_LENGTH constant.
MAX_TEXT_LENGTH | MAX_TEXT_LENGTH constant.

Properties

Name | Description
AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox.)
AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from TextBox.)
AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from TextBox.)
AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from TextBox.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. This property is not relevant for this class. (Inherited from TextBoxBase.)
BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
BackgroundImage | This property is not relevant for this class. (Inherited from TextBoxBase.)
BackgroundImageLayout | This property is not relevant for this class. (Inherited from TextBoxBase.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from TextBoxBase.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from TextBox.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from TextBox.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from TextBoxBase.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from TextBoxBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from TextBoxBase.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from TextBoxBase.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Overrides TextBoxBase..::.MaxLength.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from TextBox.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from TextBox.)
PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox.)
SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase.)
SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase.)
SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the current text in the TextBox. (Inherited from TextBox.)
TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox.)
TextLength | Gets the length of text in the control. (Inherited from TextBoxBase.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from TextBox.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)
WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)

Events

Name | Description
AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from TextBox.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

HomeIdTextBox Class
Zensys.ZWave.Programmer.Controls Namespace


HomeIdTextBox Constructor

HomeIdTextBox Constructor
HomeIdTextBox Class See Also

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public HomeIdTextBox()

See Also

HomeIdTextBox Class
Zensys.ZWave.Programmer.Controls Namespace


HomeIdTextBox Fields

[image]

Z-Wave Programmer reference library
HomeIdTextBox Fields
HomeIdTextBox Class See Also

The HomeIdTextBox type exposes the following fields.

Fields

Name | Description
MAX_ARRAY_LENGTH | MAX_ARRAY_LENGTH constant.
MAX_TEXT_LENGTH | MAX_TEXT_LENGTH constant.

See Also

HomeIdTextBox Class
Zensys.ZWave.Programmer.Controls Namespace


MAX_ARRAY_LENGTH Field

HomeIdTextBox..::.MAX_ARRAY_LENGTH Field
HomeIdTextBox Class See Also

MAX_ARRAY_LENGTH constant.

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public const int MAX_ARRAY_LENGTH

See Also

HomeIdTextBox Class
Zensys.ZWave.Programmer.Controls Namespace


MAX_TEXT_LENGTH Field

HomeIdTextBox..::.MAX_TEXT_LENGTH Field
HomeIdTextBox Class See Also

MAX_TEXT_LENGTH constant.

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public const int MAX_TEXT_LENGTH

See Also

HomeIdTextBox Class
Zensys.ZWave.Programmer.Controls Namespace


HomeIdTextBox Methods

[image]

Z-Wave Programmer reference library
HomeIdTextBox Methods
HomeIdTextBox Class See Also

The HomeIdTextBox type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Clear | Clears all text from the text box control. (Inherited from TextBoxBase.)
ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | (Inherited from TextBoxBase.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from TextBoxBase.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from TextBoxBase.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from TextBoxBase.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is an input key or a special key that requires preprocessing. (Inherited from TextBox.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAcceptsTabChanged | Raises the AcceptsTabChanged event. (Inherited from TextBoxBase.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from TextBox.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnBorderStyleChanged | Raises the BorderStyleChanged event. (Inherited from TextBoxBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() event. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from TextBox.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from TextBox.)
OnHandleCreated | (Inherited from TextBox.)
OnHandleDestroyed | (Inherited from TextBox.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnHideSelectionChanged | Raise the HideSelectionChanged event. (Inherited from TextBoxBase.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Overrides Control..::.OnLeave(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Overrides Control..::.OnLostFocus(EventArgs).)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnModifiedChanged | Raises the ModifiedChanged event. (Inherited from TextBoxBase.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | (Inherited from TextBoxBase.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnMultilineChanged | Raises the MultilineChanged event. (Inherited from TextBoxBase.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | This method is not relevant for this class. (Inherited from TextBoxBase.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnReadOnlyChanged | Raises the ReadOnlyChanged event. (Inherited from TextBoxBase.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextAlignChanged | Raises the TextAlignChanged event. (Inherited from TextBox.)
OnTextChanged | (Inherited from TextBoxBase.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Paste | Overloaded.
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Gets a value indicating the state of the ShortcutsEnabled property. (Inherited from TextBoxBase.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | (Inherited from TextBoxBase.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | (Inherited from Control.)
ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
Select | Overloaded.
SelectAll | Selects all text in the text box. (Inherited from TextBoxBase.)
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Sets the specified bounds of the TextBoxBase control. (Inherited from TextBoxBase.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
Undo | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from TextBox.)

Explicit Interface Implementations

Name | Description
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

HomeIdTextBox Class
Zensys.ZWave.Programmer.Controls Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.AccessibilityNotifyClients Method
HomeIdTextBox Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.BeginInvoke Method
HomeIdTextBox Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.Dispose Method
HomeIdTextBox Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the TextBox and optionally releases the managed resources. (Inherited from TextBox.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.GetChildAtPoint Method
HomeIdTextBox Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.Invalidate Method
HomeIdTextBox Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.Invoke Method
HomeIdTextBox Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.MemberwiseClone Method
HomeIdTextBox Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


OnLeave Method

HomeIdTextBox..::.OnLeave Method
HomeIdTextBox Class See Also

Raises the Leave event.

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void OnLeave(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
An EventArgs that contains the event data.

See Also

HomeIdTextBox Class
Zensys.ZWave.Programmer.Controls Namespace


OnLostFocus Method

HomeIdTextBox..::.OnLostFocus Method
HomeIdTextBox Class See Also

Raises the LostFocus event.

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void OnLostFocus(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
An EventArgs that contains the event data.

See Also

HomeIdTextBox Class
Zensys.ZWave.Programmer.Controls Namespace


Paste Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.Paste Method
HomeIdTextBox Class See Also

Overload List

Name | Description
Paste()()() | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
Paste(String) | Replaces the specified selection in the TextBox with the contents of the Clipboard. (Inherited from TextBox.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.PerformLayout Method
HomeIdTextBox Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.ResumeLayout Method
HomeIdTextBox Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.RtlTranslateAlignment Method
HomeIdTextBox Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


Scale Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.Scale Method
HomeIdTextBox Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


Select Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.Select Method
HomeIdTextBox Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.SetBounds Method
HomeIdTextBox Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
HomeIdTextBox..::.UpdateBounds Method
HomeIdTextBox Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

HomeIdTextBox Class
HomeIdTextBox Members
Zensys.ZWave.Programmer.Controls Namespace


HomeIdTextBox Properties

[image]

Z-Wave Programmer reference library
HomeIdTextBox Properties
HomeIdTextBox Class See Also

The HomeIdTextBox type exposes the following properties.

Properties

Name | Description
AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox.)
AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from TextBox.)
AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from TextBox.)
AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from TextBox.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. This property is not relevant for this class. (Inherited from TextBoxBase.)
BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
BackgroundImage | This property is not relevant for this class. (Inherited from TextBoxBase.)
BackgroundImageLayout | This property is not relevant for this class. (Inherited from TextBoxBase.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from TextBoxBase.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from TextBox.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from TextBox.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from TextBoxBase.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from TextBoxBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether control drawing is done in a buffer before the control is displayed. This property is not relevant for this class. (Inherited from TextBoxBase.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from TextBoxBase.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Overrides TextBoxBase..::.MaxLength.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from TextBox.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from TextBox.)
PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox.)
SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase.)
SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase.)
SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or sets the current text in the TextBox. (Inherited from TextBox.)
TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox.)
TextLength | Gets the length of text in the control. (Inherited from TextBoxBase.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from TextBox.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)
WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)

See Also

HomeIdTextBox Class
Zensys.ZWave.Programmer.Controls Namespace


MaxLength Property

HomeIdTextBox..::.MaxLength Property
HomeIdTextBox Class See Also

Gets or sets the maximum number of characters the user can type or paste into the text box control.

Namespace: Zensys.ZWave.Programmer.Controls
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public override int MaxLength { get; set; }

Field Value

Return Value

The number of characters that can be entered into the control. The default is 32767.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The value assigned to the property is less than 0.

See Also

HomeIdTextBox Class
Zensys.ZWave.Programmer.Controls Namespace


Zensys.ZWave.Programmer.Dispatchers Namespace

Zensys.ZWave.Programmer.Dispatchers Namespace

Classes

Class | Description
ConsoleFormDispatcher | ConsoleFormDispatcher class. Bind/Unbind functions to the Console Form controls.
LogFormDispatcher | LogFormDispatcher class. Bind/Unbind functions to the Log Form controls.
MainFormDispatcher | MainFormDispatcher class. Bind/Unbind functions to the Main Form controls.
ZW010xFormDispatcher | ZW010xFormDispatcher class. Bind/Unbind functions to the ZW010x Form controls.
ZW020xFormDispatcher | ZW020xFormDispatcher class. Bind/Unbind functions to the ZW020x Form controls.
ZW030xFormDispatcher | ZW030xFormDispatcher class. Bind/Unbind functions to the ZW030x Form controls.
ZW040xFormDispatcher | ZW040xFormDispatcher class. Bind/Unbind functions to the ZW040x Form controls.


ConsoleFormDispatcher Class

ConsoleFormDispatcher Class
Members See Also

ConsoleFormDispatcher class. Bind/Unbind functions to the Console Form controls.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ConsoleFormDispatcher : IViewDispatcher

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Dispatchers..::.ConsoleFormDispatcher

See Also

ConsoleFormDispatcher Members
Zensys.ZWave.Programmer.Dispatchers Namespace


ConsoleFormDispatcher Members

[image]

Z-Wave Programmer reference library
ConsoleFormDispatcher Members
ConsoleFormDispatcher Class Constructors Methods See Also

The ConsoleFormDispatcher type exposes the following members.

Constructors

Name | Description
ConsoleFormDispatcher |

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConsoleFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ConsoleFormDispatcher Constructor

ConsoleFormDispatcher Constructor
ConsoleFormDispatcher Class See Also

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ConsoleFormDispatcher()

See Also

ConsoleFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ConsoleFormDispatcher Methods

[image]

Z-Wave Programmer reference library
ConsoleFormDispatcher Methods
ConsoleFormDispatcher Class See Also

The ConsoleFormDispatcher type exposes the following methods.

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConsoleFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Bind Method

ConsoleFormDispatcher..::.Bind Method
ConsoleFormDispatcher Class See Also

Binds the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Bind(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Bind(IView, ActionCollection)

See Also

ConsoleFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Drop Method

ConsoleFormDispatcher..::.Drop Method
ConsoleFormDispatcher Class See Also

Drops the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Drop(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Drop(IView, ActionCollection)

See Also

ConsoleFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


LogFormDispatcher Class

LogFormDispatcher Class
Members See Also

LogFormDispatcher class. Bind/Unbind functions to the Log Form controls.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class LogFormDispatcher : IViewDispatcher

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Dispatchers..::.LogFormDispatcher

See Also

LogFormDispatcher Members
Zensys.ZWave.Programmer.Dispatchers Namespace


LogFormDispatcher Members

[image]

Z-Wave Programmer reference library
LogFormDispatcher Members
LogFormDispatcher Class Constructors Methods See Also

The LogFormDispatcher type exposes the following members.

Constructors

Name | Description
LogFormDispatcher |

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


LogFormDispatcher Constructor

LogFormDispatcher Constructor
LogFormDispatcher Class See Also

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public LogFormDispatcher()

See Also

LogFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


LogFormDispatcher Methods

[image]

Z-Wave Programmer reference library
LogFormDispatcher Methods
LogFormDispatcher Class See Also

The LogFormDispatcher type exposes the following methods.

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Bind Method

LogFormDispatcher..::.Bind Method
LogFormDispatcher Class See Also

Binds the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Bind(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Bind(IView, ActionCollection)

See Also

LogFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Drop Method

LogFormDispatcher..::.Drop Method
LogFormDispatcher Class See Also

Drops the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Drop(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Drop(IView, ActionCollection)

See Also

LogFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


MainFormDispatcher Class

MainFormDispatcher Class
Members See Also

MainFormDispatcher class. Bind/Unbind functions to the Main Form controls.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class MainFormDispatcher : IViewDispatcher

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Dispatchers..::.MainFormDispatcher

See Also

MainFormDispatcher Members
Zensys.ZWave.Programmer.Dispatchers Namespace


MainFormDispatcher Members

[image]

Z-Wave Programmer reference library
MainFormDispatcher Members
MainFormDispatcher Class Constructors Methods See Also

The MainFormDispatcher type exposes the following members.

Constructors

Name | Description
MainFormDispatcher |

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MainFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


MainFormDispatcher Constructor

MainFormDispatcher Constructor
MainFormDispatcher Class See Also

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public MainFormDispatcher()

See Also

MainFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


MainFormDispatcher Methods

[image]

Z-Wave Programmer reference library
MainFormDispatcher Methods
MainFormDispatcher Class See Also

The MainFormDispatcher type exposes the following methods.

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MainFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Bind Method

MainFormDispatcher..::.Bind Method
MainFormDispatcher Class See Also

Binds the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Bind(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Bind(IView, ActionCollection)

See Also

MainFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Drop Method

MainFormDispatcher..::.Drop Method
MainFormDispatcher Class See Also

Drops the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Drop(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Drop(IView, ActionCollection)

See Also

MainFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW010xFormDispatcher Class

ZW010xFormDispatcher Class
Members See Also

ZW010xFormDispatcher class. Bind/Unbind functions to the ZW010x Form controls.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW010xFormDispatcher : IViewDispatcher

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Dispatchers..::.ZW010xFormDispatcher

See Also

ZW010xFormDispatcher Members
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW010xFormDispatcher Members

[image]

Z-Wave Programmer reference library
ZW010xFormDispatcher Members
ZW010xFormDispatcher Class Constructors Methods See Also

The ZW010xFormDispatcher type exposes the following members.

Constructors

Name | Description
ZW010xFormDispatcher |

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW010xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW010xFormDispatcher Constructor

ZW010xFormDispatcher Constructor
ZW010xFormDispatcher Class See Also

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW010xFormDispatcher()

See Also

ZW010xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW010xFormDispatcher Methods

[image]

Z-Wave Programmer reference library
ZW010xFormDispatcher Methods
ZW010xFormDispatcher Class See Also

The ZW010xFormDispatcher type exposes the following methods.

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW010xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Bind Method

ZW010xFormDispatcher..::.Bind Method
ZW010xFormDispatcher Class See Also

Binds the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Bind(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Bind(IView, ActionCollection)

See Also

ZW010xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Drop Method

ZW010xFormDispatcher..::.Drop Method
ZW010xFormDispatcher Class See Also

Drops the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Drop(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Drop(IView, ActionCollection)

See Also

ZW010xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW020xFormDispatcher Class

ZW020xFormDispatcher Class
Members See Also

ZW020xFormDispatcher class. Bind/Unbind functions to the ZW020x Form controls.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW020xFormDispatcher : IViewDispatcher

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Dispatchers..::.ZW020xFormDispatcher

See Also

ZW020xFormDispatcher Members
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW020xFormDispatcher Members

[image]

Z-Wave Programmer reference library
ZW020xFormDispatcher Members
ZW020xFormDispatcher Class Constructors Methods See Also

The ZW020xFormDispatcher type exposes the following members.

Constructors

Name | Description
ZW020xFormDispatcher |

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW020xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW020xFormDispatcher Constructor

ZW020xFormDispatcher Constructor
ZW020xFormDispatcher Class See Also

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW020xFormDispatcher()

See Also

ZW020xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW020xFormDispatcher Methods

[image]

Z-Wave Programmer reference library
ZW020xFormDispatcher Methods
ZW020xFormDispatcher Class See Also

The ZW020xFormDispatcher type exposes the following methods.

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW020xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Bind Method

ZW020xFormDispatcher..::.Bind Method
ZW020xFormDispatcher Class See Also

Binds the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Bind(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Bind(IView, ActionCollection)

See Also

ZW020xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Drop Method

ZW020xFormDispatcher..::.Drop Method
ZW020xFormDispatcher Class See Also

Drops the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Drop(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Drop(IView, ActionCollection)

See Also

ZW020xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW030xFormDispatcher Class

ZW030xFormDispatcher Class
Members See Also

ZW030xFormDispatcher class. Bind/Unbind functions to the ZW030x Form controls.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW030xFormDispatcher : IViewDispatcher

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Dispatchers..::.ZW030xFormDispatcher

See Also

ZW030xFormDispatcher Members
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW030xFormDispatcher Members

[image]

Z-Wave Programmer reference library
ZW030xFormDispatcher Members
ZW030xFormDispatcher Class Constructors Methods See Also

The ZW030xFormDispatcher type exposes the following members.

Constructors

Name | Description
ZW030xFormDispatcher |

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW030xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW030xFormDispatcher Constructor

ZW030xFormDispatcher Constructor
ZW030xFormDispatcher Class See Also

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW030xFormDispatcher()

See Also

ZW030xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW030xFormDispatcher Methods

[image]

Z-Wave Programmer reference library
ZW030xFormDispatcher Methods
ZW030xFormDispatcher Class See Also

The ZW030xFormDispatcher type exposes the following methods.

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW030xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Bind Method

ZW030xFormDispatcher..::.Bind Method
ZW030xFormDispatcher Class See Also

Binds the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Bind(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Bind(IView, ActionCollection)

See Also

ZW030xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Drop Method

ZW030xFormDispatcher..::.Drop Method
ZW030xFormDispatcher Class See Also

Drops the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Drop(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Drop(IView, ActionCollection)

See Also

ZW030xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW040xFormDispatcher Class

ZW040xFormDispatcher Class
Members See Also

ZW040xFormDispatcher class. Bind/Unbind functions to the ZW040x Form controls.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW040xFormDispatcher : IViewDispatcher

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Dispatchers..::.ZW040xFormDispatcher

See Also

ZW040xFormDispatcher Members
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW040xFormDispatcher Members

[image]

Z-Wave Programmer reference library
ZW040xFormDispatcher Members
ZW040xFormDispatcher Class Constructors Methods See Also

The ZW040xFormDispatcher type exposes the following members.

Constructors

Name | Description
ZW040xFormDispatcher |

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW040xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW040xFormDispatcher Constructor

ZW040xFormDispatcher Constructor
ZW040xFormDispatcher Class See Also

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW040xFormDispatcher()

See Also

ZW040xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


ZW040xFormDispatcher Methods

[image]

Z-Wave Programmer reference library
ZW040xFormDispatcher Methods
ZW040xFormDispatcher Class See Also

The ZW040xFormDispatcher type exposes the following methods.

Methods

Name | Description
Bind | Binds the functions to the specified view.
Drop | Drops the functions to the specified view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZW040xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Bind Method

ZW040xFormDispatcher..::.Bind Method
ZW040xFormDispatcher Class See Also

Binds the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Bind(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Bind(IView, ActionCollection)

See Also

ZW040xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Drop Method

ZW040xFormDispatcher..::.Drop Method
ZW040xFormDispatcher Class See Also

Drops the functions to the specified view.

Namespace: Zensys.ZWave.Programmer.Dispatchers
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public void Drop(
    IView view,
    ActionCollection actions
)

Parameters

view
Type: Zensys.Programmer.Interfaces..::.IView
The view.
actions
Type: Zensys.ZWave.Programmer.Classes..::.ActionCollection
The actions (functions).

Implements

IViewDispatcher..::.Drop(IView, ActionCollection)

See Also

ZW040xFormDispatcher Class
Zensys.ZWave.Programmer.Dispatchers Namespace


Zensys.ZWave.Programmer.Models Namespace

Zensys.ZWave.Programmer.Models Namespace

Classes

Class | Description
DocumentModel | DocumentModel class. Implements application model class.


DocumentModel Class

DocumentModel Class
Members See Also

DocumentModel class. Implements application model class.

Namespace: Zensys.ZWave.Programmer.Models
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class DocumentModel

Inheritance Hierarchy

System..::.Object
Zensys.ZWave.Programmer.Models..::.DocumentModel

See Also

DocumentModel Members
Zensys.ZWave.Programmer.Models Namespace


DocumentModel Members

[image]

Z-Wave Programmer reference library
DocumentModel Members
DocumentModel Class Constructors Methods Properties See Also

The DocumentModel type exposes the following members.

Constructors

Name | Description
DocumentModel | Initializes a new instance of the DocumentModel class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsAsic | Gets or sets a value indicating whether application is in ASIC mode.
PortInfo | Gets or sets the Port Info.
SelectedChipType | Gets or sets the type of the Selected chip.
Settings | Gets or sets the Settings.

See Also

DocumentModel Class
Zensys.ZWave.Programmer.Models Namespace


DocumentModel Constructor

DocumentModel Constructor
DocumentModel Class See Also

Initializes a new instance of the DocumentModel class.

Namespace: Zensys.ZWave.Programmer.Models
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public DocumentModel()

See Also

DocumentModel Class
Zensys.ZWave.Programmer.Models Namespace


DocumentModel Properties

[image]

Z-Wave Programmer reference library
DocumentModel Properties
DocumentModel Class See Also

The DocumentModel type exposes the following properties.

Properties

Name | Description
IsAsic | Gets or sets a value indicating whether application is in ASIC mode.
PortInfo | Gets or sets the Port Info.
SelectedChipType | Gets or sets the type of the Selected chip.
Settings | Gets or sets the Settings.

See Also

DocumentModel Class
Zensys.ZWave.Programmer.Models Namespace


IsAsic Property

DocumentModel..::.IsAsic Property
DocumentModel Class See Also

Gets or sets a value indicating whether application is in ASIC mode.

Namespace: Zensys.ZWave.Programmer.Models
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public bool IsAsic { get; set; }

Field Value

true if application is in ASIC mode; otherwise, false.

See Also

DocumentModel Class
Zensys.ZWave.Programmer.Models Namespace


PortInfo Property

DocumentModel..::.PortInfo Property
DocumentModel Class See Also

Gets or sets the Port Info.

Namespace: Zensys.ZWave.Programmer.Models
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public SerialPortInfo PortInfo { get; set; }

Field Value

The port info.

See Also

DocumentModel Class
Zensys.ZWave.Programmer.Models Namespace


SelectedChipType Property

DocumentModel..::.SelectedChipType Property
DocumentModel Class See Also

Gets or sets the type of the Selected chip.

Namespace: Zensys.ZWave.Programmer.Models
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public byte SelectedChipType { get; set; }

Field Value

The type of the Selected chip.

See Also

DocumentModel Class
Zensys.ZWave.Programmer.Models Namespace


Settings Property

DocumentModel..::.Settings Property
DocumentModel Class See Also

Gets or sets the Settings.

Namespace: Zensys.ZWave.Programmer.Models
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ProgrammerSettings Settings { get; set; }

Field Value

The Settings.

See Also

DocumentModel Class
Zensys.ZWave.Programmer.Models Namespace


Zensys.ZWave.Programmer.UI Namespace

Zensys.ZWave.Programmer.UI Namespace

Classes

Class | Description
ConsoleForm | ConsoleForm class. Represents the Console View.
LogForm | LogForm class. Represents the Log View.
MainForm | Main Form class.
ProgressForm | ProgressForm class.
SettingsForm | SettingsForm class. Represents the Settings View.
ZW010xForm | ZW010xForm class. Represents the ZW010x View
ZW020xForm | ZW020xForm class. Represents the ZW020x View
ZW030xForm | ZW030xForm class. Represents the ZW030x View
ZW040xForm | ZW040xForm class. Represents the ZW040x View


ConsoleForm Class

ConsoleForm Class
Members See Also

ConsoleForm class. Represents the Console View.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ConsoleForm : DockableView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
DockContent
Zensys.ZWave.Programmer.Classes..::.DockableView
Zensys.ZWave.Programmer.UI..::.ConsoleForm

See Also

ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


ConsoleForm Members

[image]

Z-Wave Programmer reference library
ConsoleForm Members
ConsoleForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The ConsoleForm type exposes the following members.

Constructors

Name | Description
ConsoleForm | Initializes a new instance of the ConsoleForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DockStyle | Gets or sets the dock style. (Inherited from DockableView.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewContainer | Gets or sets the form. (Inherited from DockableView.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ConsoleForm Class
Zensys.ZWave.Programmer.UI Namespace


ConsoleForm Constructor

ConsoleForm Constructor
ConsoleForm Class See Also

Initializes a new instance of the ConsoleForm class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ConsoleForm()

See Also

ConsoleForm Class
Zensys.ZWave.Programmer.UI Namespace


ConsoleForm Methods

[image]

Z-Wave Programmer reference library
ConsoleForm Methods
ConsoleForm Class See Also

The ConsoleForm type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ConsoleForm Class
Zensys.ZWave.Programmer.UI Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.AccessibilityNotifyClients Method
ConsoleForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.BeginInvoke Method
ConsoleForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.Dispose Method
ConsoleForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method (Boolean)

ConsoleForm..::.Dispose Method (Boolean)
ConsoleForm Class See Also

Clean up any resources being used.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ConsoleForm Class
Dispose Overload
Zensys.ZWave.Programmer.UI Namespace


DockTo Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.DockTo Method
ConsoleForm Class See Also

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.GetChildAtPoint Method
ConsoleForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.Invalidate Method
ConsoleForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.Invoke Method
ConsoleForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.MemberwiseClone Method
ConsoleForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.PerformLayout Method
ConsoleForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.ResumeLayout Method
ConsoleForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.RtlTranslateAlignment Method
ConsoleForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


Scale Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.Scale Method
ConsoleForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


Select Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.Select Method
ConsoleForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.SetBounds Method
ConsoleForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


Show Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.Show Method
ConsoleForm Class See Also

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


ShowDialog Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.ShowDialog Method
ConsoleForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.UpdateBounds Method
ConsoleForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


Validate Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.Validate Method
ConsoleForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


ValidateChildren Method

[image]

Z-Wave Programmer reference library
ConsoleForm..::.ValidateChildren Method
ConsoleForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ConsoleForm Class
ConsoleForm Members
Zensys.ZWave.Programmer.UI Namespace


LogForm Class

LogForm Class
Members See Also

LogForm class. Represents the Log View.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class LogForm : DockableView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
DockContent
Zensys.ZWave.Programmer.Classes..::.DockableView
Zensys.ZWave.Programmer.UI..::.LogForm

See Also

LogForm Members
Zensys.ZWave.Programmer.UI Namespace


LogForm Members

[image]

Z-Wave Programmer reference library
LogForm Members
LogForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The LogForm type exposes the following members.

Constructors

Name | Description
LogForm | Initializes a new instance of the LogForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DockStyle | Gets or sets the dock style. (Inherited from DockableView.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewContainer | Gets or sets the form. (Inherited from DockableView.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

LogForm Class
Zensys.ZWave.Programmer.UI Namespace


LogForm Constructor

LogForm Constructor
LogForm Class See Also

Initializes a new instance of the LogForm class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public LogForm()

See Also

LogForm Class
Zensys.ZWave.Programmer.UI Namespace


LogForm Methods

[image]

Z-Wave Programmer reference library
LogForm Methods
LogForm Class See Also

The LogForm type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

LogForm Class
Zensys.ZWave.Programmer.UI Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
LogForm..::.AccessibilityNotifyClients Method
LogForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
LogForm..::.BeginInvoke Method
LogForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
LogForm..::.Dispose Method
LogForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method (Boolean)

LogForm..::.Dispose Method (Boolean)
LogForm Class See Also

Clean up any resources being used.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

LogForm Class
Dispose Overload
Zensys.ZWave.Programmer.UI Namespace


DockTo Method

[image]

Z-Wave Programmer reference library
LogForm..::.DockTo Method
LogForm Class See Also

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
LogForm..::.GetChildAtPoint Method
LogForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
LogForm..::.Invalidate Method
LogForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
LogForm..::.Invoke Method
LogForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
LogForm..::.MemberwiseClone Method
LogForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
LogForm..::.PerformLayout Method
LogForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
LogForm..::.ResumeLayout Method
LogForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
LogForm..::.RtlTranslateAlignment Method
LogForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


Scale Method

[image]

Z-Wave Programmer reference library
LogForm..::.Scale Method
LogForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


Select Method

[image]

Z-Wave Programmer reference library
LogForm..::.Select Method
LogForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
LogForm..::.SetBounds Method
LogForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


Show Method

[image]

Z-Wave Programmer reference library
LogForm..::.Show Method
LogForm Class See Also

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


ShowDialog Method

[image]

Z-Wave Programmer reference library
LogForm..::.ShowDialog Method
LogForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
LogForm..::.UpdateBounds Method
LogForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


Validate Method

[image]

Z-Wave Programmer reference library
LogForm..::.Validate Method
LogForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


ValidateChildren Method

[image]

Z-Wave Programmer reference library
LogForm..::.ValidateChildren Method
LogForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

LogForm Class
LogForm Members
Zensys.ZWave.Programmer.UI Namespace


MainForm Class

MainForm Class
Members See Also

Main Form class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class MainForm : Form, IView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
Zensys.ZWave.Programmer.UI..::.MainForm

See Also

MainForm Members
Zensys.ZWave.Programmer.UI Namespace


MainForm Members

[image]

Z-Wave Programmer reference library
MainForm Members
MainForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The MainForm type exposes the following members.

Constructors

Name | Description
MainForm | Initializes a new instance of the MainForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockStyle | Gets or sets the dock style.
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewContainer | Gets or sets the form.
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

MainForm Class
Zensys.ZWave.Programmer.UI Namespace


MainForm Constructor

MainForm Constructor
MainForm Class See Also

Initializes a new instance of the MainForm class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public MainForm()

See Also

MainForm Class
Zensys.ZWave.Programmer.UI Namespace


MainForm Methods

[image]

Z-Wave Programmer reference library
MainForm Methods
MainForm Class See Also

The MainForm type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

MainForm Class
Zensys.ZWave.Programmer.UI Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
MainForm..::.AccessibilityNotifyClients Method
MainForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
MainForm..::.BeginInvoke Method
MainForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
MainForm..::.Dispose Method
MainForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method (Boolean)

MainForm..::.Dispose Method (Boolean)
MainForm Class See Also

Clean up any resources being used.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

MainForm Class
Dispose Overload
Zensys.ZWave.Programmer.UI Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
MainForm..::.GetChildAtPoint Method
MainForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
MainForm..::.Invalidate Method
MainForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
MainForm..::.Invoke Method
MainForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
MainForm..::.MemberwiseClone Method
MainForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
MainForm..::.PerformLayout Method
MainForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
MainForm..::.ResumeLayout Method
MainForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
MainForm..::.RtlTranslateAlignment Method
MainForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


Scale Method

[image]

Z-Wave Programmer reference library
MainForm..::.Scale Method
MainForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


Select Method

[image]

Z-Wave Programmer reference library
MainForm..::.Select Method
MainForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
MainForm..::.SetBounds Method
MainForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


Show Method

[image]

Z-Wave Programmer reference library
MainForm..::.Show Method
MainForm Class See Also

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


ShowDialog Method

[image]

Z-Wave Programmer reference library
MainForm..::.ShowDialog Method
MainForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
MainForm..::.UpdateBounds Method
MainForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


Validate Method

[image]

Z-Wave Programmer reference library
MainForm..::.Validate Method
MainForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


ValidateChildren Method

[image]

Z-Wave Programmer reference library
MainForm..::.ValidateChildren Method
MainForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

MainForm Class
MainForm Members
Zensys.ZWave.Programmer.UI Namespace


MainForm Properties

[image]

Z-Wave Programmer reference library
MainForm Properties
MainForm Class See Also

The MainForm type exposes the following properties.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockStyle | Gets or sets the dock style.
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewContainer | Gets or sets the form.
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

MainForm Class
Zensys.ZWave.Programmer.UI Namespace


DockStyle Property

MainForm..::.DockStyle Property
MainForm Class See Also

Gets or sets the dock style.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public DockStyle DockStyle { get; set; }

Field Value

The dock style.

Implements

IView..::.DockStyle

See Also

MainForm Class
Zensys.ZWave.Programmer.UI Namespace


ViewContainer Property

MainForm..::.ViewContainer Property
MainForm Class See Also

Gets or sets the form.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Form ViewContainer { get; }

Field Value

The form.

Implements

IView..::.ViewContainer

See Also

MainForm Class
Zensys.ZWave.Programmer.UI Namespace


ProgressForm Class

ProgressForm Class
Members See Also

ProgressForm class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ProgressForm : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
Zensys.ZWave.Programmer.UI..::.ProgressForm

See Also

ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


ProgressForm Members

[image]

Z-Wave Programmer reference library
ProgressForm Members
ProgressForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The ProgressForm type exposes the following members.

Constructors

Name | Description
ProgressForm | Initializes a new instance of the ProgressForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
ProgressDelegate | Gets or sets the execute delegate.
ProgressInfo | Gets or sets the Progress info text.
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ProgressForm Class
Zensys.ZWave.Programmer.UI Namespace


ProgressForm Constructor

ProgressForm Constructor
ProgressForm Class See Also

Initializes a new instance of the ProgressForm class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ProgressForm()

See Also

ProgressForm Class
Zensys.ZWave.Programmer.UI Namespace


ProgressForm Methods

[image]

Z-Wave Programmer reference library
ProgressForm Methods
ProgressForm Class See Also

The ProgressForm type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ProgressForm Class
Zensys.ZWave.Programmer.UI Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.AccessibilityNotifyClients Method
ProgressForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.BeginInvoke Method
ProgressForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.Dispose Method
ProgressForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method (Boolean)

ProgressForm..::.Dispose Method (Boolean)
ProgressForm Class See Also

Clean up any resources being used.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ProgressForm Class
Dispose Overload
Zensys.ZWave.Programmer.UI Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.GetChildAtPoint Method
ProgressForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.Invalidate Method
ProgressForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.Invoke Method
ProgressForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.MemberwiseClone Method
ProgressForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.PerformLayout Method
ProgressForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.ResumeLayout Method
ProgressForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.RtlTranslateAlignment Method
ProgressForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


Scale Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.Scale Method
ProgressForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


Select Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.Select Method
ProgressForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.SetBounds Method
ProgressForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


Show Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.Show Method
ProgressForm Class See Also

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


ShowDialog Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.ShowDialog Method
ProgressForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.UpdateBounds Method
ProgressForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


Validate Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.Validate Method
ProgressForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


ValidateChildren Method

[image]

Z-Wave Programmer reference library
ProgressForm..::.ValidateChildren Method
ProgressForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ProgressForm Class
ProgressForm Members
Zensys.ZWave.Programmer.UI Namespace


ProgressForm Properties

[image]

Z-Wave Programmer reference library
ProgressForm Properties
ProgressForm Class See Also

The ProgressForm type exposes the following properties.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
ProgressDelegate | Gets or sets the execute delegate.
ProgressInfo | Gets or sets the Progress info text.
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

ProgressForm Class
Zensys.ZWave.Programmer.UI Namespace


ProgressDelegate Property

ProgressForm..::.ProgressDelegate Property
ProgressForm Class See Also

Gets or sets the execute delegate.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public Delegate ProgressDelegate { get; set; }

Field Value

The progress delegate.

See Also

ProgressForm Class
Zensys.ZWave.Programmer.UI Namespace


ProgressInfo Property

ProgressForm..::.ProgressInfo Property
ProgressForm Class See Also

Gets or sets the Progress info text.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public string ProgressInfo { get; set; }

Field Value

The progress info.

See Also

ProgressForm Class
Zensys.ZWave.Programmer.UI Namespace


SettingsForm Class

SettingsForm Class
Members See Also

SettingsForm class. Represents the Settings View.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class SettingsForm : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
Zensys.ZWave.Programmer.UI..::.SettingsForm

See Also

SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


SettingsForm Members

[image]

Z-Wave Programmer reference library
SettingsForm Members
SettingsForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The SettingsForm type exposes the following members.

Constructors

Name | Description
SettingsForm | Initializes a new instance of the SettingsForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedPortInfo | Gets or sets the Selected Port Info.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
OnLoadInterfaces | Occurs when Load Interfaces called.
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SettingsForm Class
Zensys.ZWave.Programmer.UI Namespace


SettingsForm Constructor

SettingsForm Constructor
SettingsForm Class See Also

Initializes a new instance of the SettingsForm class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public SettingsForm()

See Also

SettingsForm Class
Zensys.ZWave.Programmer.UI Namespace


SettingsForm Methods

[image]

Z-Wave Programmer reference library
SettingsForm Methods
SettingsForm Class See Also

The SettingsForm type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SettingsForm Class
Zensys.ZWave.Programmer.UI Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.AccessibilityNotifyClients Method
SettingsForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.BeginInvoke Method
SettingsForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.Dispose Method
SettingsForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method (Boolean)

SettingsForm..::.Dispose Method (Boolean)
SettingsForm Class See Also

Clean up any resources being used.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SettingsForm Class
Dispose Overload
Zensys.ZWave.Programmer.UI Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.GetChildAtPoint Method
SettingsForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.Invalidate Method
SettingsForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.Invoke Method
SettingsForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.MemberwiseClone Method
SettingsForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.PerformLayout Method
SettingsForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.ResumeLayout Method
SettingsForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.RtlTranslateAlignment Method
SettingsForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


Scale Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.Scale Method
SettingsForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


Select Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.Select Method
SettingsForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.SetBounds Method
SettingsForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


Show Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.Show Method
SettingsForm Class See Also

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


ShowDialog Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.ShowDialog Method
SettingsForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.UpdateBounds Method
SettingsForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


Validate Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.Validate Method
SettingsForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


ValidateChildren Method

[image]

Z-Wave Programmer reference library
SettingsForm..::.ValidateChildren Method
SettingsForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

SettingsForm Class
SettingsForm Members
Zensys.ZWave.Programmer.UI Namespace


SettingsForm Properties

[image]

Z-Wave Programmer reference library
SettingsForm Properties
SettingsForm Class See Also

The SettingsForm type exposes the following properties.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedPortInfo | Gets or sets the Selected Port Info.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

SettingsForm Class
Zensys.ZWave.Programmer.UI Namespace


SelectedPortInfo Property

SettingsForm..::.SelectedPortInfo Property
SettingsForm Class See Also

Gets or sets the Selected Port Info.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public SerialPortInfo SelectedPortInfo { get; set; }

Field Value

The Selected Port Info.

See Also

SettingsForm Class
Zensys.ZWave.Programmer.UI Namespace


SettingsForm Events

[image]

Z-Wave Programmer reference library
SettingsForm Events
SettingsForm Class See Also

The SettingsForm type exposes the following events.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
OnLoadInterfaces | Occurs when Load Interfaces called.
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SettingsForm Class
Zensys.ZWave.Programmer.UI Namespace


OnLoadInterfaces Event

SettingsForm..::.OnLoadInterfaces Event
SettingsForm Class See Also

Occurs when Load Interfaces called.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public event EventHandler OnLoadInterfaces

See Also

SettingsForm Class
Zensys.ZWave.Programmer.UI Namespace


ZW010xForm Class

ZW010xForm Class
Members See Also

ZW010xForm class. Represents the ZW010x View

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW010xForm : DockableView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
DockContent
Zensys.ZWave.Programmer.Classes..::.DockableView
Zensys.ZWave.Programmer.UI..::.ZW010xForm

See Also

ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


ZW010xForm Members

[image]

Z-Wave Programmer reference library
ZW010xForm Members
ZW010xForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The ZW010xForm type exposes the following members.

Constructors

Name | Description
ZW010xForm | Initializes a new instance of the ZW010xForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DockStyle | Gets or sets the dock style. (Inherited from DockableView.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewContainer | Gets or sets the form. (Inherited from DockableView.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ZW010xForm Class
Zensys.ZWave.Programmer.UI Namespace


ZW010xForm Constructor

ZW010xForm Constructor
ZW010xForm Class See Also

Initializes a new instance of the ZW010xForm class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW010xForm()

See Also

ZW010xForm Class
Zensys.ZWave.Programmer.UI Namespace


ZW010xForm Methods

[image]

Z-Wave Programmer reference library
ZW010xForm Methods
ZW010xForm Class See Also

The ZW010xForm type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ZW010xForm Class
Zensys.ZWave.Programmer.UI Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.AccessibilityNotifyClients Method
ZW010xForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.BeginInvoke Method
ZW010xForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.Dispose Method
ZW010xForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method (Boolean)

ZW010xForm..::.Dispose Method (Boolean)
ZW010xForm Class See Also

Clean up any resources being used.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ZW010xForm Class
Dispose Overload
Zensys.ZWave.Programmer.UI Namespace


DockTo Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.DockTo Method
ZW010xForm Class See Also

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.GetChildAtPoint Method
ZW010xForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.Invalidate Method
ZW010xForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.Invoke Method
ZW010xForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.MemberwiseClone Method
ZW010xForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.PerformLayout Method
ZW010xForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.ResumeLayout Method
ZW010xForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.RtlTranslateAlignment Method
ZW010xForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


Scale Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.Scale Method
ZW010xForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


Select Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.Select Method
ZW010xForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.SetBounds Method
ZW010xForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


Show Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.Show Method
ZW010xForm Class See Also

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


ShowDialog Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.ShowDialog Method
ZW010xForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.UpdateBounds Method
ZW010xForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


Validate Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.Validate Method
ZW010xForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


ValidateChildren Method

[image]

Z-Wave Programmer reference library
ZW010xForm..::.ValidateChildren Method
ZW010xForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ZW010xForm Class
ZW010xForm Members
Zensys.ZWave.Programmer.UI Namespace


ZW020xForm Class

ZW020xForm Class
Members See Also

ZW020xForm class. Represents the ZW020x View

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW020xForm : DockableView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
DockContent
Zensys.ZWave.Programmer.Classes..::.DockableView
Zensys.ZWave.Programmer.UI..::.ZW020xForm

See Also

ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


ZW020xForm Members

[image]

Z-Wave Programmer reference library
ZW020xForm Members
ZW020xForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The ZW020xForm type exposes the following members.

Constructors

Name | Description
ZW020xForm | Initializes a new instance of the ZW020xForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DockStyle | Gets or sets the dock style. (Inherited from DockableView.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewContainer | Gets or sets the form. (Inherited from DockableView.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ZW020xForm Class
Zensys.ZWave.Programmer.UI Namespace


ZW020xForm Constructor

ZW020xForm Constructor
ZW020xForm Class See Also

Initializes a new instance of the ZW020xForm class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW020xForm()

See Also

ZW020xForm Class
Zensys.ZWave.Programmer.UI Namespace


ZW020xForm Methods

[image]

Z-Wave Programmer reference library
ZW020xForm Methods
ZW020xForm Class See Also

The ZW020xForm type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ZW020xForm Class
Zensys.ZWave.Programmer.UI Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.AccessibilityNotifyClients Method
ZW020xForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.BeginInvoke Method
ZW020xForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.Dispose Method
ZW020xForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method (Boolean)

ZW020xForm..::.Dispose Method (Boolean)
ZW020xForm Class See Also

Clean up any resources being used.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ZW020xForm Class
Dispose Overload
Zensys.ZWave.Programmer.UI Namespace


DockTo Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.DockTo Method
ZW020xForm Class See Also

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.GetChildAtPoint Method
ZW020xForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.Invalidate Method
ZW020xForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.Invoke Method
ZW020xForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.MemberwiseClone Method
ZW020xForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.PerformLayout Method
ZW020xForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.ResumeLayout Method
ZW020xForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.RtlTranslateAlignment Method
ZW020xForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


Scale Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.Scale Method
ZW020xForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


Select Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.Select Method
ZW020xForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.SetBounds Method
ZW020xForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


Show Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.Show Method
ZW020xForm Class See Also

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


ShowDialog Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.ShowDialog Method
ZW020xForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.UpdateBounds Method
ZW020xForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


Validate Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.Validate Method
ZW020xForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


ValidateChildren Method

[image]

Z-Wave Programmer reference library
ZW020xForm..::.ValidateChildren Method
ZW020xForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ZW020xForm Class
ZW020xForm Members
Zensys.ZWave.Programmer.UI Namespace


ZW030xForm Class

ZW030xForm Class
Members See Also

ZW030xForm class. Represents the ZW030x View

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW030xForm : DockableView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
DockContent
Zensys.ZWave.Programmer.Classes..::.DockableView
Zensys.ZWave.Programmer.UI..::.ZW030xForm

See Also

ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


ZW030xForm Members

[image]

Z-Wave Programmer reference library
ZW030xForm Members
ZW030xForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The ZW030xForm type exposes the following members.

Constructors

Name | Description
ZW030xForm | Initializes a new instance of the ZW030xForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DockStyle | Gets or sets the dock style. (Inherited from DockableView.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewContainer | Gets or sets the form. (Inherited from DockableView.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ZW030xForm Class
Zensys.ZWave.Programmer.UI Namespace


ZW030xForm Constructor

ZW030xForm Constructor
ZW030xForm Class See Also

Initializes a new instance of the ZW030xForm class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW030xForm()

See Also

ZW030xForm Class
Zensys.ZWave.Programmer.UI Namespace


ZW030xForm Methods

[image]

Z-Wave Programmer reference library
ZW030xForm Methods
ZW030xForm Class See Also

The ZW030xForm type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ZW030xForm Class
Zensys.ZWave.Programmer.UI Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.AccessibilityNotifyClients Method
ZW030xForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.BeginInvoke Method
ZW030xForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.Dispose Method
ZW030xForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method (Boolean)

ZW030xForm..::.Dispose Method (Boolean)
ZW030xForm Class See Also

Clean up any resources being used.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ZW030xForm Class
Dispose Overload
Zensys.ZWave.Programmer.UI Namespace


DockTo Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.DockTo Method
ZW030xForm Class See Also

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.GetChildAtPoint Method
ZW030xForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.Invalidate Method
ZW030xForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.Invoke Method
ZW030xForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.MemberwiseClone Method
ZW030xForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.PerformLayout Method
ZW030xForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.ResumeLayout Method
ZW030xForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.RtlTranslateAlignment Method
ZW030xForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


Scale Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.Scale Method
ZW030xForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


Select Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.Select Method
ZW030xForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.SetBounds Method
ZW030xForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


Show Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.Show Method
ZW030xForm Class See Also

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


ShowDialog Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.ShowDialog Method
ZW030xForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.UpdateBounds Method
ZW030xForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


Validate Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.Validate Method
ZW030xForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


ValidateChildren Method

[image]

Z-Wave Programmer reference library
ZW030xForm..::.ValidateChildren Method
ZW030xForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ZW030xForm Class
ZW030xForm Members
Zensys.ZWave.Programmer.UI Namespace


ZW040xForm Class

ZW040xForm Class
Members See Also

ZW040xForm class. Represents the ZW040x View

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public class ZW040xForm : DockableView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
DockContent
Zensys.ZWave.Programmer.Classes..::.DockableView
Zensys.ZWave.Programmer.UI..::.ZW040xForm

See Also

ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


ZW040xForm Members

[image]

Z-Wave Programmer reference library
ZW040xForm Members
ZW040xForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The ZW040xForm type exposes the following members.

Constructors

Name | Description
ZW040xForm | Initializes a new instance of the ZW040xForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DockStyle | Gets or sets the dock style. (Inherited from DockableView.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewContainer | Gets or sets the form. (Inherited from DockableView.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ZW040xForm Class
Zensys.ZWave.Programmer.UI Namespace


ZW040xForm Constructor

ZW040xForm Constructor
ZW040xForm Class See Also

Initializes a new instance of the ZW040xForm class.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
public ZW040xForm()

See Also

ZW040xForm Class
Zensys.ZWave.Programmer.UI Namespace


ZW040xForm Methods

[image]

Z-Wave Programmer reference library
ZW040xForm Methods
ZW040xForm Class See Also

The ZW040xForm type exposes the following methods.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Overrides OnLayout method. (Inherited from DockableView.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ZW040xForm Class
Zensys.ZWave.Programmer.UI Namespace


AccessibilityNotifyClients Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.AccessibilityNotifyClients Method
ZW040xForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


BeginInvoke Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.BeginInvoke Method
ZW040xForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.Dispose Method
ZW040xForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


Dispose Method (Boolean)

ZW040xForm..::.Dispose Method (Boolean)
ZW040xForm Class See Also

Clean up any resources being used.

Namespace: Zensys.ZWave.Programmer.UI
Assembly: ZWaveProgrammer (in ZWaveProgrammer.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ZW040xForm Class
Dispose Overload
Zensys.ZWave.Programmer.UI Namespace


DockTo Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.DockTo Method
ZW040xForm Class See Also

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


GetChildAtPoint Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.GetChildAtPoint Method
ZW040xForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


Invalidate Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.Invalidate Method
ZW040xForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


Invoke Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.Invoke Method
ZW040xForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


MemberwiseClone Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.MemberwiseClone Method
ZW040xForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


PerformLayout Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.PerformLayout Method
ZW040xForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


ResumeLayout Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.ResumeLayout Method
ZW040xForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


RtlTranslateAlignment Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.RtlTranslateAlignment Method
ZW040xForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


Scale Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.Scale Method
ZW040xForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


Select Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.Select Method
ZW040xForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


SetBounds Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.SetBounds Method
ZW040xForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


Show Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.Show Method
ZW040xForm Class See Also

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


ShowDialog Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.ShowDialog Method
ZW040xForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


UpdateBounds Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.UpdateBounds Method
ZW040xForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


Validate Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.Validate Method
ZW040xForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


ValidateChildren Method

[image]

Z-Wave Programmer reference library
ZW040xForm..::.ValidateChildren Method
ZW040xForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ZW040xForm Class
ZW040xForm Members
Zensys.ZWave.Programmer.UI Namespace


Z-Wave Programmer API References

Zensys A/S Z-Wave Programmer API References

Zensys USB Z-Wave Programmer for flash programming of the Z-Wave 100/200/300/400 Series Single Chips.

The Z-Wave Programmer support also programming of the external EEPROM on the Z-Wave modules.

Finally, can the Z-Wave Programmer also be used to configure transmission power and RF settings on the Z-Wave modules.