Introduction

简介

STK502是Atmel公司生产的STK500开发板的扩展模块。它新增加了对64引脚的AVR单片机(带有LCD接口和不带有LCD接口)的支持功能。所支持的AVR单片机型号清单请参阅 所支持的器件 。 利用STK502 上的一些连接接口和硬件装备，可以充分发挥出这些器件的新特性，比如零阻力插入（Zero Insertion Force，ZIF）插槽可以很方便的使用 TQFP 封装的器件。 这个用户说明是个总体的说明并且对于高级用户来说也是一份完整的技术参考。 STK502实验开发板还带有一个演示用的范例应用，此外还有基于ATmega169应用的两份操作说明书：“AVR064: STK502-A Temperature Monitoring System with LCD Output”和“AVR065: LCD Driver for the STK502” 这些操作说明书解释了如何使用器件的不同模块。套件中还有一块预编程的 ATmega169。把它安装到 ZIF 插槽中，示例程序就会立刻运行。

图 1.1 STK500的扩展模块STK502

特性：

  • 支持内建有LCD控制器的64引脚的AVR器件。

  • 带有用来演示LCD控制器的LCD显示器。

  • 由AVR Studio 4支持。

  • 适用于TQFP封装的，ZIF（Zero Insertion Force）插槽。

  • 支持高电压并行编程模式。

  • 支持串行编程模式。

  • 适用于仿真适配器的TQFP焊盘。

  • 扩展了端口连接接口：端口E、F和G。

  • LCD显示器插头，可以用于连接外部的LCD显示器。

  • LCD 和其它外围设备都可以从设备上分离。

  • 支持使用 JTAG ICE或者JTAG mkII* 进行在线调试的 JTAG 接口。

  • 板上32 kHz 晶振可以实现简易实时时钟。

  • 用于演示范例应用的温度传感器。

  • 在PCB的丝印上有全部开关和短路片的简易参考。

  • 带有范例的预编程的 ATmega169。在ATmega169内有给出所有主要外围设备使用的C-代码示例。

*在本帮助文档中有关JTAG ICE的描述同样适用于JTAGICE mkII。

AVR技术图书馆CD，作为STK502实验开发板中的一部分，包含有以下内容：

  • STK502用户向导。

  • “AVR064 STK502 - A Temperature Monitoring System with LCD Output”操作说明书。这份操作说明书详细描述了预编程的ATmega169中的范例。

  • AVR064的源代码。

  • “AVR065: LCD Driver for the STK502 LCD”操作说明书。这份操作说明书通过一个例子详细描述了如何使用内建的LCD控制器。

  • AVR065的源代码。

  • 一个测试版本的IAR编译器，可以用于编译范例程序的源代码。

上述提到的操作说明书以及源代码都可以在 www.atmel.com网站上找到。

快速查找：

STK502的综述

  • 简介

  • 疑难解答

  • 所支持的器件

  • 入门指导

  • 端口插座

对AVR器件进行编程

  • 串行编程

  • 并行编程

  • JTAGICE的连接接口

LCD显示器

  • 如何使用LCD显示器

选项设置

  • TOSC开关

  • 传感器、ARFE和PF[1:0]开关

附录

  • LCD技术规范说明书

  • LCD位映射

  • 完整的电原理图1

  • 完整的电原理图2

  • 完整的电原理图3

  • 装配简图


疑难解答

2002年11月4日。

没有疑难解答

回首页


STK502 Supported Devices

所支持的器件

STK502支持所有的64引脚的AVR器件（带有LCD控制器以及不带有LCD控制器） 。目前STK502支持以下器件：

-ATmega165

-ATmega169 （LCD）

-ATmega325

-ATmega329 （LCD）

-ATmega645

-ATmega649 （LCD）


入门指导

这部分将详细说明如何将STK500与STK502连接在一起使用。

将STK502连接到STK500实验开发板

将STK502与STK500板上的expansion插头0和1连接。把扩展模块按照图2-1所示的正确方位进行连接，这点非常重要。STK502扩展模块上标记着EXPAND0的插头必须插在STK500板上标记着EXPAND0 的插座里。

图 2-1: STK502与STK500的连接

注意： 按照错误的方向连接STK502与STK500会损坏实验板。

安装AVR器件到STK502板上

STK502有一个ZIP插槽和一个适用于TQFP封装形式的焊盘,该焊盘的使用提供了一种将仿真适配器直接焊接到STK502上的简单方法。注意器件（或是适配器）的放置方向。ZIF插座和TQFP焊盘的1号引脚的位置如图2-2所示。

图 2-2: ZIF插槽和TQFP焊盘的1号引脚

当心： 不要在已经有一个AVR器件安装在STK500评估板上的同时，再在STK502板上安装AVR器件。如果安装了多个AVR器件，这些AVR器件都不会按照设想的工作。


Port Connectors

端口连接接口

STK502板支持的AVR器件新增了STK500上没有的端口，因此STK502板上新增了这些端口的接口。它们有着跟STK500评估板上端口连接接口一样的引脚和功能。PORTA到PORTD端口在STK500板上已经有了，因此在STK502实验板上没有这几个端口的连接接口。

端口E/F

下图是I/O端口插头端口E和端口F的引脚描述。

图 2-3： 普通的I/O端口

注意： 端口E的接口在STK500上已经有了，但是只是PE0到PE2（3个最低有效位）。如果要使用完整的端口E，还是必须要使用STK502上的端口连接接口。

端口G/RST

除了普通的端口G的引脚，这个连接接口还有一个RESET-信号引脚。

图 2-4: 端口G/RST

PG0-PG4

这些普通I/O端口引脚直接连接到ZIF插槽和TQFP焊盘。

RST

“RST-STK500”是从STK500板上连过来的RESET信号引脚，“RST-STK502”是连接到ZIF插座和TQFP-64焊盘的RESET信号引脚。将这两个引脚用短路片连接起来。

图 2-5: 端口G /RST上的RESET信号引脚


Programming the ATmega169

对AVR器件进行编程

简介

AVR器件有两种编程方式：SPI编程和高电压并行编程。以下部分将要说明在使用这两种编程方式时如何使用编程转接线进行正确的连接。AVR Studio STK500软件和以往的使用方法一样，详情请参阅STK500帮助手册。

注意： STK502支持的AVR器件都支持自编程，更多有关该主题的信息，请参阅操作说明书AVR109。

注意： 在任何编程进行前，必须在端口G的复位信号（引脚5和引脚7）安装短路片。

在系统编程

图 2-6： 在系统编程

在使用ISP编程模式对AVR器件进行编程时，需要按照图2-6所示的，用6芯的连接线将STK500评估板上的ISP6PIN接口与STK502板上的ISP接口连接起来。连接好后，就可以使用AVR Studio STK500软件中的串行编程模式对该器件进行编程。

注意： 更多有关如何使用STK500管理软件进行ISP编程的信息，请参阅STK500用户手册。

高电压编程

图 2-7： 高电压编程

在使用高电压编程模式对AVR器件进行编程时，需要按照图2-7所示，分别将STK500评估板上的 PROGCTRL与PORTD、PROGDATA与PORTB连接起来。

确保TOSC开关放置在XTAL位置。点击 这里 查看有关TOSC开关的说明信息

为了对ATmega器件进行高电压编程，必须按照STK500用户向导中（短路片设置章节）说明的，安装BSEL2短路片。在使用高电压编程模式时，这个设置对于STK502支持的其他AVR器件同样适用。

现在可以使用AVR Studio STK500软件中的高电压编程模式对该器件进行编程了。

注意： 更多有关如何使用STK500管理软件进行高电压编程的信息，请参阅STK500用户手册。

注意： 在高电压编程模式下，要能正确运行，目标电压必须要高于4.5V。

当心： 确保在进行并行编程时，断开LCD显示器的连接。否则将会缩短LCD显示器的寿命。


JTAGICE Connection

JTAGICE的连接接口

图 2-8 向我们展示了如何将JTAG ICE连接到STK502板上。

图 2-8： JTAG ICE与STK502的连接

JTAG接口是提供给本身带有JTAG接口的AVR器件使用的。JTAG连接接口的引脚如图2-9所示，它和其他可以从Atmel公司获得的JTAG ICE的引脚是相兼容的。将JTAG ICE连接到这个接口，就可以使用外部仿真器进行在系统仿真。

更多有关JTAG ICE和AVR片上调试系统的信息，请参阅JTAG ICE用户手册，您可以从Atmel网站： www.atmel.com获得该手册。

Figure 2-9 : JTAG连接接口


LCD

STK502板上有一块LCD液晶显示器（Liquid Crystal Display）。它由6个14-段的数字和其他一些附加的段组成。该显示器总共有120个段。它的工作电压设置在3V。更多有关显示器的信息请参阅技术规范说明。

您可以从下面的网站单独订购STK502上的LCD显示器：

ACTE 挪威（Norway） www.acte.no

电话号码：+47 63 89 89 00

传真：+47 63 87 90 00

电子邮件： info@acte.no

价格： 99,- NOK

订购型号： H4042-DL DE5156/L。

STK502板载LCD与LCD AVR器件的连接

LCD AVR器件的段引脚设置在端口A、端口C、端口D和端口G。为了方便使用，已经将这些引脚整合成了一个标记为“Segment pins from ATmega169”的插头。在这个插头的旁边，有一个标记着“STK502 LCD pins”的插头，该插头包含了STK502板载LCD的全部段引脚。您使用STK502配套的34-芯连接线，可以把这两个插头连在一起，这样LCD AVR器件就可以控制STK502板载的LCD显示器了。见图2-10。

图 2-10： LCD AVR器件和STK502板载LCD的连接

小心： 高电压编程会使用到端口B和端口D。在使用高电压编程前，请确保断开LCD显示器与AVR器件的连接。否则会大大缩短LCD显示器的寿命。

小心： 当把端口A、端口C、端口D或者端口G用作一般的I/O端口时，请相应地断开与AVR器件连接的LCD段引脚。

缺省段配置

64引脚的LCD AVR器件支持100个段。这样就使得LCD显示器上的120个段不能同时显示。LCD显示器上的30个段引脚中的5个没有连接。这些没有连接的LCD引脚是引脚#： 3、24、30、31和32。有关未连接的段的详情，请参阅技术规范说明。

如果您要使用LCD段引脚中缺省未使用的段引脚，或者您要把一些段引脚当作一般的I/O引脚使用，这时就需要您自己设计一个排线。这两个插头都是按照2.54mm的间距排列插头的，您可以很容易地设计出适合自己需要的排线。

这两个插头（图 2-11）的引脚配置可以在STK502底部的PCD上找到，同样您也可以参考附录里的完整电路图。

图 2-11: LCD插头的引脚

使用显示器上的两个冒号

您可以在标记着“19 24”的插头J300上放置短路片，将LCD的引脚24（缺省未连接）与LCD引脚19连接起来。见图2.12。这样做的原因是因为LCD引脚24控制着段“COL1”，而LCD引脚19控制着“COL2”。在实际应用中，例如：显示时钟、日期等，通过放置短路片可以很容易地控制这两个冒号的显示。但是连接这些引脚会同时导致以下段之间的连接（参阅技术规范说明）：“S5”和“3”、“S8”和“S7”、“8”和“7”，在实际应用中这些段会失效。图2-13是在缺省配置时LCD显示器上可以使用的段。

图 2-12： 连接COL1和COL2的短路片

图 2-13： 缺省LCD段配置时。图2.12中有短路片和没有短路片时的LCD显示器上的显示。

其他的LCD显示器也可以连接到LCD AVR器件上，您可以使用整合了全部段引脚的插头“Segment pins from ATmega169”，同样您也可以直接通过端口A、端口C、端口D和端口G的连接接口，进行LCD显示器的连接。

注意： 确保显示器的电气特性和LCD AVR器件的电气特性一致。

更多有关如何编写LCD显示器的软件程序的信息，请参阅“AVR064 STK502-A temperature monitoring system with LCD output”应用说明以及“AVR065 LCD driver for the STK502 LCD”应用说明


TOSC Switch

TOSC开关

图 2-14: TOSC开关

STK502 所支持的的AVR器件的TOSC1和TOSC2信号引脚与XTAL1和XTAL2引脚是共用的。通过TOSC开关，可以把STK502板上的32kHz晶振连接到AVR器件，同样通过TOSC开关，也可以把STK500板上的XT1/XT2信号连接到AVR器件。

图 2-15是简单的电原理框图，它向我们解释了TOSC开关是如何工作。

图 2.15： TOSC开关的电原理图


Sensor

传感器

图 2-16： NTC-电热传感器的连接

STK502有一个带紧固螺丝的连接座，可以用于传感器的连接。STK502评估板套件中有一个适合于这个带紧固螺丝连接座的NTC-电热传感器。NTC的工作原理是：当温度下降时，NTC电热传感器的阻值会变大。使用一个分压器，通过AVR器件的ADC通道读出电热传感器的电压值，然后通过计算就可以获得温度值。“AVR064 STK502-A temperature monitoring system with LCD output”操作说明书详细叙述了该应用的细节。

传感器开关

STK502使用了两个开关来控制传感器与AVR器件的ADC通道之间的连接，如图2-17所示。

图 2-17： 温度传感器开关

AREF开关

AREF开关控制着AVR器件的AREF-引脚上的输入。

图 2-18： AREF开关

位置:

  • AREF： 当开关在这个位置时，STK500上的AREF信号连接到AVR器件的AREF引脚。这是缺省设置。

  • VREF: 当开关在这个位置时，STK502上的1.263V参考电压连接到AVR器件的AREF引脚。开关放在这个位置上，才可以运行操作说明书“AVR064 STK502-A temperature monitoring system with LCD output”里的代码。

PF[1:0]开关

PF[1:0]开关控制AVR器件的PF1和PF0引脚（ADC channel 1/0）的输入。

图 2-19： PF[1:0]开关

位置：

  • PIN： 当开关在这个位置时，STK502上的端口F的PF0和PF1直接连接到AVR器件的PF0和PF1引脚上。这是缺省设置。

  • Sensor： 当开关在这个位置时，STK502上的带紧固螺丝的连接器的引脚1与AVR器件的PF0相连，该连接器的引脚2与AVR器件的PF1相连。开关放在这个位置，才可以运行操作说明书‘AVR064 STK502-A temperature monitoring system with LCD output“里的代码。

当开关在传感器（sensor）位置上时，不管在应用中使用的是逐次逼近式还是微分式ADC测量方法，PF0和PF1都是直接连接到传感器引脚。这就是说，PF1不可能作为普通的I/O端口来使用，尽管在使用逐次逼近式ADC时，只有PF0被ADC使用。


Trouble Shooting Guide

问题解决向导

问题 | 原因 | 解决方法
LCD显示器上没有任何显示。 | 没有连接LCD显示器。 | 用34-芯的转接线连接STK502上的2个34-引脚的插头。
LCD显示器上没有任何显示。 | AVR 设备中的LCD控制模块没有被激活。 | 检查LCD的初始化。 “AVR065 LCD driver for the STK502 LCD”操作说明书叙述了如何控制LCD显示器，或者参阅“AVR064 STK502-A temperature monitoring system with LCD output”操作说明书
LCD显示器上没有任何显示。 | 刷新的频率不正确。 | 确认使用了正确的时钟源及分频系数。
LCD屏幕上有些地方时暗时明。 | 端口A/C/D或者G 连接有一些其他的设备。 | 检查确认没有其他设备连接到在STK500和STK502板上的这些端口。
不能控制PORTF[1:0]。 | 端口F[1:0]没有连接到iAVR器件。 | 把端口F[1:0]开关设置到PIN位置。
串行编程不工作。 | ISP连接线没有连接。 | 按照图2-6连接ISP连接线。
串行编程不工作。 | STK500目标电压错误。 | 请参考AVR器件数据手册上的串行编程电压限制。从而调整STK500上的目标电压。
并行编程不工作。 | 连接线没有正确的连接。 | 请参考图2-7上的并行编程电压限制，从而调整STK500上的目标电压。
并行编程不工作。 | TOSC开关没有设置正确。 | 设置TOSC开关到 XTAL位置。
没有一种编程模式正常工作。 | RESET-信号没有连接到AVR器件。 | 使用短路片将STK502和STK500上的RST-连接在一起。


Technical Specification

技术规范说明书

系统单元

体积： 56 x 119 x 27 mm

重量： 70 g

工作环境

工作电压： 1.8V - 5.5V

温度： 0℃ - 50℃

LCD显示器

工作电压： 3V


Technical Support

技术支持

寻求技术支持，请联系avr@atmel.com。当您需要技术支持时，请您提供以下信息：

  • 您使用的AVR设备型号（完整器件型号）。

  • 目标电压和速度。

  • 时钟源和AVR设备熔丝位的设置

  • 编程方式（ISP或者高电压）。

  • AVR工具的硬件版本，可以在PCB上找到。

  • AVR Studio的版本，您可以在AVR Studio的帮助菜单中找到。

  • 您使用的电脑的操作系统及版本。

  • 您使用的电脑的处理器型号和速度。

  • 一份详细的问题说明。


LCD Technical Specification

LCD技术规范说明书

回首页


LCD Bit Mappings

STK502的LCD位映射

AVR器件里的LCD数据寄存器（LCD Data Registers 简写为LCDDRx），按照底板控制线（也叫公共线）的使用，通过组的方式进行组织的。STK502上的LCD显示器使用4根公共线和25个段，加起来一共4 x 25 = 100 段。LCD显示器数据表（图4-1）中描述了内部引脚、公共线和段的连接，按照图上的数字标记，您可以很方便地查到每个数字字型是由哪几个段组成的。以下按照上述规则列出了STK502的位映射。

数字字型 2

下面列出了数字字型2的位映射。

表 4-1. LCD数字字型 # 2的位映射

数字字型 3

下面列出了数字字型3的映射。

表 4-2. LCD数字字型 # 3的位映射

数字字型 4

下面列出了数字字型4的位映射。

表 4-3. LCD数字字型 # 4的位映射

数字字型 5

下面列出了数字字型5的位映射。

表 4-4. LCD数字字型 # 5的位映射

数字字型 6

下面列出了数字字型6的位映射。

表 4-5. LCD数字字型 # 6的位映射

数字字型 7

下面列出了数字字型7的位映射.

表 4-6. LCD数字字型 # 7的位映射


Complete Schematics Page 1

完整的电原理图1

为了打印电原理图，您需要将图片拖放到一个支持*.gif格式文件的图片处理应用程序，再调整图片的大小以适应纸的大小。


Complete Schematics Page 2

完整的电原理图2

为了打印电原理图，您需要将图片拖放到一个支持*.gif格式文件的图片处理应用程序，再调整图片的大小以适应纸的大小。


Complete Schematics Page 3

完整的电原理图3

为了打印电原理图，您需要将图片拖放到一个支持*.gif格式文件的图片处理应用程序，再调整图片的大小以适应纸的大小。


Assembly Drawing

装配简图

回首页