STK501CAN Introduction

STK501CAN

简介

Atmel公司提供的ATADAPCAN01 - STK501 CAN硬件设备是STK500和STK501实验开发板的扩展，增加了对AVR AT90CAN128器件的支持。

AVR AT90CAN128内部包含有一个CAN（Controller Area Network）控制器，该控制器有实现与“BOSCH GmbH” CAN 2.0A和2.0B 规范一致的CAN串行通信协议所需的全部特性。

为了应用的开发与调试，STK501CAN扩展板上提供有CAN收发器、终端匹配和其他将STK500实验开发板连接到CAN总线所需的器件。

所需器件

  • STK500评估板，串行连接线和电源

  • STK500的扩展模块STK501

  • 64引脚TQFP封装的AVR AT90CAN128


Connections

与STK500/STK501的连接

ATADAPCAN01模块是提供给STK500、STK501评估板使用的，SKT501是SKT500评估板的扩展模块，它上面有一个可以给AT90CAN128器件使用的64引脚TQFP ZIF插座，ATADAPCAN01需要有与AVR器件CANTx和CANRx信号引脚的接线，当然也要有跟Vcc和GND的接线。可以使用下面3种方法中的任何一种将ATADAPCAN01扩展板连接到STK500/STK501评估板。

  • 连接到PORTD的信号线是分开的。 使用STK500评估板配套的2-芯连接线，进行下面的连接。

    • STK500 PD5 （引脚6）与 ATADAPCAN01 PORTD 引脚 6 （CANTx）连接

    • STK500 PD6 （引脚7）与 ATADAPCAN01 PORTD 引脚 7 （CANRx）连接

    • STK500 GND 和 VTG 分别与 ATADAPCAN01 PORTD 引脚 9和10连接

  • 使用扁平电缆连接PORTD。 使用一个STK500评估板配套的10-芯扁平电缆，按照图1所示，将STK500D的PORTD插头与ATADAPCAN01的PORTD插头连接起来。连接时应注意相同序号的引脚要连在一起。

  • 直接在PORTD上安装连接。 在ATADAPCAN01 (J8)上设计了第2个PORTD插座，但是没有安装。在扩展板的背面按上一个匹配的10引脚插座，这样就可以将STK500评估板的PORTD插头直接插到扩展板的这个PORTD插座里。同时ATADAPCAN01扩展板正面的PORTD接口还可以用作其他PORTD引脚的连接。

图1：使用10-线扁平电缆连接STK500


CAN Bus Interface

CAN总线接口

在连接ATADAPCAN01到CAN总线时，有许多可以利用的选择。

总线连接接口

D-SUB-9公连接接口是连接CAN总线时的首选。当然，您也可以使用标记有“CAN BUS flat-cable” 的10-引脚插头。如果CAN总线的拓扑结构需要，您也可以同时使用这两种连接接口。这两种接口都是按照表1所示的CiA Draft Standard 102 2.0版本标准设计制造的。

表1. CAN 总线连接器配线

信号描述 | D-SUB-9引脚 | 扁平电缆引脚
Reserved | 1 | 1
CAN_L | 2 | 3
CAN_GND | 3 | 5
Reserved | 4 | 7
CAN_SHLD* | 5* | 9*
CAN_GND | 6 | 2
CAN_H | 7 | 4
Reserved | 8 | 6
CAN_V+ | 9 | 8
(未使用) |  | 10

* 在内部CAN_SHLD 引脚没有连接在一起。

CAN总线的接地和屏蔽

这两个CAN总线连接接口的“CAN_SHLD”信号线可以随意地通过0 ohm的电阻直接连接到地，或者您也可以在R2位置（对于D-SUB-9）、R3位置（对于flat-cable）放上一个小阻值的电阻后，再连接到地。R2和R3的landing pads都是1026标准大小。

缺省地，这两个连接接口的“CAN_GND” 信号线都是通过0 ohm的电阻R1连接到STK500的地的。.移除R1会断开CAN总线的“CAN_GND” 地信号与STK500 / ATADAPCAN01地信号之间的连接。

CAN总线终端匹配器

为了正常运行，CAN总线在两端都需要有各自放置一个120 ohm的终端匹配器。简单地设置标记着“TERM”的短路片，就可以将ATADAPCAN01变成一个终端节点。这是使用了2个串连的62 ohm电阻终止了CAN总线。通过设置标记着“SPLIT”的短路片，可以将这两个电阻的中心抽头通过10nF的电容C1连接到地。 这减少了普通模式下总线的干扰。 这个中心抽头也可以按照“分压”部分中描述的那样进行稳定（如果有按在“CAN1”上的CAN无线电收发机的支持）。

CAN收发器的选择

ATADAPCAN01扩展板上有两个CAN收发器的焊盘。 这为交换使用CAN器件以及发挥出这些部分额外的特性提供了一种简单可行的方法。当考虑到这些选择时，请参考下面的图2电原理图。

这两个“CAN1” 和 “CAN2“ 焊盘的引脚1、2、3、4、6和7都是使用的标准CAN器件引脚。缺省情况下，“CAN1” 在实验板（Atmel ATA6660）上是按好的。如果要在 "CAN2" 位置使用一个器件，将该器件焊接到实验板上，从“CAN1”部分移除掉标记着R8、R9、R10，阻值为0 ohm的电阻，然后把它们安装在“CAN2” 部分的R11、R12、R13位置上。尽管空闲的CAN收发器仍然连接到CAN总线，但是每次只能有一个CAN器件连接到AVR设备。

图 1 器件放置图

图 2 电原理图。

利用CAN收发器额外的特性

许多CAN收发器在引脚5和8上都有不同的额外功能。ATADAPCAN01允许您利用这些特性。“CAN1”和 “ CAN2” 的footprints上的引脚8都连接在了“SLOPE CTRL” 接口的中心引脚上。“CAN1”的引脚5连接在了终端网络的中心抽头上，“CAN2” 的引脚5连接在了R5和C2上，见图2。

Slope控制（引脚8，“CAN1” 和“CAN2”）

CAN无线电收发器支持slope或者slew-rate控制，允许在RS引脚（引脚8）和地之间连接一个电阻，以减少总线驱动信号的slope。这样可以在限制最大传输速率的情况下减少电磁干扰（EMI）。"CAN1" 和 "CAN2" 器件的引脚8都可以连接到"SLOPE CTRL" 短路片的中间引脚。如果要设置短路片到打开（ON）状态，只需将中间引脚通过电阻R7连接到地；如果要设置短路片到OFF状态，只需将中间引脚直接连接到地（无slope控制或者高速模式使用）。更多有关电阻R7阻值的选择（缺省24K），请参考CAN收发器件说明文档。

等待功能（引脚8，“CAN1” 和 “CAN2”）

某些CAN收发器具有这样的功能：通过控制引脚8上的逻辑电平可以使其进入等待模式。为了这个达到目的，可以将“SLOPE CTRL” 插头的中间引脚（移除了短路片）连接到AVR器件的一个I/0引脚。您的AVR代码应该按照CAN收发器说明文档中说明的那样控制这根信号线。

关闭功能（引脚5，“CAN2”）

一些CAN无线电收发器有SHUTDOWN功能，该功能是由连接在引脚5上的R-C设定的。“CAN2”footprint的引脚5通过电阻R6连到Vcc，通过电容C2连到地， 如原理图所示。缺省R6是个0 ohm的电阻，连接到Vcc，电容C2没有安装。两个零件都是0603大小。更多信息请参考CAN无线电收发器。

分压（引脚5，“CAN1”）

可以使用将CAN总线终端（如果激活）的中心点与某个CAN收发器的引脚5连接起来的方法，来稳定中心点。如果CAN收发器支持该特性，可以在R14的位置安装一个0 ohm的0603电阻，同时还要设置好“SPLIT” 和“TERM” 短路片（参见“CAN总线终端”部分）。