STK501 使用说明

简介

STK501评估板是Atmel公司开发的STK500评估板的扩展模块，它增加了对ATmega64、ATmega103、ATmega128和AT90CAN128器件的支持。如果将STK500配合着SKT501使用，就可以实现在一个开发环境下支持目前所有的AVR器件！

STK501包括有连接接口、短路跳线和Zero Insertion Force (ZIF)插槽。有了ZIF插槽，我们就可以很轻松地插入ATmega64、ATmega128和 AT90CAN128这样TQFP封装形式的器件，同时我们还可以发挥出这些器件的全部功能。

这个文档既可以给一般初学者使用，也可以给高级使用者提供完整的技术参考。

增加了对新器件的支持，同时也增加了对以前STK500不支持的一些外围设备的支持。增加了一个RS-232接口和外部SRAM接口，这两个都是为新功能增加的外围设备。有两个UART或是有XRAM接口的器件可以充分利用STK501评估板上的新资源。

请参阅下列主题：

  • 特性
  • STK501与STK500评估板的连接
  • 端口连接接口
  • JTAG接口
  • 在STK501上安放器件
  • 器件编程
  • RS-232C端口
  • SRAM （XMEM）
  • TOSC开关


Features

特性

  • STK500兼容。
  • AVR Studio兼容。
  • 支持ATmega64、ATmega103、ATmega128和AT90CAN128。
  • 适用于TQFP封装形式的零阻力插入（Zero Insertion Force）插槽。
  • 适用于仿真适配器的TQFP焊盘。
  • 支持ATmega64、ATmega128和AT90CAN128器件所有的新功能。
  • 带有JTAG连接接口，支持使用JTAG ICE（ATmega64、ATmega128、AT90CAN128）进行片上仿真。
  • 新增的RS-232C接口。
  • 增加了STK500对XRAM的支持。（所有带有XRAM接口的器件都可以使用）。
  • 评估板上带有32kHz时钟振荡器，可以用于简单的实时时钟（RTC）。

图1 STK501—STK500的扩展模块

返回简介


新增功能

2004年3月8日

  • 增加了对AT90CAN128的支持。

2002年11月4日

  • 增加了对ATmega64的支持。


疑难解答

2002年11月4日

  • 目前没有疑难解答。


Connecting the STK501 to the STK500 Starter Kit

STK501与STK500评估板的连接

通过扩展插头0和扩展插头1，可以将STK501连接到STK500上。 很重要的一点是必须按照图1所画的那样，按照正确的方向放置连接STK501。STK501扩展板上写着EXPAND0的插头必须插在STK500评估板上写着EXPAND0的那个插座里。

图 1 STK501与STK500的连接


PORT Connectors

端口连接接口

端口E/F

ATmega64、ATmega103、ATmega128和ATCAN1m128新增了STK500上没有的端口，因此STK501扩展板上新增了这些端口的连接接口。它们有着跟STK500评估板上端口连接接口一样的引脚和功能。端口A到端口D连接接口在STK500上已经有了，所以没有在STK501上重复设置。I/O端口连接接口如图1所示。E端口和F端口都是一般的I/O端口，而G端口有一些新增的信号线。

注意： 端口E的连接接口在STK500上已经有了，但是只是PE0到PE2（3个最低有效位）。如果要使用整个端口E，还是必须要使用STK501上的连接接口。

图 1 普通的I/O端口

端口G/AUX

除了一般的端口引脚，这个插座还增加了一些额外的信号引脚。

PG0-PG4

这些是ATmega64、ATmega128和ATCAN1m128以及连接在ZIF中的和TQFP封装形式的器件可以使用的普通IO端口引脚。因为PG3和PG4也可以用作32kHz振荡器的输入，所以PG3和PG4的信号通过TOSC开关传送。

注意： ATmega103没有端口G。

A16

这根线连接到SRAM上的A16（最高有效位）。

SRAMEN

SRAM是否选通由SRAMEN这根信号线控制。在这个引脚上加上一个低电平信号就可以选通SRAM。缺省这个引脚上的电平是拉高的。

PEN

PEN引脚是跟ATmega64/103/128插座上的PEN引脚相连的。这个引脚在相应器件的数据使用手册中的编程部分有详尽的描述说明。


JTAG Connector

JTAG接口

JTAG接口是提供给像ATmega64、ATmega128和ATCAN1m128这样本身带有JTAG接口的器件使用的。JTAG接口的引脚如图1所示，它和其他可以从Atmel公司获得的JTAG ICE的引脚是相兼容的。将JTAG ICE连接到这个接口，ATmega64/128就可以使用外部真实的器件作为仿真器进行在系统仿真。

更多有关JTAG ICE和AVR片上调试系统（AVROCD）的信息，请参阅JTAG ICE用户手册。

图1 JTAG接口：

下图向我们展示了如果将JTAG ICE连接到STK501扩展板上。


PLACING AN ATMEGA103 OR ATMEGA128 ON THE STK500

在STK501上安放器件

STK501有一个ZIP插槽和一个适合TQFP封装形式的焊盘；这样就提供了一种将AVR器件直接焊接到STK501上的简单方法。注意器件（或是适配器）的放置方向。ZIF插座和TQFP焊盘的1号引脚的位置如图1所示。

注意： 不要在已经有一个AVR器件安装在STK500评估板上的同时，再在STK501板上安装ATmega64、ATmega103、ATmega128或者 ATCAN1m128！

图1 ZIF插槽和TQFP焊盘的1号引脚


Device Programming

器件编程

ATmega64、ATmega103、ATmega128和AT90CAN128都有两种编程方式：SPI编程、高电压并行编程。以下将要说明的是在使用这两种编程模式时如何进行编程连接线的连接。AVR Studio STK500软件和以往的使用方法一样。

注意： ATmega64ATmega128和AT90CAN128都支持自编程，但在以下的说明中不包含这部分内容。（更多有关该主题的信息，请参阅操作说明书AVR109。）

在系统编程

在使用ISP编程模式对ATmega64、ATmega103、ATmega128和AT90CAN128进行编程时，需要按照图1所示的，用6芯的连接线将STK500评估板上的ISP6PIN插头与STK501扩展板上的ISP插头连接起来。连接好后，就可以使用AVR Studio STK500软件中的串行编程模式对该器件进行编程。

注意： 更多有关如何使用STK500管理软件进行ISP编程的信息，请参阅STK500用户手册。

图 1 ISP编程

高电压编程

在使用高电压编程模式对ATmega64、ATmega103、ATmega128和AT90CAN128进行编程时，需要按照图2所示，分别将STK500评估板上的 PROGCTRL与PORTD、PROGDATA与PORTB连接起来。连接好后，就可以使用AVR Studio STK500软件中的高电压编程模式对该器件进行编程。

注意： BSEL2短路片必须安上。更多有关其他短路片在高电压编程模式下的连接，请参阅STK500使用手册。

注意： 更多有关如何使用STK500管理软件进行高电压编程的信息，请参阅STK500用户手册。.

注意： 在高电压编程模式下，要能正确运行，目标电压必须要高于4.5V。小心：确保SRAM（如果安装）能够承受该电压。

图 2 高电压（并行）编程


RS-232C Port

RS-232C端口

ATmega64/128比ATmega103多了一个UART接口。STK501扩展板上的RS-232接口有增加的RXD和TXD信号线，这样就增加了对RTS和CTS的流控制。有关实现部分的简单电原理图如图1所示。ATmega64/128（包括其他AVR器件）的UART不支持硬件RTS或者硬件CTS控制。如果需要这样的功能，那么必须通过软件的方式实现。

图1. UART部分电原理图

安装在STK500评估板上的器件也可以使用这个UART接口。只需简单地将相应的端口引脚连接到STK501扩展板上的RXD和TXD。

注意： 如果没有使用RTS/CTS流，在RTS和CTS之间的短路片可以确保外部的应用程序使用这样的流控制来进行正确的通信。


SRAM (XMEM)

SRAM （XMEM）

STK501板上有一个焊盘可以用于焊接SRAM器件。确保SRAM器件和其他部分设计的电压范围一样。

注意： 如果使用了一个低电压的SRAM，需要特别小心。因为并行编程需要编程电压高于4.5V，在使用了低电压SRAM的情况下进行并行编程，会损坏SRAM器件。

注意： 缺省状态是不能使用SRAM的。在端口G/AUX连接接口的SRAMEN和GND之间按上短路片，就可以开启对SRAM的支持。

图1: SRAM 焊盘的引脚1

A16

这根线连接到SRAM上的A16（第16根地址线）。ATmega64、ATmega103和ATmega128支持最大60KB的外部SRAM。STK501扩展板上的SRAM的焊盘是按照128KB的SRAM设计的。使用软件对A16进行控制，可以把能够控制的SRAM的大小从64KB增加到128KB。缺省这根线是拉低的，这时只能使用SRAM的一半空间。

图2： SRAM部分的电原理图

SRAMEN

SRAMEN信号线控制着SRAM是选通还是不选通。如果选通SRAM，需要给这个引脚一个低电平。缺省这个引脚是拉高的。可以使用一种简单的方法：利用配套的短路片选通SRAM，如图 3所示。

图2简单化的电原理图向我们展示了它是如何工作的。其实这个引脚的信号还可以由软件或是一些外部控制逻辑控制。

图3： SRAMEN和GND连接

RAM高位地址短路片

当使用了外部存储器时，所有端口C的引脚缺省用作高地址位。如果不需要将60KB地址空间都映射到外部存储器，端口C的引脚可以部分或者全部解放出来，当作普通的端口引脚使用，详情参阅ATmega64/128使用手册。AT90S/LS8515、ATmega103和ATmega161没有该功能，在使用这些器件的XRAM接口时必须安装所有的短路片。

如果部分或者所有的端口C的引脚被解放出来用作普通的端口使用，那么负责该Ram高地址通信的相应短路片必须拿开，以免端口C的信号连接到SRAM地址线引脚而影响到地址的选通。

如果移除了一个短路片，那么SRAM上相应的那位地址线会同过给一个逻辑0的方式拉低。见电原理图

图2。

A[7:0] 连接接口

标记着A[7:0]的连接接口包含有外部SRAM地址总线的8根最低有效位（LSB）。接口的目的是提供简单的与地址总线的连接。您可以在“Ram High Addresses”短路片或者端口C的连接接口中找到这8根最高有效位。

接口被放在latch的后面，如图2所示。在使用SRAM接口连接外部器件的时候，可以很方便地使用这个接口。

使用AT90S/LS8515和ATmega161的SRAM接口

当使用安置在STK500评估板上的器件的SRAM接口时，需要连接一些特别的线。因为对于AT90S8515 / ATmega161(L)和ATmega64(L)/103(L)/128(L)，RD WR和ALE信号不在同一个端口的接口上，所以这些信号线就必须要使用2根2-芯转接线进行连接。

连接线 | STK500 | STK501 | 说明
写信号 WR | PD6 | PG0 | 将STK500上的PD6与STK501上的PG0连接起来
读信号 RD | PD7 | PG1 | 将STK500上的PD7与STK501上的PG1连接起来
地址选通 ALE | PE1 | PG2 | 将STK500上的PE1与STK501上的PG2连接起来

图 4 选通SKT500上器件的SRAM接口


TOSC Switch

TOSC开关

ATmega64/128的TOSC1和TOSC2的信号引脚和端口G（PG4 PG3）引脚是共用的。TOSC开关控制选择32kHz晶振和端口G引脚中的哪一个连接到器件的这些引脚上。

有关实现部分的简单电原理图如图1所示。

注意： 因为ATmega103上没有G端口，所以开关只有2种状态：要么连接32kHz晶振，要么与32kHz晶振断开。