JTAGICE mkII firmware history

JTAGICE mkII固件历史

下面列出JTAGICE mkII最近的5个版本中的改动内容。

FW 版本 1.04 - AVR Studio 版本 4.11.

JTAGICE mkII 固件:

模块 | 软件版本
主模块 | 03.0A
从模块 | 03.0F

注意：你当前使用的JTAGICE mkII的版本可以在状态标签中的JTAGICE mkII选项对话框中找到。

JTAGICE mkII所支持的新芯片

芯片 | 接口
AT90PWM3 | debugWIRE
AT90PWM2 | debugWIRE
ATtiny45 | debugWIRE
ATmega406 | JTAG
ATmega2560 | JTAG
ATmega2561 | JTAG

要查看所有支持的芯片的列表请点击所支持的器件。

版本 1.04中做的修正：

  • STK500编程对话框（STK500 programming dialog）: 修正了下载带有偏移（引导装入程序）的hex文件时出错的问题。

  • 支持包含debugWIRE引导装入过程的工程。

版本1.04的新功能

  • 添加了调试选项对话框（Debug options page）:程序下载 Always/Never/TimeStamp, 与JTAGICE的高级调试选项相似。

  • Bug修正:当在工程中动态的设置断点时，显示在输出窗口中的断点信息可以正确的检查了。

  • 对AT90PWM2/3芯片在选项对话框中添加了一个新的标签"PWM"。

在线帮助的更新:

  • 更新了ATmega162的在线帮助。请参考ATmega162的注意事项。

  • 更新了‘疑难解答’。

  • 添加了命令行软件的内容。

FW 版本 1.03 - AVR Studio 版本 4.11 Beta

JTAGICE mkII 固件:

模块 | 软件版本
主模块 | 02.13
从模块 | 02.14

注意：你当前使用的JTAGICE mkII的版本可以在状态标签中的JTAGICE mkII选项对话框中找到。

JTAGICE mkII所支持的新芯片

芯片 | 接口
ATtiny45 | DebugWire

要查看所有支持的芯片的列表请点击所支持的器件。

版本 1.03中所作的修正

  • 无

在线帮助的更新:

  • 更新了ATtiny45的在线帮助。请参考关于ATtiny45的疑难解答。

  • 更新了‘疑难解答’。

FW 版本 1.02 - AVR Studio 版本 4.10.

下面对自AVR Studio4.10Beta版以来，本版本所做的修正及新增功能进行一些简短的总结。请相关的参考疑难解答。

JTAGICE mkII 固件:

模块 | 软件版本
主模块 | 02.13
从模块 | 02.14

注意：你当前使用的JTAGICE mkII的版本可以在状态标签中的JTAGICE mkII选项对话框中找到。

JTAGICE mkII所支持的新芯片

芯片 | 接口
ATmega325 | JTAG
ATmega3250 | JTAG
ATmega329 | JTAG
ATmega3290 | JTAG

要查看所有支持的芯片的列表请点击所支持的器件。

版本1.02中所做的修正

  • 修正了事件溢出而造成仿真器丢失断点的问题。

在线帮助的更新:

  • 更新了ATmega325, ATmega3250, ATmega329, 和 ATmega3290的在线帮助。

  • 更新了‘疑难解答’。

FW 版本 1.01 - AVR Studio 版本 4.10 beta.

下面列出了该版本的一些新功能和所作的修正，请同时参考疑难解答。

JTAGICE mkII中的新内容

  • JTAGICE mkII 包装内容 中增加了一个10pin－6pin的适配线。这个线简化了JTAGICE 插头 和 ISP 插头之间的连接。

JTAGICE mkII 固件:

模块 | 软件版本
主模块 | 02.12
从模块 | 02.12

注意：你当前使用的JTAGICE mkII的版本可以在状态标签中的JTAGICE mkII选项对话框中找到。

JTAGICE mkII所支持的新芯片

Device | Interface
ATmega88 | debugWIRE
ATmega165 | JTAG
AT90CAN128 | JTAG
ATmega168 | debugWIRE

要查看所有支持的芯片的列表请点击所支持的器件。

版本1.01中做的修正

  • 更快的时间存储器的上载。

  • 更快的JTAG通讯速率。

  • 在检测芯片时的界面更加人性化，添加了帮助和重试按钮。

  • 改良了debugWIRE通信时的同步。以前，工作在特定的频率上时有很多声明为MAX_BIT_LENGTH_DIFF的假调试事件信息会发生。现在已经修正了。

  • 对于flash存储器大于64K的芯片，可以在大于64K的地址中设定软件断点了。

  • 共享IDR/OSCCAL寄存器的芯片，可以发送IDR事件了。

  • STK500可以支持上载带有引导装入程序的.Hex文件了。

  • 调试（Debug） -> 上载/下载存储器（Up/Download memories）：可以上载>256字节的文件了。

  • 修正了选项对话框中各式各样的bug。例如：使用debugWIRE芯片时，保护EEPROM现在被禁止了。

在线帮助的更新:

  • 更新了对Atmega165, Atmega88, Atmega168, 和 AT90SCAN128的在线帮助。

  • 添加了“新增功能”页面和“固件历史”页面。

  • 更新了‘疑难解答’。

  • 更新了JTAGICE mkII中安装/升级USB驱动的部分。

FW 版本 1.00 - AVR Studio 版本 4.09.

这是与JTAGICE mkII所发布的最初的版本。

JTAGICE mkII 固件:

模块 | 软件版本
主模块 | 01.07
从模块 | 01.07

注意：你当前使用的JTAGICE mkII的版本可以在状态标签中的JTAGICE mkII选项对话框中找到。

JTAGICE mkII所支持的新芯片

Device | Interface
ATmega16 | JTAG
ATmega162 | JTAG
ATmega169 | JTAG
ATmega32 | JTAG
ATmega64 | JTAG
ATmega128 | JTAG*
ATtiny13 | debugWIRE
ATtiny2313 | debugWIRE
ATmega48 | debugWIRE

要查看所有支持的芯片的列表请点击所支持的器件。

点击疑难解答来查看关于疑难解答的列表。


疑难解答

JTAG:

  • 当电源掉电又复原，或应用一个外部复位时，一些乱真事件会出现。

  • 调试时，当用户选择了错误的芯片的名字时，AVR Studio就会警告用户说检测不到用户选择的芯片，并问你是否用AVR Studio检测到的芯片进行继续调试。这时，如果你实际使用的芯片是Atmega169，AVR Studio会说它检测到的芯片是Atmega165。在这种情况下你只能重新启动调试，并正确的选择Atmega169芯片。

  • 芯片复位，会使“断点模式时，继续使定时器工作”这个选项清除。尤其是当你选定了这个选项时。解决的方法是重新加载工程文件。

  • 对于包含自修改代码的工程：当上载一个工程的时候，目标芯片会在复位到复位向量之前运行几个毫秒，这意味着程序可能会改变AVR Flash和EEPROM的内容。解决的方法：写上一些应用代码，防止自修改代码被无意的访问。

  • 命令行软件(Jtagiceii.exe):注意参数S[f|e] <address>不校验写进的字节值。

DebugWire:

  • 执行一个没有结尾的源代码时会使DebugWIRE产生错误的消息。这可能是因为芯片内部包含没有被擦除的代码。注意Flash中没有用的页不会被删除。

  • 调试期间不要改变目标板的电压或频率。如果要改变这些值，要先结束调试。

  • Osccal 和 CLKPR 寄存器不能在调试期间被代码写入。这将导致JTAGICE mkII和AVR Studio因同步失败而能通讯。重新进行调试可以解决这个问题。

  • 带有PRR寄存器（Power Reduction Register）的芯片的PRSPI位（Power Reduction Serial Peripheral Interface bit）不能被写成1。如果这一位被写成1，将会禁止掉debugWIRE的时钟，所有与JTAGICE mkII 和 debugWire 接口的通讯都会停止。目前这个bug出现在Atmega48/88/168芯片中。

共同的:

  • 自动执行（Autostepping）:在自动执行（Autostepping）模式中，复位按钮是不可用的。如果要对芯片复位，先点击停止按钮，然后点击复位按钮。

  • 用一个已经存在的工程在debugWIRE和JTAG之间切换时，将导致错误的工程设置被写到工程文件中。在这种情况下删除这个工程文件，重新用需要的芯片建立工程文件。

  • 单步执行一个SLEEP指令不能使芯片进入休眠模式。要使用运行模式（Run Mode）。

  • 不能在AVR Studio的程序存储器视图（Program Memory View）中编辑目标板的Flash中的内容。也不能在观察窗口（Watch Window）中改变Flash常量的内容。

  • 在使用USB时不能使用同一个AVR Studio来同时进行JTAGICE mkII的调试和编程。当你既要对一个芯片进行调试，又要可以对他编程时，可以开两个AVR Studio。

  • 不能通过一个连接在总线驱动的USB集线器（bus-powered USB hub）上的USB进行JTAGICE mkII升级。

  • 请注意：当任何一个锁定位被编程后，片上调试系统都会被禁止（为了安全）。

  • 当用JTAGICE mkII进行调试的时候，不会对相兼容的熔丝位置位。

  • ELF/DWARF 生成的C-工程：“Step out”不起作用。

  • 对一个递归函数执行“Stepping over”时，实际上只是执行到了该函数更深一层的调用。


所支持的器件

JTAGICE mkII对JTAG接口和debugWIRE接口都支持。

目前JTAGICE mkII支持下面的这些芯片。

Device | Interface
Atmega644 | JTAG
ATmega2560 | JTAG
ATmega2561 | JTAG
ATmega128 | JTAG*
AT90CAN128 | JTAG
ATmega64 | JTAG
Atmega6490 | JTAG
Atmega649 | JTAG
Atmega6450 | JTAG
Atmega645 | JTAG
ATmega406 | JTAG
ATmega32 | JTAG
ATmega3290 | JTAG
ATmega329 | JTAG
ATmega3250 | JTAG
ATmega325 | JTAG
ATmega16 | JTAG
ATmega162 | JTAG
ATmega169 | JTAG
ATmega168 | debugWire
ATmega165 | JTAG
ATmega88 | debugWIRE
ATmega48 | debugWIRE
ATtiny45 | debugWIRE
ATtiny24 | debugWIRE
ATtiny2313 | debugWIRE
ATtiny13 | debugWIRE
AT90PWM3 | debugWIRE
AT90PWM2 | debugWIRE

*注意ATmega128不支持BREAK指令。

如果有新版本发布，这个列表会更新。请在www.atmel.com上查询最新的消息。


新增功能

下面是这次所发布的一些修正和新特性。 具体新增功能请参考 疑难解答。

FW 1.08 - AVR Studio 4.11 SP3

Service pack 3 包括AVR Studio 4.11和SP2所有的更改。

JTAGICE mkII 固件：

模块 | 软件版本
主模块 | 04.01
从模块 | 04.03

注意：JTAGICE mkII 的版本可以从JTAGICE mkII 选项对话框的状态（status）标签。

JTAGICE mkII所支持的新器件

芯片 | 接口
ATmega644 | JTAG
ATtiny24 | debugWIRE
Atmega649 | JTAG
Atmega6490 | JTAG
Atmega645 | JTAG
Atmega6450 | JTAG

点这里查看所支持的器件列表.

新特性

Service Pack3

  • jtagiceii.exe 变化

-j 命令 可选JTAGID的验证功能

根据编程退出的情况使用不同的退出代码。-he 选项给出所有退出代码的说明。

增加 -y (read lock byte) 和 -L (verify lock byte) 读取和验正锁定熔丝位命令的帮助输出。

在打印支持振荡器校准的芯片列表后增加空行

将OSCCAL值写入FLASH或EEPROM后增加了效验功能

Service Pack2

  • 支持通过命令行工具jtagiceii.exe进行振荡器校准。请参考命令行接口帮助和AVR053的操作说明书 。注意: 振荡器校准功能仅是测试版。

  • 增加了命令行工具读取JTAG ID的功能（使用-j参数）。更多内容请参考命令行接口的帮助。JTAG ID也可以在状态标签下的JTAGICE mkII选项对话框中读取。以前JTAG ID是在读取标志位时的JTAGICE mkII编程接口对话框中读取的。

修正

Service Pack3

  • 修正了当目标芯片进入或退出休眠状态时中断连接的问题
  • 修正了在菊花链方式中对ATmega16/32编程出现的问题
  • 修正了从存储器观察窗口中写XRAM出错的问题
  • 修正了当编程大容量EEPROM（>255字节）时，出现的超时和一直与目标芯片断开连接的问题

Service Pack2

  • 更新了Atmega2561的XML文件，包含了定时器4和5寄存器。

  • 修正了设置软件断点时死机的问题。原来，当一个软件断点正处于停止状态时，又去设置新的断点就会出现这种错误。当有超过3个的断点时，会自动启用软件断点。

  • 修正了当打开EEPROM数据视图时，会无意的改动EEPROM I/O寄存器的问题。

  • JTAGICEii.exe 的改变:

    • 读Flash和EEPROM时总是忽略最后一个字节，现在改正了。

    • 延长了枚举USB设备时的超时时间，且在限定的时间内也多次执行USB设备的枚举。这项修正解决了使用批量文件多次调用jtagiceii.exe时出现的问题。

    • 修正了在进行调试以前改变选项（菊花链，芯片速度）会死机的问题。

    • 删除了连接到目标板以前修改菊花链设置时跳出的警告消息。

    • 修正了对菊花链中非第一个ATmega128芯片进行下载的问题。这个问题在4.11中被介绍。

在线帮助的更新

Service Pack3

  • 增加了人工更新固件的内容

Service Pack2

  • 更新了命令行软件的内容。

  • 更新了所支持的芯片的内容。