ICE50 Firmvare history

ICE 50 固件历史

在本日志中只有5个最新的固件版本的历史。

FW（固件）版本1.13－AVR Studio 版本4.11服务包2。

在服务包1当中的更改和修正同样列在此处。

特色

新器件

  • 新支持Atmega644

ICE50 固件：

模块 | 软件版本 | 固件版本
Main | 00.4D | 00.04
MMU | 00.1F | 00.1F
OSC | 00.21 | 00.10
AVR | 00.2E |
EVENT | 00.1F | 00.18
POD | 00.0D | 00.10
TRACE | 00.19 | 01.51
TS |  | 00.0C

新器件文件修订版：

文件 | 固件版本
Atmega2561 | 01.03
Atmega128 | 01.2A
AT90CAN128 | 00.1B
Atmega64 | 01.18
Atmega644 | 00.03
Atmega649 | 01.0B
Atmega32 | 01.29
Atmega329 | 01.0B
Atmega325 | 01.0B
Atmega16 | 01.29
Atmega162 | 01.28
Atmega169 | 02.2D
Atmega165 | 02.2D
Atmega168 | 01.0C
Atmega8 | 01.37
Atmega88 | 01.0C
Atmega8515 | 01.1C
Atmega8535 | 01.1E
Atmega48 | 01.0C
ATtiny26 | 01.2C
ATtiny13 | 01.1C
ATtiny2313 | 01.01

ICE50固件版本v. 1.13更正：

  • 在升级软件当中更正了一个错误，该错误有时会使 ICE50 中的 RS232 接口不可用。

ICE50 器件文件版本v.1.13更正：

  • 没有更正

在线帮助更新：

  • 更正Atmega644在线帮助

固件版本 1.11－AVR Studio发布版本4.11。

特色

新器件

  • 完全支持 ATtiny2561 。注意必须从 Atmel 购买单独的 插件存储模块，以便为 ICE50 增加更多的存储空间。检查这些备件清单获取 订购信息。为了安装该器件，请查阅 “ICE50 插件存储模块装备”

支持新的插件存储模块：

  • 存在新的 ICE50 插件存储模块，增加 ICE50 中对 Atmega2561 的支持。检查这些备件清单获取 订购信息 和如何购买这个新的上电插入存储模块。为了安装该器件，请查阅 “ICE50插件存储模块装备”

ICE50固件：

模块 | 软件版本 | 固件版本
Main | 00.4D | 00.04
MMU | 00.1F | 00.1F
OSC | 00.21 | 00.10
AVR | 00.2E |
EVENT | 00.1F | 00.18
POD | 00.0D | 00.10
TRACE | 00.19 | 01.51
TS |  | 00.0C

新器件文件修订版：

文件 | 固件版本
Atmega2561 | 01.03
Atmega128 | 01.2A
AT90CAN128 | 00.1B
Atmega64 | 01.18
Atmega649 | 01.0B
Atmega32 | 01.29
Atmega329 | 01.0B
Atmega325 | 01.0B
Atmega16 | 01.29
Atmega162 | 01.28
Atmega169 | 02.2D
Atmega165 | 02.2D
Atmega168 | 01.0C
Atmega8 | 01.37
Atmega88 | 01.0C
Atmega8515 | 01.1C
Atmega8535 | 01.1E
Atmega48 | 01.0C
ATtiny26 | 01.2C
ATtiny13 | 01.1C
ATtiny2313 | 01.01

ICE50固件版本v. 1.11更正：

  • 没有更正

ICE50器件文件版本v.1.11更正：

  • ATtiny13，ATtiny2313，ATtiny26：关于非法访问存储区的问题解决。先前，使用间接寻址指针如X，Y，Z寄存器 访问 RAM，使用16位 RAM 地址。当前更改为部分使用仅8位的地址指针。

在线帮助更新：

  • 增加安装 ICE50 存储插件模块的在线帮助。

  • 更新Atmega2561的在线帮助。

  • 更新订购信息。

  • 印刷更改

FW（固件）版本1.10－AVR Studio 版本4.10。

特色

新器件

  • 完全支持ATtiny2313。一 款新的针对 ATtiny2313 的个性化适配器可以从 Ateml 公司购买，请查阅 ICE50 订购号。

  • 完全支持Atmega165，使用针对 Atmega169 的个性化适配器。

  • 完全支持Atmega325，使用针对 Atmega169 的个性化适配器。

  • 除了LCD输出，完全支持 Atmega649，使用针对 Atmel169 的个性化适配器。为了仿真在 AVR Studio 中的 LCD 输出，请使用 AVR LCD 观察仪。LCD插件模块能在www.atmel.com 单独下载。

ICE50 固件：

模块 | 软件版本 | 固件版本
Main | 00.4C | 00.04
MMU | 00.1E | 00.1F
OSC | 00.21 | 00.10
AVR | 00.2E |
EVENT | 00.1F | 00.18
POD | 00.0D | 00.10
TRACE | 00.19 | 01.51
TS |  | 00.0C

新器件文件修订版：

文件 | 固件版本
Atmega128 | 01.2A
AT90CAN128 | 00.19
Atmega64 | 01.18
Atmega649 | 01.0B
Atmega32 | 01.29
Atmega329 | 01.0B
Atmega325 | 01.0B
Atmega16 | 01.29
Atmega162 | 01.28
Atmega169 | 02.2D
Atmega165 | 02.2D
Atmega168 | 01.0C
Atmega8 | 01.37
Atmega88 | 01.0C
Atmega8515 | 01.1C
Atmega8535 | 01.1E
Atmega48 | 01.0C
ATtiny26 | 01.2B
ATtiny13 | 01.1B
ATtiny2313 | 01.00

ICE50固件版本v. 1.10更正：

没有更新

ICE50器件文件版本v. 1.10更正：

  • ICE50外部ADC模块最高能够承受的时钟频率是1.3M赫兹。该更正适合所有器件除了AT90SCAN128。请查阅疑难解答 。该更正将同样应用于AT90SCAN128以后的版本。

  • Tiny26：更正了单步时清除TIMER1溢出中断标志TOV1。当单步运行时，TIMER1中断溢出发生，在中断服务程序里TOV1标志不能清除。这部分不能更正。
  • TWI: 所有带有TWI模块的器件现在可以单步执行。当在TWI功能执行完成之前中断或者终止TWI传输，先前的一些器件将不会释放数据线（状态?#39640;?#65289;。该部分现在已经更正。但是，在使能TWI接口时，短时脉冲波形干扰可能在SCL和SDA线上发生。请查阅疑难解答 。

在线帮助更新：

  • 更新ATtiny2313， Atmega165， Atmega325， Atmega649在线帮助。

  • 更新安装/升级USB驱动帮助。

  • 新的订购信息。

  • 更新和印刷更改堆栈监视器在线帮助。

  • 印刷更改。

FW（固件）版本1.9－AVR Studio 版本4.09。

特色

新器件

  • 完全支持 AT90CAN128，使用针对 Atmega128 的个性化适配器。

  • 除了LCD输出，完全支持 Atmega329，使用针对 Atmega169 的个性化适配器。为了在 AVR Studio 中仿真 LCD 输出，使用 AVR LCD 观察仪。LCD插件模块能够从www.atmel.com 单独下载。

ICE50 固件：

模块 | 软件版本 | 固件版本
Main | 00.4A | 00.04
MMU | 00.1D | 00.1F
OSC | 00.21 | 00.10
AVR | 00.2E |
EVENT | 00.1F | 00.18
POD | 00.0D | 00.10
TRACE | 00.19 | 01.51
TS |  | 00.0C

新器件文件修订版：

文件 | FW固件版本 ver.
Atmega128 | 01.2A
AT90CAN128 | 00.19
Atmega64 | 01.18
Atmega32 | 01.29
Atmega329 | 01.08
Atmega16 | 01.29
Atmega162 | 01.28
Atmega169 | 02.2C
Atmega168 | 01.0B
Atmega8 | 01.37
Atmega88 | 01.0B
Atmega8515 | 01.1C
Atmega8535 | 01.1E
Atmega48 | 01.0B
ATtiny26 | 01.2A
ATtiny13 | 01.1A

ICE50固件版本v. 1.9更正：

没有更正

ICE50器件文件版本v. 1.9更正：

  • 所有带有 XRAM 接口的器件：已更正 ，以便于在使用外部 RAM ，并且设置了“使能 XRAM 接口”时，ICE50 不会发出错误事件的信息。

  • 扩展 ICE50 的 ADC 模块能够承受的最高频率是1.3MHz。 除了Atmega169，Atmega329，ATCAN1m128，Atmega48/88/168，and Attiny13，该应用适合于所有器件。请查阅 疑难解答 。这些器件将在更新的版本当中更改。

  • 在下列器件当中的异步时钟：Atmega169，Atmega329， Atmega48/88/168。更正结果是：异步时钟运行于电源省电休眠模式。
  • 所有带有异步时钟的器件：更正结果是：当单步执行时，ASSR 里面的时钟更新繁忙标志始终正确。

在线帮助更新：

  • 更新 ATCAN1m128 和 Atmega329 的在线帮助。

  • 更新复位仿真电源（POR）的在线帮助，掉电复位（BOD），和外部复位，请查阅 使用ICE50仿真 。

  • 印刷更改

固件版本1.8－AVR Studio 4.08 服务包 1 。

特色

新器件

  • 完全支持 Atmega48，Atmega88，Atmega168，使用针对 Atmega8 的个性化适配器。

ICE50 固件：

模块 | 软件版本 | 固件版本
Main | 00.4A | 00.04
MMU | 00.1D | 00.1F
OSC | 00.20 | 00.10
AVR | 00.2B |
EVENT | 00.1F | 00.18
POD | 00.0D | 00.10
TRACE | 00.19 | 01.51
TS |  | 00.0C

新器件文件修订版：

文件 | 固件版本
Atmega128 | 01.28
Atmega64 | 01.16
Atmega32 | 01.27
Atmega16 | 01.27
Atmega162 | 01.25
Atmega169 | 02.29
Atmega168 | 01.09
Atmega8 | 01.35
Atmega88 | 01.09
Atmega8515 | 01.1B
Atmega8535 | 01.1C
Atmega48 | 01.09
ATtiny26 | 01.2A
ATtiny13 | 01.19

ICE50固件版本v. 1.8更正：

没有更正

在线帮助更新：

  • 更新Atmega48，Atmega88，Atmega168在线帮助。

固件版本1.7－AVR Studio版本4.08。

特色

新器件

  • 完全支持 ATtiny13，可以从 Ateml 公司订购个性化适配器。

USB

  • ICE50 USB已经升级，同样包括 DMA 存储器传输 也已升级。当装载工程并且读出存储器的追踪时，这将显著提高传输速度。

  • 为了使用新的 USB 固件， 必须安装新的USB驱动程序。请确保您已经升级和安装好了新的USB。请查阅：关于USB升级支持的注意事项 。

追踪

  • 完全更新了ICE50 的追踪 支持。更新后，包括了许多新的特性，如：宽频滤波，代码作色和源同步发生器。请查阅 追踪向导 获取更多信息。

  • 在新的追踪显示区中增加了带有预先和滞后的追踪。

堆栈监视器

  • 堆栈监视器支持 ICE50 。可以监视和 中止程序堆栈段和数据堆栈段的向上溢出和向下溢出。 请查阅 堆栈监视器 获取更多信息。

中止模式选项

  • 扩展了 ICE50 中止模式选项。时钟，通信模块和 PWM 输出能被使能/禁止。请查阅 中止模式选项 获取更多信息。

新工程向导支持

  • 工程向导可以从 AVR Studio 的工程菜单中启动。在装载工程之前，可以现在被选择打开ICE50选现。这将方便在某些情况下的工程建立。 请查阅 快速入门向导 获取更多信息。

在休眠模式下 中止止

  • 中止休眠模式，现在适合于所有的器件

ICE50 固件：

模块 | 软件版本 | 固件版本
Main | 00.49 | 00.04
MMU | 00.1D | 00.1F
OSC | 00.20 | 00.10
AVR | 00.2B |
EVENT | 00.1F | 00.18
POD | 00.0D | 00.10
TRACE | 00.19 | 01.51
TS |  | 00.0C

新器件文件修订版：

文件 | 固件版本
Atmega128 | 01.28
Atmega64 | 01.16
Atmega32 | 01.27
Atmega16 | 01.27
Atmega162 | 01.25
Atmega169 | 02.29
Atmega8 | 01.35
Atmega8515 | 01.1B
Atmega8535 | 01.1C
ATtiny26 | 01.2A
ATtiny13 | 01.19

ICE50 固件版本v. 1.7更正：

所有器件

  • 升级 ICE50 追踪速度

  • 更正休眠模式下的 中止状态

  • 更正当 BOD 禁止时 BOD 复位禁止

  • 更 正同步时钟，一旦使能，将唤醒同时异步时钟运行时，所有处于休眠模式的器件，

  • 更正在擦除 SPM 页时不能擦除 SPM 临时缓冲区 的问题

  • 在振荡器IO寄存器中，装载了芯片上复位部分事先调整的值

  • 更正器件能够在休眠模式下 中止

Atmega32, Atmega16

  • 更正了写 SPM 加密位

Atmega169

  • 更正Atmega169在复位上电激励时不能正确装载（POR激励当目标没有上电）

Atmega162

  • 更正TWI模块，TWI模块不能像先前那样工作。

Atmega8535

  • 更正了 TWI 模块，TWI 模块不会像先前那样工作

ATtiny26

  • 增强 ICE50 的ADC模块，使得该模块可以承受最高1.3M赫兹的 ADC 时钟。注意：在这种速度下 ， ADC 不能达到10位的精确度。 ICE50 将拥有10位精度的处理，但是之后可能出错。

在线帮助更新：

  • 根据 ICE50 中的新特性更新

固件版本1.6：

ICE50 固件：

模块 | 软件版本 | 固件版本
Main | 00.2D | 00.04
MMU | 00.17 | 00.0E
OSC | 00.16 | 00.07
AVR | 00.21 |
EVENT | 00.1A | 00.0D
POD | 00.0A | 00.0C
TRACE | 00.10 | 01.03
TS |  | 00.0C

新器件文件修订版：

文件 | 固件版本
Atmega128 | 01.1C
Atmega64 | 01.08
Atmega32 | 01.16
Atmega16 | 01.16
Atmega8 | 01.24
Atmega162 | 01.19
Atmega169 | 02.15
ATtiny26 | 01.1D
Atmega8515 | 01.0F
Atmega8535 | 01.0C

ICE50固件版本v. 1.6更正：

Atmega64:

  • 更正：在没有重新使能 RWW 部分时，从 RWW 部分可以执行代码。

Atmega169.

  • 更正所有 SPM 仿真的熔丝位

Atmega8515, Atmega8535

  • 更正：在16M赫兹情况下单步执行追踪。

Atmega16, Atmega32:

  • 更正IO显示，当单步执行时读出 UBBRH 和 UCSRC 的值。

  • 现在，SPM 临时缓冲区可从 SPM 临时缓冲存储区可读写。

在线帮助更新：

  • 一些印刷上的更正。

固件版本1.5：

新的 ICE50 器件版本

下面是针对 ICE50 发布的新器件：

  • Atmega64

ICE50 固件：

模块 | 软件版本 | 固件版本
Main | 00.2D | 00.04
MMU | 00.17 | 00.0E
OSC | 00.16 | 00.07
AVR | 00.21 |
EVENT | 00.1A | 00.0D
POD | 00.0A | 00.0C
TRACE | 00.10 | 01.03
TS |  | 00.0C

新器件文件修订版：

文件 | 固件版本
Atmega128 | 01.1C
Atmega64 | 01.07
Atmega32 | 01.15
Atmega16 | 01.15
Atmega8 | 01.24
Atmega162 | 01.19
Atmega169 | 02.13
ATtiny26 | 01.1D
Atmega8515 | 01.0E
Atmega8535 | 01.0B

ICE50固件版本v.1.5的新特性：

  • 在所有器件当中增加非法存储区访问检测。请查阅更新文档获取更多信息。

ICE50 固件版本v. 1.5更正：

所有器件带有8×8的乘法器。

  • 在固件版本1.4当中，对于所有器件，硬件乘法器给出错误的结果。现在 ，更正了包含所有8×8位的硬件乘法器。

没有 XRAM 的接口器件：

  • 在固件版本1.4中，当访问那些没有 XRAM 接口器件的 SRAM 地址时，如果超过最大的 EEPROM 地址，非法访问 SRAM 中止将发生。这在本固件版本中更正。

带有引导部分的器件。

  • 现在，除了Atmega32，Atmega16，和 Atmega8535 ，所有的器件的临时缓冲区从 SPM 临时缓冲存储区可读和可写 。

  • 除了Atmega162，SPM仿真现在可以对所有器件保持正确性 (请查阅 疑难解答)。在本版本中适合Atmega64，Atmega32，Atmega16，Atmega162，Atmega8515 和 Atmega8535。完成了下列更正：

    • 在页写入后和在 SPMCR 写入 RWWSE 后擦除 SPM 临时缓冲区。

    • 更正：代码可以从没有重新使能的 RWW 部分执行。

    • 更正：读熔丝位和加密位。

    • 现在，当页写入和页擦除时，能够正确地忽略 SPM 地址的文字部分。

所有器件(EEPROM 写时序)：

  • 现在，已经在全部器件中更正了 EEprom 的写入时间。（EEPROM 写入时间是8MS）

在16M赫兹条件下追踪单步执行指令。

    • 在16M赫兹时钟条件下，单步执行追踪不能保证正确。除了Atmega8515，该部分现在已经全部更正。

Atmega169:

  • 当使用 prescaler 时 ，ADC不能正常工作。该部分现在已经更正。

  • 使能 CKDIV 熔丝位能够提供一个有效的16分频时钟，而不是在数据书册上指定的8分频。该部分现在更正为正确的8分频时钟。

  • 外部校准RC振荡器的频率将降低（500K赫兹而不是1M赫兹）。该部分将在本版本中更正。

ICE50 升级程序：

  • 已经完成了一些升级程序当中的更正和升级，以便使 ICE5 0更加稳定并且提供一个无错的 ICE50 升级。

ICE50 自测程序：

  • 更正了在运行 SRAM 自检发生的错误。

  • 已经完成了一些自测程序当中的更正和升级，以便使 ICE50 更加稳定并且可靠 ，包括上载一些正确的器件来自检。

在线帮助更新：

  • 更新了“ICE50 选项”中的“其他选项”的帮助。

  • 增加了“使用 ICE50 仿真”这一新部分。

  • 增加了“升级与自测”这一新部分。

  • 一些印刷更正。

提示！
AVR Studio 将不断更新版本。请您到 www.atmel.com查阅更新。

请查阅
  • ICE50 仿真器使用说明


Personality Adapter Description

个性化适配器相关说明

ICE50 配套有多种个性化适配器。这些适配器将 ICE50 POD 的引脚连线与它所支持的器件引脚联系起来。 每个适配器都有其独有的认证码，这些认证码供 ICE50 和 AVR Studio 进行自动器件检测时使用。请注意：大多数适配器有两个版本，老版本的适配器顶部有2到4个连接器，适用于.C版本的 Probe 适配器；新版本的适配器顶部是一个大的连接器，适用于.D版本的 Probe。

有关适用于.C版本的 Probe 的老版适配器的描述请查阅 “旧版个性化适配器”。这些老版的适配器已经不再生产了，如果您正使用这些老版本的产品，我们建议您将它们用新版本的产品加以替换。

ICE50 开发包包括下列适配器：

t26 个性化适配器

SNR: A9902.3.1370.B, .D revision of Probe.

m8 个性化适配器

SNR: A9902.3.1390.B, .D revision of Probe.

m128 个性化适配器

SNR: W106355SDF, .D revision of Probe.

SNR: W9844M - Bottom adapter for Atmega128

支持器件类型:

  • ATtiny26

支持器件类型:

  • Atmega8
  • Atmega168
  • Atmega88
  • Atmega48

支持器件类型:

  • Atmega128
  • Atmega64
  • AT90CAN128

t13 个性化适配器

SNR: A9902.3.1430.A, .D revision of Probe

m32 个性化适配器

SNR: A9902.3.1310.B, .D revision of Probe

m162 个性化适配器

SNR: A9902.3.1300.C, .D revision of Probe

支持器件类型:

  • ATtiny13

重要说明:

ATtiny13 并不是 ICE50 套件的一部分，该适配器需单独订购。

支持器件类型:

  • Atmega644
  • Atmega32
  • Atmega16
  • Atmega8535

支持器件类型:

  • Atmega162
  • Atmega8515

m169 个性化适配器

W10634SDF, .D revision of Probe

SNR: W9844M - Bottom adapter for Atmega169

t2313 个性化适配器

SNR: A9902.3.1330B, .D revision of Probe

支持器件类型:

  • Atmega649
  • Atmega329
  • Atmega325
  • Atmega169
  • Atmega165
重要说明:

Atmega169并不是 ICE50 套件的一部分，该适配器需单独订购。

支持器件类型:

  • ATtiny2313

重要说明:

ATtiny2313并不是 ICE50 套件的一部分，该适配器需单独订购。

每一个适配器对应一种引脚输出形式并且支持一种或多种 AVR 微控制器。下表将显示不同个性化适配器所支持的芯片。

器件 | 所用个性化适配器名称：
Atmega128 | m128 (W10635SDF)
AT90CAN128 | m128 (W10635SDF)
Atmega64 | m128 (W10635SDF)
Atmega649 | m169 (W10634SDF)
Atmega32 | m32
Atmega329 | m169 (W10634SDF)
Atmega325 | m169 (W10634SDF)
Atmega16 | m32
Atmega169 | m169 (W10634SDF)
Atmega165 | m169 (W10634SDF)
Atmega168 | m8
Atmega162 | m162
Atmega8 | m8
Atmega88 | m8
Atmega8535 | m32
Atmega8515 | m162
Atmega48 | m8
ATtiny26 | t26
ATtiny13 | t13
ATtiny2313 | t2313

将个性化适配器连接到 Probe

当将个性化适配器和 Probe 连接时，请确保将 Probe 连接到正确的方向上。只有在电路板的方向正确时 ，连接器才能够接入。在个性化适配器上。一个圆圈表示1号引脚。请确保在 Probe 上的圆圈和个性化适配器上的圆圈配合。下面的图片显示了两种版本的 Probe。

A9902.3.1200.C A9902.3.1200.D

t2313个性化适配器

t26 个性化适配器是 PDIP 封装形式的，支持 t2313 器件。标准的20脚0.300宽，PDIP封装形式。如果目标应用 板是另外的封装形式，必须从第三方购买其他适配器。当连接个性化适配器和 Probe时，请确保在 Probe 和个性化适配器上面排列的圆圈相对应，如 上图 所示。

t13个性化适配器

t26 个性化适配器是 PDIP 封装形式的，支持 t13 器件。标准的8脚0.300宽，PDIP封装形式。如果目标应用 板是另外的封装形式，必须从第三方购买其他适配器。当连接个性化适配器和 Probe 时，请确保在 Probe 和个性化适配器上面排列的圆圈相对应，如 上图 所示。

t26个性化适配器

t26 个性化适配器是 PDIP 封装形式的，支持 t26 器件。标准的20脚0.300宽，PDIP 封装形式。 如果目标应用板是另外的封装形式，必须从第三方购买其他适配器。当连接个性化适配器和 Probe时，确定在 Probe 和个性化适配器上面排列的圆圈相对应，如 上图 所示。

m8 个性化适配器

m8 个性化适配器是 PDIP 封装形式的，支持 m8 器件。标准的28脚0.300宽，PDIP 封装形式。 如果目标应用板是另外的封装形式，必须从第三方购买其他适配器。当连接个性化适配器和 Probe时，确定在 Probe 和个性化适配器上面排列的圆圈相对应，如 上图 所示。

m32 个性化适配器

m32 个性化适配器是 PDIP 封装形式的，支持 m32 器件。标准的40脚0.600宽，PDIP 封装形式。 如果目标应用板是另外的封装形式，必须从第三方购买其他适配器。当连接个性化适配和 Probe时，确定在 Probe 和个性化适配器上面排列的圆圈相对应，如 上图 所示。

m162 个性化适配器

m162 个性化适配器是 PDIP 封装形式的，支持 m162 器件。标准的40脚0.600宽，PDIP 封装形式。 如果目标应用板是另外的封装形式，必须从第三方购买其他适配器。当连接个性化适配器和Probe 时，确定在 Probe 和个性化适配器上面排列的圆圈相对应，如 上图 所示。

m128 个性化适配器

m128 个性化适配器是 TQFP64 封装的适配器。并且包括两个模块。底层模块是 TOFP 封装，并且应该在目标板上固化。确保正确的方向。在板上“1”表示1号引脚。一旦底层模块固化在目标应用上，连接上层模块。确 保在上层模块上的1号引脚和底层模块上的1号引脚相匹配。一旦适配器安全地安装好了，将 Probe 放置在个性化适配器上。在 Probe 圆圈应该和 m128 适配器引脚1排列匹配。

m169 个性化适配器

m128 个性化适配器是 TQFP64 封装形式的。并且包括两个模块。底层模块是 TOFP 封装，并且应该在目标板上固化。适用于 Atmega128 和 Atmega169 的适配器的底层模块是相同的。 确保正确的方向。在板上“1”表示1号引脚。一旦底层模块固化在目标应用上，连接上层模块。确定在上层模块上的1号引脚和底层模块上的1号引脚相匹配。

一旦适配器安全地安装好了，将 Probe 放置在个性化适配器上。在 Probe 圆圈应该和 m169 适配器引脚1排列配合。

m169 只能与.E版本的 Probe 配合使用。 单击 这里 获得有关各种 Probe 的描述。

注意!
在改换适配器时，注意不要将个性化适配器的引脚弯曲或折断。仿真器和目标板的电源未关闭之前也不要进行个性化适配器的替换。

提示!
为了避免损坏适配器的引脚，我将个性化适配器安装在一个标准的DIP插座上，这可以延长设配器的寿命。如果引脚弯曲或折断了，只要将插座替换掉就行了！

提示!
如果在目标应用板与个性化适配器之间需要更大的空间，这个DIP插座也可以提供您所需要的距离。注意尽量少使用插座。

请查阅

  • ICE50 仿真器使用说明
  • 主仿真单元
  • POD
  • Probe
  • 个性化适配器


contents

ICE50 资源

ATICE50 包括下列部分：

  • ICE50 主单元/POD/4根 FPC（层柔性印刷电路板）电缆和 Probe
  • 适合的个性化适配器：
    • Atmega128
    • Atmega64 *
    • ATmega32
    • ATmega16 *
    • ATmega162
    • Atmega8
    • Atmega8515 *
    • Atmega8535 *
    • ATtiny26
  • 9芯 RS232C 电缆线
  • USB 电缆线
  • 电源
  • 欧洲标准电源线
  • 美国标准电源线
  • Atmel 产品 CD ROM 包含：
    • AVR 数据书
    • 应用注意
    • AVR Studio 4.00 或更新版本
  • ICE50 快速入门指导
重要注意实项
# 存在各种其他不同的个性化适配器，请查阅 ICE50 订购信息 。

重要注意实项
* 一些器件拥有相同的引脚输出，因此可以使用相同的个性化适配器。请查阅 个性化适配器 获取更多的信息。

提示！
AVR Studio 将不断更新版本。请您到 www.atmel.com查阅更新。

请查阅


features

ICE50 特性

在电路仿真器中的 ICE50 是一款高端仿真器。由 Ateml 公司设计，满足不同 AVR 器件的仿真。ICE50 由 AVR Studio 4.0 或更高版本控制。目前支持下列器件：

  • Atmega2561
  • Atmega128
  • AT90CAN128
  • Atmega64
  • Atmega644
  • Atmega649
  • Atmega32
  • Atmega329
  • Atmega325
  • Atmega16
  • Atmega169
  • Atmega165
  • Atmega168
  • Atmega162
  • Atmega8
  • Atmega88
  • Atmega8515
  • Atmega8535
  • Atmega48
  • ATtiny85
  • ATtiny45
  • ATtiny26
  • ATtiny25
  • ATtiny13
  • ATtiny2313

The ICE50 支持下列特性：

  • 仿真所有的数字和模拟外围器件
  • 目标电压范围2.2伏－5.5伏
  • 受支持所有器件满足所有频率范围
  • 监视
  • 追踪缓冲区
  • 非限制数量的断点数
  • 支持符号调试
  • 访问寄存器文件，SP，PC和存储器的完全可视化
  • 访问所有的IO寄存器
  • IO可以设置为运行或者在中止模式下停止
  • 周期计数器

请查阅


ICE50 ordering information

ICE50 订购信息

ICE50 和独立的 ICE50 器件能够通过 Atmel 单独订购。可以直接或者通过你当地代理商购买。

订购代码 | 产品信息
ATICE50MAIN | 完全的配有标准设置的个性化适配器，电源和电缆的 ICE50
ATICE50POD01 | 带有柔性电缆线，Probe和测试适配器的 ICE50 POD
ATICE50PROBE01 | ICE50 probe
ATICE50MEM01 | ICE50 存储插件模块，该模块增加支持更多的程序存储，最多到128KB。
ATICE50FLEX01 | ICE50 柔性电缆线
ATICE50TMEM01 | ICE50 模块追踪存储区
ATADAPTEST01 | ICE50 测试适配器
ATADAPMEGA128 | 适合Atmega128的个性化适配器 (TOP适配器)
ATADAP64BOT | 适合ATADAPMEGA128 和 ATADAPMEGA169的64 脚 TQFP封装底层适配器
ATADAPMEGA169 | 适合ATmega169 的个性化适配器（top 适配器）
ATADAPMEGA32 | 适合ATmega32 的个性化适配器（DIP 适配器）
ATADAPMEGA162 | 适合ATmega162的个性化适配器（DIP 适配器）
ATADAPMEGA8 | 适合ATmega8 的个性化适配器（DIP 适配器）
ATADAPTINY26 | 适合ATtiny26 的个性化适配器（DIP 适配器）
ATADAPTINY13 | 适合ATtiny13的个性化适配器（DIP 适配器）
ATADAPTINY2313 | 适合ATtiny2313的个性化适配器（DIP 适配器）
ATICE50RS232 | ICE50串口RS232电缆线
ATICE50USB | ICE50 USB 电缆线
ATICE50POWER | ICE50 直流电源

重要注意事项： 许多个性化适配器支持不同器件，请查阅 个性化适配器 描述获取更多的信息。


known issues

疑难解答

该版本疑难解答。

ICE50

ICE50 测试程序：

  • 一些测试可能失败，并且带有下列信息： "Method '~' of object '~' failed"。如果该错误发生，请您通过选择出错的测试重试几次，并且只运行该测试。如果测试现在成功，ICE 将正常工作。该错误信息是由于内部软件 出错。这种错误将在更新版本的 AVR Studio 当中修正。

ICE50 升级程序：

  • 如果任何模块都不能升级，请重复 ICE50 上电并且重复升级过程。如果某个 AVR 器件文件报告程序错误，请您参考 编程FPGA错误 部分中关于疑难解答部分。

时钟振荡器：

  • 外部时钟振荡器只能在3.5－5.5伏电压范围内工作。一旦在 Atmega32 和 Atmega16上外部时钟振荡器不能工作。解决方法：使用内部32KHz时钟振荡器。

外部晶体振荡器：

  • ICE50 probe不支持外部晶体/共鸣器。

小技巧1： 更改配置仿真器，使用内部可编程时钟。XTAL1 引脚将处于三态状态。XTAL2引脚将被使能并且内部可编程时钟在该引脚上驱动输出。请查阅关于如何建立 XTAL2 时钟的特殊部分。

小技巧2： 从目标获取外部时钟，并且使用 ICE50 选项当中的外部时钟选项。

带复位禁止熔丝位的器件：

  • 在 ICE50 POD 的复位引脚上连有一个外部上拉电阻。如果复位禁止熔丝位被编程并且复位引脚被用作IO引脚，该上拉仍然有效。

ADC：

  • 当改变模拟数字转换（ADC）通道时，电荷将从以前的通道转移到被选择的通道。这将导致在 ADC 输入上的噪声影响。在通道转换之后的设置时间也将相应的延长，延长的时间取决于两个通道上电压值的差异。普遍情况下，在新通道第二次采样中，结果正确率在90％以下，第三次采样则全部正确。

在每一个 ADC 通道上放置一个外部电容。电容值尽量大以便使您的应用能够到达需要的带宽。例如：如果您需要1KHz的带宽，并且您的电阻值是1K欧姆，使用该电容值：1/(2譸i譮識)。由上面给定的值计算出大概的电容值是160nF。“f”代表所需的带宽，“R”代表源阻抗值。

  • 所有新AVR器件的内部参考电压是1.1伏，在目前的 ICE50 POD 上不支持该参考电压。一旦选择该参考电压，我们将使用2.5伏参考内部电压。

使用2.5伏参考电压并且在使用 ICE50 调试时参比结果。

  • 如果目标板在 ICE50 之前上电，ADC将被锁定。同样，请在 ICE50 没有上电时，确定在 ADC 输入引脚上没有多余的电压。如果怀疑ADC被锁定（从 ADC 得到错误结果），关掉目标和 ICE 的电源并且执行正确的上电步骤。

  • AT90SCAN128 的最大 ADC 转换时钟大概为900KHz。其他器件的 ADC 最大转换时钟大概是1.3MHz。注意硅型器件在使用普通的ADC转换，时钟超过了250KHz的上限频率时，将达不到10位的转换精度。 ICE50 只能在不超过最大 ADC 转换时钟的条件下到达10位精度。

Atmega169：

LCD：

  • 目前 ICE50 POD 不能仿真模拟的 LCD 波形。当使能 Atmega169 的 LCD 模块时，被使能的段和普通的引脚将输出“空白”波形，即设置段引脚位输出“0”（低电平）。一个LCD插入模块可以通过 Atmel 获取。该模块可以读 LCD 控制寄存器和显示 LCD GUI 模块的 LCD 波形结果。请查阅AVR Studio LCD 模块在线帮助获取更多信息。

ATtiny26:

  • 片内 ATtiny26 的锁相环路（PLL）时钟大概是64MHz，在 ICE50 中是66MHz，并且在 ICE50 当中设置 OSCAL 寄存器对 PLL 时钟不起作用。

ATtiny85/45/25：

  • TCNT1 不能通过 IO显示区写入数据。

  • 在普通模式下 PLL 速度是66MHz而不是 64MHz，得到的时钟可以以此为依据。

  • 在tiny15模式下 PLL 速度是 25MHz 而不是 25.6MHz，得到的时钟可以以此为依据。

提示!
AVR Studio 将不断更新版本。请您到www.atmel.com查阅更新。

请查阅
  • ICE50 仿真器使用说明

报告错误问题

总体上关于AVR Studio的错误问题可以报告到 avr@atmel.com。


What's new

新增功能

下面是一部分新特性的简要总结以及该版本的修正。请查阅 疑难解答 的当前列表。

FW（固件）1.14版本- AVR Studio 4.11 服务包 3。

在服务包1和服务包2当中的更改和修正同样列在此处。

特色

新器件

  • 新增ATtiny25，ATtiny45，ATtiny85的支持（服务包3）

  • 新增Atmega644的支持（服务包1）

ICE50 固件：

模块 | 软件版本 | 固件版本
Main | 00.4D | 00.04
MMU | 00.1F | 00.1F
OSC | 00.21 | 00.10
AVR | 00.2E |
EVENT | 00.1F | 00.18
POD | 00.0D | 00.10
TRACE | 00.19 | 01.51
TS |  | 00.0C

新器件文件修订版：

文件 | 固件版本
Atmega2561 | 01.05
Atmega128 | 01.2A
AT90CAN128 | 00.1E
Atmega64 | 01.18
Atmega644 | 00.04
Atmega649 | 01.0B
Atmega32 | 01.29
Atmega329 | 01.0B
Atmega325 | 01.0B
Atmega16 | 01.29
Atmega162 | 01.28
Atmega169 | 02.2D
Atmega165 | 02.2D
Atmega168 | 01.0F
Atmega8 | 01.37
Atmega88 | 01.0F
Atmega8515 | 01.1C
Atmega8535 | 01.1E
Atmega48 | 01.0F
ATtiny85 | 01.01
ATtiny45 | 01.01
ATtiny26 | 01.2C
ATtiny25 | 01.01
ATtiny13 | 01.1D
ATtiny2313 | 01.02

ICE50固件版本v. 1.14更正：

  • 在升级软件当中更正了一个错误，该错误有时会使ICE50中的RS232接口不可用。（服务包1）

ICE50器件文件版本v. 1.14更正：

  • AT90CAN128：ICE50 的 XRAM 仿真中出现的错误已经被确定并且更正。（服务包3）

  • 针对mega2561，mega48/88/168，tiny2313 和 tiny13 的 EEPROM 擦，写特性已经更正。（服务包3）

  • 针对mega2561，mega48/88/168，tiny2313 和 tiny13 的 EEPROM 暂停工作的错误已经更正。先前 EEPROM 暂停工作只能在第一次使用时执行。现在 EEPROM 暂停工作可以在每一次擦或写的过程中发生。（服务包3）。

  • tiny13，tiny2313，mega48/88/168 和 mega2561 的看门狗中断特性已经被更正。先前在器件复位时，看门狗中断不能执行。现在在器件中看门狗中断可以执行。如果选择“看门狗溢出中断中止”选项，使能看门狗中断将导致看门狗溢出时没有 中止发生。（服务包3）。

  • 更正了Atmega2561中的错误。如果堆栈指针定位在 XRAM 中并且 IN 或 OUT 指令在某个中断之前直接执行，指令将在进入中断时再次被执行。堆栈指针在第二次执行IN/OUT指令后首先被更新。这些错误现在已经更正完成。（服务包3）。

  • 更正了 Atmega644 的追踪结果。

  • 更正了发生在最后 SRAM/XRAM 地址的非法 SRAM 中止。本更正适用于所有的器件。

在线帮助更新：

  • 更新了Atmega644的在线帮助

  • 更新了 ATtiny85，ATtiny45，ATtiny25的在线帮助

提示！
AVR Studio 将不断更新版本。请您到 www.atmel.com查阅更新。

请查阅