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C8051F35x DEVELOPMENT KIT USER’S GUIDE

1. Kit Contents

The C8051F35x Development Kit contains the following items:
C8051F350 Target Board

2. Hardware Setup

Serial Adapter (RS232 to Target Board Debug Interface Protocol Converter)

Silicon Laboratories IDE and Product Information CD-ROM. CD content includes:

e Silicon Laboratories Integrated Development Environment (IDE)
Keil 8051 Development Tools (macro assembler, linker, evaluation ‘C’ compiler)
Installation Utility (SETUP.EXE)

» Source code examples and register definition files

* Documentation

AC to DC Power Adapter

RS232 Serial Cable
7" Ribbon Cable
Quick-start Guide

C8051F35x Development Kit User’s Guide (this document)

The target board is connected to a PC running the Silicon Laboratories IDE via the Serial Adapter as shown in
Figure 1.

1. Connect one end of the RS232 serial cable to a Serial (COM) Port on the PC.

2. Connect the other end of the RS232 serial cable to the DB-9 connector on the Serial Adapter.

3. Connect the Serial Adapter to the DEBUG connector on the target board with the10-pin ribbon cable.
4. Connect the AC/DC power adapter to power jack P1 on the target board.

PC

Serial Port

Serial
Cable

AC/DC
Adapter

Serial

Ribbon Cable

Target Board

Figure 1. Hardware Setup

Note: The Reset switch on the target board is disabled when the serial adapter is connected to the
target board. Use the Reset button in the Silicon Laboratories IDE toolbar to reset the target when

connected to the Serial Adapter.
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3. Software Setup

The included CD-ROM contains the Silicon Laboratories Integrated Development Environment (IDE), Keil software
8051 tools and additional documentation. Insert the CD-ROM into your PC’'s CD-ROM drive. An installer will auto-
matically launch, allowing you to install the IDE software or read documentation by clicking buttons on the Installa-
tion Panel. If the installer does not automatically start when you insert the CD-ROM, run autorun.exe found in the
root directory of the CD-ROM. Refer to the readme.txt file on the CD-ROM for the latest information regarding
known IDE problems and restrictions.

4. Silicon Laboratories Integrated Development Environment

The Silicon Laboratories IDE integrates a source-code editor, source-level debugger and in-system Flash program-
mer. The use of third-party compilers and assemblers is also supported. This development kit includes the Keil
Software A51 macro assembler, BL51 linker and evaluation version C51 ‘C’ compiler. These tools can be used
from within the Silicon Laboratories IDE.

4.1. System Requirements
The Silicon Laboratories IDE requirements:

e Pentium-class host PC running Microsoft Windows 95 or later, or Microsoft Windows NT or later.
e One available COM port.
« 64 MB RAM and 40 MB free HD space recommended.

4.2. Assembler and Linker

A full-version Keil A51 macro assembler and BL51 banking linker are included with the development kit and are
installed during IDE installation. The complete assembler and linker reference manual can be found on-line under
the Help menu in the IDE or in the “SiLabs\MCU\hIp” directory (A51.pdf).

4.3. Evaluation C51 ‘C’ Compiler

An evaluation version of the Keil C51 ‘C’ compiler is included with the development kit and is installed during IDE
installation. The evaluation version of the C51 compiler is the same as the full professional version except code
size is limited to 4 kB and the floating point library is not included. The C51 compiler reference manual can be
found under the Help menu in the IDE or in the “SiLabs\MCU\hIp” directory (C51.pdf).

4.4. Using the Keil Software 8051 Tools with the Silicon Laboratories IDE

To perform source-level debugging with the IDE, you must configure the Keil 8051 tools to generate an absolute
object file in the OMF-51 format with object extensions and debug records enabled. You may build the OMF-51
absolute object file by calling the Keil 8051 tools at the command line (e.g. batch file or make file) or by using the
project manager built into the IDE. The default configuration when using the Silicon Laboratories IDE project
manager enables object extension and debug record generation. Refer to Applications Note AN104 - Integrating
Keil 8051 Tools Into the Silicon Labs IDE in the “SiLabs\MCU\Documentation\Appnotes” directory on the CD-
ROM for additional information on using the Keil 8051 tools with the Silicon Laboratories IDE.

To build an absolute object file using the Silicon Laboratories IDE project manager, you must first create a project. A
project consists of a set of files, IDE configuration, debug views, and a target build configuration (list of files and tool
configurations used as input to the assembler, compiler, and linker when building an output object file).

The following sections illustrate the steps necessary to manually create a project with one or more source files, build
a program and download the program to the target in preparation for debugging. (The IDE will automatically create a
single-file project using the currently open and active source file if you select Build/Make Project before a project is
defined.)
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4.4.1. Creating a New Project

1. Select Project->New Project to open a new project and reset all configuration settings to default.

2. Select File->New File to open an editor window. Create your source file(s) and save the file(s) with a rec-
ognized extension, such as .c, .h, or .asm, to enable color syntax highlighting.

3. Right-click on “New Project” in the Project Window. Select Add files to project. Select files in the file
browser and click Open. Continue adding files until all project files have been added.

4. For each of the files in the Project Window that you want assembled, compiled and linked into the target
build, right-click on the file name and select Add file to build. Each file will be assembled or compiled as
appropriate (based on file extension) and linked into the build of the absolute object file.

Note: If a project contains a large number of files, the “Group” feature of the IDE can be used to organize.
Right-click on “New Project” in the Project Window. Select Add Groups to project. Add pre-defined
groups or add customized groups. Right-click on the group name and choose Add file to group. Select files
to be added. Continue adding files until all project files have been added.

4.4.2. Building and Downloading the Program for Debugging

1. Once all source files have been added to the target build, build the project by clicking on the Build/Make
Project button in the toolbar or selecting Project->Build/Make Project from the menu.

Note: After the project has been built the first time, the Build/Make Project command will only build the
files that have been changed since the previous build. To rebuild all files and project dependencies, click
on the Rebuild All button in the toolbar or select Project->Rebuild All from the menu.

2. CB8051F35x family devices use the Silicon Labs 2-wire (C2) debug interface. You must select C2 in the
Options->Debug Interface menu to enable connection to C8051F35x target devices. Click the Connect
button in the toolbar or select Debug->Connect from the menu to connect to the device.

3. Download the project to the target by clicking the Download Code button in the toolbar.

Note: To enable automatic downloading if the program build is successful select Enable automatic con-
nect/download after build in the Project->Target Build Configuration dialog. If errors occur during the
build process, the IDE will not attempt the download.

4. Save the project when finished with the debug session to preserve the current target build configuration,
editor settings and the location of all open debug views. To save the project, select Project->Save Project
As... from the menu. Create a new name for the project and click on Save.
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5. Example Source Code

Example source code and register definition files are provided in the “SiLabs\MCU\Examples\C8051F35x” directory
during IDE installation. These files may be used as a template for code development. Example applications include
a blinking LED example which configures the green LED on the target board to blink at a fixed rate.

5.1. Register Definition Files

Register definition files C8051F350.inc and C8051F350.h define all SFR registers and bit-addressable control/
status bits. They are installed into the “SiLabs\MCU\Examples\C8051F35x” directory during IDE installation. The
register and bit names are identical to those used in the C8051F35x data sheet. Both register definition files are
also installed in the default search path used by the Keil Software 8051 tools. Therefore, when using the Keil 8051
tools included with the development kit (A51, C51), it is not necessary to copy a register definition file to each
project’s file directory.

5.2. Blinking LED Example

The example source files blink.asm and blinky.c show examples of several basic C8051F35x functions. These
include; disabling the watchdog timer (WDT), configuring the Port I/O crossbar, configuring a timer for an interrupt
routine, initializing the system clock, and configuring a GPIO port. When compiled/assembled and linked this pro-
gram flashes the green LED on the C8051F350 target board about five times a second using the interrupt handler
with a C8051F350 timer.
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6. Target Board

The C8051F35x Development Kit includes a target board with a C8051F350 device pre-installed for evaluation and
preliminary software development. Numerous input/output (I/O) connections are provided to facilitate prototyping
using the target board. Refer to Figure 2 for the locations of the various I/O connectors.

P1 Power connector (accepts input from 7 to 15 VDC unregulated power adapter)
J1 22-pin Expansion 1/O connector

J3 Port I/O Configuration Jumper Block

J4 DEBUG connector for Serial Adapter interface
J5 DB-9 connector for UARTO RS232 interface
J6 Analog I/0 terminal block

J7 Connector for IDACO voltage circuit

J8 Serial Adapter target board power connector
J9,J10 External crystal enable connectors

J11 Connector for IDAC1 voltage circuit

J12 Connector block for Thermistor circuitry

J13, J14 ADC external voltage reference connectors
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Figure 2. C8051F350 Target Board
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6.1. System Clock Sources

The C8051F350 device installed on the target board features a calibrated programmable internal oscillator which is
enabled as the system clock source on reset. After reset, the internal oscillator operates at a frequency of
3.0625 MHz (x2%) by default but may be configured by software to operate at other frequencies. Therefore, in many
applications an external oscillator is not required. However, if you wish to operate the C8051F350 device at a fre-
guency not available with the internal oscillator, an external crystal may be used. Refer to the C8051F35x data sheet
for more information on configuring the system clock source.

The target board is designed to facilitate the installation of an external crystal. Remove shorting blocks at jumpers
J9 and J10 and install the crystal at the pads marked Y1. Install a 10 MQ resistor at R9 and install capacitors at
C14 and C15 using values appropriate for the crystal you select. Refer to the C8051F35x data sheet for more infor-
mation on the use of external oscillators.

6.2. Switches and LEDs

Two switches are provided on the target board. Switch SW1 is connected to the RESET pin of the C8051F350.
Pressing SW1 puts the device into its hardware-reset state. Switch SW2 is connected to the C8051F350’s general
purpose /O (GPIO) pin through jumpers. Pressing SW2 generates a logic low signal on the port pin. Remove the
shorting block from the jumper to disconnect SW2 from the port pins. The port pin signal is also routed to a pin on
the J1 1/O connector. See Table 1 for the port pins and jumpers corresponding to each switch.

Three LEDs are also provided on the target board. The red LED labeled PWR is used to indicate a power connec-
tion to the target board. The green LEDs labeled with port pin names are connected to the C8051F350's GPIO pins
through jumpers. Remove the shorting blocks from the jumpers to disconnect the LEDs from the port pins. The port
pin signals are also routed to pins on the J1 I/O connector. See Table 1 for the port pins and jumpers corresponding
to each LED.

Description I/0 Jumper
SwWi1 Reset none
SW2 P1.0 J3[5-6]

Green LED D2 P0.6 J3[1-2]

Green LED D1 P0.7 J3[3-4]

Red LED PWR none

Table 1. Target Board I/O Descriptions

®
6 Rev. 0.1 @

SILICON LABORATORIES



AN185

6.3. Expansion I/O Connector (J1)

The 34-pin Expansion 1/0 connector J1 provides access to all signal pins of the C8051F350 device. Pins for Vpp and
GND as well as pins for VDDA and AGND are also available. A small through-hole prototyping area is also provided.
All'l/O signals routed to connector J1 are also routed to through-hole connection points between J1 and the prototyp-
ing area (see Figure 2 on page 5). Each connection point is labeled indicating the signal available at the connection
point. See Table 2 for a list of pin descriptions for J1.

Pin #| Description Pin #| Description Pin #| Description
1 Vpp 13 P1.2 25 AIN3
2 GND 14 P1.3 26 AIN4
3 PO.0 15 P1.4 27 AINS
4 PO.1 16 P1.5 28 AING
5 P0.2 17 P1.6/IDACO 29 AIN7
6 PO0.3 18 P1.7/IDAC1 30 VREF+
7 P0.4 19 P2.0 31 IRST
8 P0.5 20 AGND 32 VREF-
9 PO0.6 21 AGND 33 VDDA
10 PO.7 22 AINO 34 AGND
11 P1.0 23 AIN1 - -

P1.1 24 AIN2 - -

Table 2. J1 Pin Descriptions

6.4. Target Board DEBUG Interface (J4)

The DEBUG connector (J4) provides access to the DEBUG (C2) pins of the C8051F350. It is used to connect the
Serial Adapter to the target board for in-circuit debugging and Flash programming. Table 3 shows the DEBUG pin
definitions.

Pin # Description
1 +3 VD (+3.3 VDC)
2,3,9 GND (Ground)
4 C2DAT
5 /IRST (Reset)
6 P3.0
7 C2CK
8 Not Connected
10 J4_Pin_10

Table 3. DEBUG Connector Pin Descriptions
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6.5. Serial Interface (J5)

A RS232 transceiver circuit and DB-9 (J5) connector are provided on the target board to facilitate serial connec-
tions to UARTO of the C8051F350. The TX, RX, RTS and CTS signals of UARTO may be connected to the DB-9
connector and transceiver by installing shorting blocks on jumpers J3.

J3[7-8] - Install shorting block to connect UARTO TX (P0.4) to transceiver.
J3[9-10] - Install shorting block to connect UARTO RX (P0.5) to transceiver.
J3[11-12] - Install shorting block to connect UARTO RTS (P1.4) to transceiver.
J3[13-14] - Install shorting block to connect UARTO CTS (P1.5) to transceiver.

6.6. Analog I/O (J6)

Many of the C8051F350 target device’s port pins are connected to the J6 terminal block. Connections for VDDA,
AGND, ADC external voltage refences, IDAC outputs and ADC inputs are available. Refer to Table 4 for the J6 ter-
minal block connections.

Pin #| Description Pin #| Description
1 IDACO 8 AIN3
2 IDAC1 9 AIN4
3 VREF+ 10 AINS
4 VREF- 11 AING
5 AINO 12 AIN7
6 AIN1 13 AGND
7 AIN2 14 VDDA

Table 4. J6 Terminal Block Pin Descriptions

6.7. IDAC Connectors(J7,J11)

The C8051F350 target board also features two Current-to-Voltage 1 KQ converting resistors that may be con-
nected to the 10-bit current-mode Digital-to-Analog Converters (IDACs) on port pins P1.6 and P1.7. Install a short-
ing block on J7 to connect the IDACO/P1.6 pin of the target device to a converting resistor. Install a second shorting
block on J11 to connect the IDAC1/P1.7 pin of the target device to a converting resistor. The IDAC signals are then
routed to the J1 and J6 connectors.

6.8. Serial Adapter Target Board Power Connector (J8)

The Serial Adapter includes a connection to provide power to the target board. This connection is routed from
J4[10] to J8[1]. Place a shorting block at jumper J8[2-3] to power the board directly from an AC/DC power adapter.
Place a shorting block at jumper J8[1-2] to power the board from the Serial Adapter. Please note that the second
option is not supported with either the EC1 or EC2 Serial Adapters.

6.9. Thermistor Connector Block(J12)

A thermistor circuit is included on the board which allows for a ratiometric measurement of the included thermistor.
To use the circuit, remove the shorting blocks on the IDAC jumpers (J7, J11) and the External Voltage Reference
jumpers (J13, J14). Next, connect all of the signals on the thermistor connector block (J12). Software on the chip
can be written to use IDACO as a reference current source for the circuit. The current creates a voltage across R27
which is used as an external Voltage Reference input, while the voltage across the thermistor (R26) can be mea-
sured by connecting AINO.O to the AIN+ ADC input, and AINO.1 to the AIN- ADC input.
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6.10. External Voltage Reference(J13, J14)

A precision 2.5V Voltage reference source is also included on the C8051F350 target board. To use this circuit as a
reference source for the ADC, place shorting block on jumpers J13 and J14. Note that software on the device
should be configured to use an external reference when using this configuration. When using the internal (on-chip)
reference source, jumpers J13 and J14 should be left open.

7. Serial Adapter

The Serial Adapter provides the interface between the PC’'s RS232 serial port and the C8051F35x’s in-system
debug/programming circuitry. The Serial Adapter connects to the C8051F350 C2 debug interface on the target
board using the 10-pin connector on the Serial Adapter labeled “JTAG”, see Figure 3. (The Serial Adapter supports
both Silicon Laboratories JTAG and C2 debug interfaces.). All Serial Adapters may be powered from the target
board, but the EC1 and EC2 Serial Adapter units cannot provide power to the target board. Table 5 shows the pin
definitions for the Serial Adapter’s JTAG connector.

Notes:
1. When powering the Serial Adapter via the JTAG connector, the input voltage to the JTAG connector’s
power pin must be 3.0 to 3.6 VDC. Otherwise, the Serial Adapter must be powered directly by connecting
the AC/DC adapter to the Serial Adapter’s DC power jack.

2. The Serial Adapter requires a target system clock of 32 Khz or greater.

Pin # Description
1 3.0 to 3.6 VDC Input
2 GND (Ground)
4 TCK (C2DAT)
5 TMS
6 TDO
7 TDI (C2CLK)
3,8,9,10 Not Connected

Table 5. JTAG/DEBUG Connector Pin Descriptions

Oség
= ]
Os X
Serial %)
Adapter @
Q ]
|_
=)

\ \—_Pin 1
Pin 2

Figure 3. Serial Adapter JTAG/DEBUG Connector
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Schematic
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Contact Information

Silicon Laboratories Inc.
4635 Boston Lane

Austin, TX 78735

Tel: 1+(512) 416-8500

Fax: 1+(512) 416-9669

Toll Free: 1+(877) 444-3032

Email: productinfo@silabs.com
Internet: www.silabs.com

The information in this document is believed to be accurate in all respects at the time of publication but is subject to change without notice.
Silicon Laboratories assumes no responsibility for errors and omissions, and disclaims responsibility for any consequences resulting from
the use of information included herein. Additionally, Silicon Laboratories assumes no responsibility for the functioning of undescribed features
or parameters. Silicon Laboratories reserves the right to make changes without further notice. Silicon Laboratories makes no warranty, rep-
resentation or guarantee regarding the suitability of its products for any particular purpose, nor does Silicon Laboratories assume any liability
arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation conse-
quential or incidental damages. Silicon Laboratories products are not designed, intended, or authorized for use in applications intended to
support or sustain life, or for any other application in which the failure of the Silicon Laboratories product could create a situation where per-
sonal injury or death may occur. Should Buyer purchase or use Silicon Laboratories products for any such unintended or unauthorized ap-
plication, Buyer shall indemnify and hold Silicon Laboratories harmless against all claims and damages.

Silicon Laboratories and Silicon Labs are trademarks of Silicon Laboratories Inc.
Other products or brandnames mentioned herein are trademarks or registered trademarks of their respective holders.
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